Ubuntu

Keyboard shortcut overlay says Ctrl+Super+Down "minimises" the current window, but it doesn't

Reported by Rishi Gadhok on 2012-03-27
82
This bug affects 20 people
Affects Status Importance Assigned to Milestone
Ayatana Design
High
John Lea
Compiz
Undecided
MC Return
Unity
High
MC Return
compiz (Ubuntu)
Undecided
Unassigned
unity (Ubuntu)
High
Unassigned

Bug Description

Acoording to the short cut keys lists, ctrl + super + down should restore a window and then minimize.
It does restore from full maximize, but it no longer minimizes the window.
Also, super+ (any arrow key) now also bring up the shortcuts cheat sheet (the one you get when you long hold the super key)
and the only way to make it go away is to tap super twice again.
It is mildly annoying, and I'm pretty sure that's not intended behavior.

-----------------------------------------------------
Desired Solution:

- If the focused window is in the 'restored' state, pressing ctrl + super + down should minimise the window.

- If the focused window is in the 'maximised' state, pressing ctrl + super + down should restore the window.

- See https://docs.google.com/a/canonical.com/document/d/1jqeKtIJwqLtl58Wk_fqjr9Rrgxn9zsouCYOo-cZsLSE/edit for the full list of Unity keyboard shortcuts

Related branches

lp:~mc-return/compiz/compiz.merge-fix966099-add-unmaximize-or-minimize-window-key
Merged into lp:compiz/0.9.9 at revision 3591
Brandon Schaefer: Approve on 2013-02-01
Daniel van Vugt: Needs Fixing on 2013-01-30
PS Jenkins bot: Pending (continuous-integration) requested 2013-02-01
lp:~mc-return/unity/unity.merge-fix966099-shortcut-fails-to-minimize-just-restores
Merged into lp:unity at revision 3102
Didier Roche: Disapprove on 2013-02-04
Brandon Schaefer: Approve on 2013-02-02
PS Jenkins bot: Pending (continuous-integration) requested 2013-02-02
lp:~mc-return/compiz/compiz.merge-fix966099-refresh-quilt-patch.0
Merged into lp:compiz/0.9.9 at revision 3594
Michael Terry: Approve on 2013-02-01
PS Jenkins bot: Pending (continuous-integration) requested 2013-02-01

Thank you for taking the time to report this bug and helping to make Ubuntu better. It seems that your bug report is not filed about a specific source package though, rather it is just filed against Ubuntu in general. It is important that bug reports be filed about source packages so that people interested in the package can find the bugs about it. You can find some hints about determining what package your bug might be about at https://wiki.ubuntu.com/Bugs/FindRightPackage. You might also ask for help in the #ubuntu-bugs irc channel on Freenode.

To change the source package that this bug is filed about visit https://bugs.launchpad.net/ubuntu/+bug/966099/+editstatus and add the package name in the text box next to the word Package.

[This is an automated message. I apologize if it reached you inappropriately; please just reply to this message indicating so.]

tags: added: bot-comment
affects: ubuntu → unity (Ubuntu)

Thank you for your bug report, not sure if it should minimize but those keybinding changed from super to ctrl-super-arrow, doing bottom twice still doesn't minimize though, not sure if that's a bug or a feature

affects: unity (Ubuntu) → compiz-plugins-main (Ubuntu)
Changed in compiz-plugins-main (Ubuntu):
importance: Undecided → Low
status: New → Incomplete
Changed in compiz-grid-plugin:
status: New → Incomplete
importance: Undecided → Low
Rishi Gadhok (rishigadhok) wrote :

It's most definitely a bug. In the Keyboard shortcuts overlay, Ctrl+Super+Down offers the following description
"Restores or minimizes current window"
Current behaviour is in variance with the description. It only Restores the current window.

John Lea (johnlea) on 2012-04-26
summary: - super+down doesn't minize the window anymore. Also
+ ctrl+ super+down doesn't minize the window anymore
description: updated
tags: added: keybinding udp
removed: bot-comment
Changed in ayatana-design:
assignee: nobody → John Lea (johnlea)
importance: Undecided → High
status: New → Confirmed
status: Confirmed → Triaged
Changed in compiz-grid-plugin:
status: Incomplete → Confirmed
Changed in compiz-plugins-main (Ubuntu):
status: Incomplete → Confirmed
Changed in compiz:
importance: Undecided → Low
status: New → Confirmed
John Lea (johnlea) on 2012-08-08
Changed in ayatana-design:
status: Triaged → Fix Committed
Changed in compiz:
status: Confirmed → Triaged
Changed in compiz-grid-plugin:
status: Confirmed → Triaged
Changed in compiz-plugins-main (Ubuntu):
status: Confirmed → Triaged

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in compiz (Ubuntu):
status: New → Confirmed
summary: - ctrl+ super+down doesn't minize the window anymore
+ Keyboard shortcut overlay says Ctrl+Super+Down "minimises" the current
+ window, but it doesn't
affects: compiz → unity
no longer affects: compiz-grid-plugin
affects: compiz (Ubuntu) → unity (Ubuntu)
no longer affects: compiz-plugins-main (Ubuntu)
Jorge Morais (jorgemorais) wrote :

I am affected by this bug, except for the part that says
"Also, super+ (any arrow key) now also bring up the shortcuts cheat sheet (the one you get when you long hold the super key)"
That part does not affect me.

John Lea (johnlea) on 2012-10-02
Changed in unity:
importance: Low → Medium
Changed in unity (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → Medium
John Lea (johnlea) on 2012-10-02
Changed in unity:
importance: Medium → High
Changed in unity (Ubuntu):
importance: Medium → High
Tomáš Karger (tomak) wrote :

I'm also affected by this bug exactly in the same way as jorgepeixotomorais.

MC Return (mc-return) wrote :

I am assigning this bug report to me, so I won't forget - although I am not sure yet how to best fix it...

Changed in unity:
assignee: nobody → MC Return (mc-return)
MC Return (mc-return) on 2013-01-29
Changed in compiz:
status: New → In Progress
assignee: nobody → MC Return (mc-return)
MC Return (mc-return) on 2013-01-29
Changed in unity:
status: Triaged → In Progress
Changed in compiz:
status: In Progress → Fix Committed
Changed in unity:
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package compiz - 1:0.9.9~daily13.02.04-0ubuntu1

---------------
compiz (1:0.9.9~daily13.02.04-0ubuntu1) raring; urgency=low

  [ Marco Trevisan (Treviño) ]
  * Spread - Window glow is incorrectly painted in the screen when
    switching spreaded application (LP: #1109805)

  [ MC Return ]
  * Coverity MISSING_BREAK - CID 12463 (LP: #1101561)
  * Thumbnail plugin: Window title text is rendered into transparency
    and glow/background are too large (LP: #1099100)
  * Showmouse plugin code: Needs cleanup (LP: #1105969)
  * Coverity SECURE_CODING - CID 10019 (LP: #957582)
  * Coverity SECURE_CODING - CID 12511 (LP: #1101605)
  * Coverity SECURE_CODING - CID 12512 (LP: #1101571)
  * Keyboard shortcut overlay says Ctrl+Super+Down "minimises" the
    current window, but it doesn't (LP: #966099)
  * Coverity SECURE_CODING - CID 10020 (LP: #957587)
  * Coverity SECURE_CODING - CID 12529 (LP: #1101641)
  * Coverity MISSING_BREAK - CID 12464 (LP: #1101549)
  * Coverity SECURE_CODING - CID 12519 (LP: #1101565)
  * Coverity SECURE_CODING - CID 12516 (LP: #1101499)
  * [GLES] Showmouse plugin needs port to OpenGL|ES (LP: #1106270)

  [ Automatic PS uploader ]
  * Automatic snapshot from revision 3594
 -- Automatic PS uploader <email address hidden> Mon, 04 Feb 2013 04:01:58 +0000

Changed in compiz (Ubuntu):
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 6.12.0daily13.02.04.1-0ubuntu1

---------------
unity (6.12.0daily13.02.04.1-0ubuntu1) raring; urgency=low

  * debian/control:
    - recommends indicator-sync so it gets installed by default
      (lp: #1053482)
    - recommends indicator-bluetooth as well (lp: #1111314)

  [ Łukasz 'sil2100' Zemczak ]
  * debian/control:
    - bump compiz build-dep due to the last ABI break

  [ Brandon Schaefer ]
  * [regression] Clicking on the indicators when the Dash is open no
    longer closes the Dash. (LP: #1109150)
  * [staging][raring] Dash Maximise/Restore button depends on the
    launcher icon size. (LP: #1101310)

  [ Romain Perier ]
  * The Dash closes when trying to switch to the Command lens (Alt+F2)
    (LP: #1019457)

  [ Marco Trevisan (Treviño) ]
  * Launcher can have smaller size on monitor resolution change (LP:
    #1105382)
  * Dragging down a window from the panel on an external monitor,
    restores it at wrong offset (LP: #1104043)
  * [regression] Alt+Tab/Alt+grave brings other window to the front but
    loses focus entirely. (LP: #1111620)
  * Quicklist items need a way to be ellipsized (LP: #1111471)

  [ Charles Kerr <email address hidden>, Andrea Azzarone ]
  * the GObject subclasses in tests/ don't dispose() properly (LP:
    #986875)

  [ Nicolas d'Offay ]
  * Speed up dash blur (LP: #1102410)

  [ Manuel de la Pena ]
  * API changes to FindKeyFocusArea in the Preview class stops more
    complicated previous fom setting the correct focus (LP: #1102387)

  [ MC Return ]
  * Wrong description in Dconf key
    com.canonical.unity.launcher.favorites (LP: #1112560)
  * Keyboard shortcut overlay says Ctrl+Super+Down "minimises" the
    current window, but it doesn't (LP: #966099)

  [ Andrea Azzarone ]
  * unmounting any gvfs-mounted device from unity menu crashes compiz
    (LP: #1111389)
  * compiz crashed with SIGSEGV in async_wrapper_callback() from
    g_simple_async_result_complete() from
    _g_simple_async_result_complete_with_cancellable() from
    unmount_reply() (LP: #1102926)

  [ Łukasz 'sil2100' Zemczak ]
  * SwitcherControllerImpl autopilot test failures in unity -
    6.12.0daily13.01.29.2-0ubuntu1 (LP: #1109192)

  [ Automatic PS uploader ]
  * Automatic snapshot from revision 3117
 -- Automatic PS uploader <email address hidden> Mon, 04 Feb 2013 09:59:13 +0000

Changed in unity (Ubuntu):
status: Triaged → Fix Released
Stephen M. Webb (bregma) on 2013-02-19
Changed in unity:
status: Fix Committed → Fix Released
John Lea (johnlea) on 2013-06-20
Changed in ayatana-design:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers