Dash home results take too long to appear

Bug #965492 reported by Jono Bacon on 2012-03-26
46
This bug affects 14 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
Medium
Michal Hruby
unity (Ubuntu)
Undecided
Unassigned

Bug Description

When I start Unity and click on the dash (which I suspect many users will do to find their applications, files etc), the home lens displays nothing for a number of seconds which offers a confusing user experience. If the results are unable to be displayed immediately (which would be preferred), some kind of indicator of the results loading should be displayed.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: unity 5.8.0-0ubuntu1
Uname: Linux 3.3.0-030300rc1-generic-pae i686
.tmp.unity.support.test.0:

ApportVersion: 1.95-0ubuntu1
Architecture: i386
CompizPlugins: [core,composite,opengl,compiztoolbox,decor,vpswitch,snap,mousepoll,resize,place,move,wall,grid,regex,imgpng,session,gnomecompat,animation,fade,unitymtgrabhandles,workarounds,scale,expo,ezoom,unityshell]
CompositorRunning: compiz
Date: Mon Mar 26 09:37:36 2012
DistUpgraded: Fresh install
DistroCodename: precise
DistroVariant: ubuntu
DkmsStatus: virtualbox, 4.1.10: added
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Alpha i386 (20120102)
MachineType: LENOVO 7417CTO
PccardctlIdent:
 Socket 0:
   no product info available
PccardctlStatus:
 Socket 0:
   no card
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.3.0-030300rc1-generic-pae root=UUID=312c6990-bc81-4ca1-926b-fd503b7a19dd ro quiet splash vt.handoff=7
SourcePackage: unity
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 11/26/2009
dmi.bios.vendor: LENOVO
dmi.bios.version: 7UET81WW (3.11 )
dmi.board.name: 7417CTO
dmi.board.vendor: LENOVO
dmi.board.version: Not Available
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Not Available
dmi.modalias: dmi:bvnLENOVO:bvr7UET81WW(3.11):bd11/26/2009:svnLENOVO:pn7417CTO:pvrThinkPadT400:rvnLENOVO:rn7417CTO:rvrNotAvailable:cvnLENOVO:ct10:cvrNotAvailable:
dmi.product.name: 7417CTO
dmi.product.version: ThinkPad T400
dmi.sys.vendor: LENOVO
version.compiz: compiz 1:0.9.7.2-0ubuntu1
version.libdrm2: libdrm2 2.4.32-1ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 8.0.2-0ubuntu2
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 8.0.2-0ubuntu2
version.xserver-xorg-core: xserver-xorg-core 2:1.11.4-0ubuntu7
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.7.0-0ubuntu1
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.99~git20111219.aacbd629-0ubuntu2
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.17.0-1ubuntu4
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20111201+b5534a1-1build2

Related branches

Jono Bacon (jonobacon) wrote :
Nekhelesh Ramananthan (nik90) wrote :

Jono Bacon, there is already an indication in the search bar where the icon keeps on rotating until it finishes the search. Isn't that enough? Or do you propose something like a string displayed in the dash?

Also could your experience be related to you are trying this out on virtualbox where the performance is not adequate?

Changed in unity:
status: New → Incomplete
Changed in unity (Ubuntu):
status: New → Incomplete
Jono Bacon (jonobacon) wrote :

I am not talking about searching: I just mean when you first log in and click on the dash it takes quite some time for the icons to appear.

Changed in unity:
status: Incomplete → Opinion
status: Opinion → Confirmed
Changed in unity (Ubuntu):
status: Incomplete → Confirmed
David Barth (dbarth) wrote :

Jono confirmed that he is getting this experience right after logging in, and so I suspect this is due to the deferred loading.
One way to provide feedback to the user without requiring too much change at this stage could be to use the spinning circle in the search field, as an indicator that the system is getting ready.
John: would that be an acceptable solution and consistent with the design guidelines of the dash?

Changed in unity:
status: Confirmed → Incomplete
Changed in unity (Ubuntu):
status: Confirmed → Incomplete
David Barth (dbarth) wrote :

Incomplete, to indicate that a design confirmation is needed at this stage.

Michal Hruby (mhr3) wrote :

John confirmed on IRC that showing the spinner in this case is desirable.

Michal Hruby (mhr3) on 2012-04-04
Changed in unity:
status: Incomplete → In Progress
importance: Undecided → Medium
assignee: nobody → Michal Hruby (mhr3)
milestone: none → 5.10.0
Jono Bacon (jonobacon) wrote :

IS just showing a spinner going to be suitable enough? I think it is still going to appear slugging - someone clicks on the dash icon and nothing appears for four seconds is going to potentially frustrate a lot of users.

Can we make the results appear quicker?

Changed in unity:
status: In Progress → Fix Committed
David Barth (dbarth) wrote :

@jono: loading the real content more quickly would slow down the general startup scenario, whereas the case where the user uses the dash right after start may be considered more rare; the real solution then would be to have a cache to display some meaningful content and then refresh it once the backends are ready. 12.10 feature imo.

Nekhelesh Ramananthan (nik90) wrote :

Marking this bug report as fix released. Further improvement as mentioned by David Barth can be done in a new bug report for 12.10.

Changed in unity (Ubuntu):
status: Incomplete → Fix Committed
Jono Bacon (jonobacon) wrote :

@David - I am not sure I would agree. I think most users (bearing in mind I have done no user testing)...will click the Ubuntu button as soon as they have started their desktop, as that is where they find their apps, files, music, video and other content.

Given that the user should rarely need to boot, I would personally prefer if we take the hit on boot time to deliver a fast dash experience when they click on the button.

Didier Roche (didrocks) on 2012-04-12
Changed in unity:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (9.2 KiB)

This bug was fixed in the package unity - 5.10.0-0ubuntu3

---------------
unity (5.10.0-0ubuntu3) precise-proposed; urgency=low

  [ Oliver Grawert ]
  * Enable subarch specific quilt support
  * add linaros disable_standalone-clients.patch to make unity build with GLES

  [ Didier Roche ]
  * remove a symlink and replace with a real file for
    debian/patches/series.<arch> as not supported in non v3 (and we don't
    want v3 format with full source upstream derived branch)

unity (5.10.0-0ubuntu2) precise-proposed; urgency=low

  [ Ricardo Salveti de Araujo ]
  * Enabling build with OpenGL ES2.0 support for ARM and disable maintainer
     mode on that arch to avoid -Werror failure (LP: #980544)

unity (5.10.0-0ubuntu1) precise-proposed; urgency=low

  * New upstream release:
    - bamfdaemon crashed with SIGABRT in g_assertion_message() (LP: #926208)
    - We are using 1 bad hack for compiz hanging on startup (LP: #963264)
    - GConf backend steals glib events from compiz (LP: #965220)
    - when I closed QupZill brawser it crashed and then and then I sow
      worrning that compiz crashed but fire fox and chrome is estle working.
      gtk-window-decorator crashed with SIGSEGV in max_window_name_width()
      (LP: #948580)
    - compiz crashed with SIGSEGV in std::basic_string<...>::basic_string()
      from unity::launcher::HudLauncherIcon::HudLauncherIcon()::{lambda} from
      unity::UBusManager::OnCallback (LP: #964897)
    - unity-panel-service crashed due to heap corruption in g_free() from
      service_proxy_name_changed() [libindicator/indicator-service-
      manager.c:574] (LP: #969360)
    - Opening dash while an application is maximized makes unity completely
      useless, have to relogin (LP: #975103)
    - unity crash on alt-tab (LP: #975168)
    - Top bar - Menus should be condensed to fit panel/overlay of appmenu
      (LP: #655184)
    - Topbar - window controls for maximised windows in the top bar should
      conform to Fitts's law (LP: #839690)
    - [FFe, UIFe] Dash - When the Dash is open and there is a maximised app in
      the background, the top bar background should not disappear
      (LP: #839480)
    - Dash - The inner bottom left, bottom right and top right corners of the
      desktop dash border are rendered incorrectly (LP: #839476)
    - Showdesktoped window contents invisible in window spread (LP: #877778)
    - Maximized windows can be accidentally closed from wrong monitor.
      (LP: #865701)
    - Unity launcher on-screen corruption on resume from suspend with nVidia
      proprietary driver (LP: #915265)
    - Launcher - Inserting items into launcher makes unnecessary animations on
      other monitors (LP: #925021)
    - Far left character in panel (and launcher popups) distorted
      (LP: #927441)
    - Jenkins build failure: SetAcceptKeyNavFocusOnMouseEnter not declared
      (LP: #938037)
    - super+<unbound key> and sometimes super+<number> keys now cause launch
      to wedge with the key hints shown and retains focus instead of selecting
      the requested window (LP: #934084)
    - three-finger move does not move (Precise) (LP: #940612)
    - compiz crashed with SIGSEGV in std::__de...

Read more...

Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
John Lea (johnlea) on 2012-04-25
no longer affects: ayatana-design
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers