Strange artifacts and other weirdness appeared after recent update

Bug #964910 reported by Jeff Lane on 2012-03-26
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
unity (Ubuntu)
Undecided
Unassigned

Bug Description

I did an update of the 12.04 install on my Thinkpad x201 on Saturday. This pulled in something like 300+ updated packages for Precise. After completing the update, I noticed a couple things immediately regarding X, Unity and the items drawn... there's weird blank spaces or artifacting now that was not there before.

The first thing I noticed is that the panel now has a solid black shadow underneath it that seem to be permanently affixed and it obscures the title bars of any window that is opened or dragged to just beneath the panel. The launcher gets these weird blank spots now where entire sections of the launcher simply disappear when the mouse enters the drawn area.

I also noticed that when I opened a terminal to file this bug, some weird blank spots appeared in the terminal window as it was drawn as well.

None of this was present before updating this system on Saturday, so a recent update to Xorg, Unity or perhaps the intel driver seems to have introduced this problem.

I opened this against Unity but it may need to be re-assigned to the intel driver or xorg in general instead. I really wasn't sure with this one.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: unity 5.8.0-0ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-20.32-generic 3.2.12
Uname: Linux 3.2.0-20-generic x86_64
.tmp.unity.support.test.0:

ApportVersion: 1.95-0ubuntu1
Architecture: amd64
CheckboxSubmission: 071b14b0b6417e4d5dcbbc71f2629e90
CheckboxSystem: bb422ca46d02494cdbc459927a98bc2f
CompizPlugins: [core,bailer,detection,composite,opengl,decor,place,compiztoolbox,mousepoll,grid,snap,move,gnomecompat,wall,vpswitch,regex,session,resize,imgpng,animation,expo,fade,scale,workarounds,ezoom,unitymtgrabhandles,unityshell]
CompositorRunning: compiz
Date: Sun Mar 25 21:07:44 2012
DistUpgraded: 2012-02-17 07:21:08,069 DEBUG enabling apt cron job
DistroCodename: precise
DistroVariant: ubuntu
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release amd64 (20111012)
MachineType: LENOVO 3626R3U
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.2.0-20-generic root=UUID=eefabbf2-c120-4fdd-8963-9c1078d9ef0c ro crashkernel=384M-2G:64M,2G-:128M quiet splash vt.handoff=7
SourcePackage: unity
UpgradeStatus: Upgraded to precise on 2012-02-16 (38 days ago)
dmi.bios.date: 06/07/2010
dmi.bios.vendor: LENOVO
dmi.bios.version: 6QET46WW (1.16 )
dmi.board.name: 3626R3U
dmi.board.vendor: LENOVO
dmi.board.version: Not Available
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Not Available
dmi.modalias: dmi:bvnLENOVO:bvr6QET46WW(1.16):bd06/07/2010:svnLENOVO:pn3626R3U:pvrThinkPadX201:rvnLENOVO:rn3626R3U:rvrNotAvailable:cvnLENOVO:ct10:cvrNotAvailable:
dmi.product.name: 3626R3U
dmi.product.version: ThinkPad X201
dmi.sys.vendor: LENOVO
version.compiz: compiz 1:0.9.7.2-0ubuntu1
version.ia32-libs: ia32-libs 20090808ubuntu35
version.libdrm2: libdrm2 2.4.32-1ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 8.0.2-0ubuntu2
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 8.0.2-0ubuntu2
version.xserver-xorg-core: xserver-xorg-core 2:1.11.4-0ubuntu7
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.7.0-0ubuntu1
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.99~git20111219.aacbd629-0ubuntu2
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.17.0-1ubuntu4
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20111201+b5534a1-1build2

Jeff Lane (bladernr) wrote :
Jeff Lane (bladernr) wrote :

Here is a brief video I shot to demo this issue. First, you'll see the transient blank areas that appear in the launcher (and you may also notice the black shadow under the panel). Then you'll see the weird artifacting that happens when I launch a terminal. The same thing happens when I launch any app and a new window is drawn. Finally, you'll see some artifacting that occurs when I move the terminal around, and also when the popups are drawn for ubuntu-bug as it runs.

Daniel van Vugt (vanvugt) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. This particular bug has already been reported and is a duplicate of bug 963093, so it is being marked as such. Please look at the other bug report to see if there is any missing information that you can provide, or to see if there is a workaround for the bug. Additionally, any further discussion regarding the bug should occur in the other report. Feel free to continue to report any other bugs you may find.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity (Ubuntu):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers