compiz crashed with SIGSEGV in std::basic_string<...>::basic_string() from unity::launcher::HudLauncherIcon::HudLauncherIcon()::{lambda} from unity::UBusManager::OnCallback

Bug #964897 reported by Sean Fitzpatrick on 2012-03-26
216
This bug affects 32 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
Critical
Tim Penhey
unity (Ubuntu)
Critical
Unassigned

Bug Description

Crash occurred while trying to use the HUD in the Software Centre to access Software Sources.

ProblemType: Crash
DistroRelease: Ubuntu 12.04
Package: unity 5.8.0-0ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-20.32-generic 3.2.12
Uname: Linux 3.2.0-20-generic x86_64
NonfreeKernelModules: fglrx
ApportVersion: 1.95-0ubuntu1
Architecture: amd64
Date: Sun Mar 25 17:39:45 2012
ExecutablePath: /usr/bin/compiz
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release amd64 (20111012)
ProcCmdline: compiz
SegvReason: reading unknown VMA
Signal: 11
SourcePackage: unity
Title: compiz crashed with SIGSEGV in std::basic_string<char, std::char_traits<char>, std::allocator<char> >::basic_string()
UpgradeStatus: Upgraded to precise on 2012-03-25 (0 days ago)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Related branches

StacktraceTop:
 _M_grab (__alloc2=<optimized out>, __alloc1=..., this=<optimized out>) at /build/buildd/gcc-4.6-4.6.3/build/x86_64-linux-gnu/libstdc++-v3/include/bits/basic_string.h:224
 std::basic_string<char, std::char_traits<char>, std::allocator<char> >::basic_string (this=0x7fff05f21410, __str=...) at /build/buildd/gcc-4.6-4.6.3/build/x86_64-linux-gnu/libstdc++-v3/include/bits/basic_string.tcc:175
 unity::launcher::HudLauncherIcon::HudLauncherIcon(unity::launcher::LauncherHideMode)::{lambda(_GVariant*)#1}::operator()(_GVariant*) const () at /usr/include/Nux-2.0/NuxCore/Property-inl.h:87
 operator() (_A_a1=@0x7fff05f21468, this=<optimized out>) at /usr/include/sigc++-2.0/sigc++/functors/slot.h:515
 unity::UBusManager::OnCallback (args=0x10ae4a0, user_data=<optimized out>) at /build/buildd/unity-5.8.0/plugins/unityshell/src/UBusWrapper.cpp:67

Changed in unity (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity (Ubuntu):
status: New → Confirmed
William Grant (wgrant) on 2012-03-30
visibility: private → public
summary: compiz crashed with SIGSEGV in std::basic_string<char,
- std::char_traits<char>, std::allocator<char> >::basic_string()
+ std::char_traits<char>, std::allocator<char> >::basic_string() from
+ unity::launcher::HudLauncherIcon::HudLauncherIcon()::{lambda} from
+ unity::UBusManager::OnCallback
Changed in unity:
status: New → Confirmed
summary: - compiz crashed with SIGSEGV in std::basic_string<char,
- std::char_traits<char>, std::allocator<char> >::basic_string() from
- unity::launcher::HudLauncherIcon::HudLauncherIcon()::{lambda} from
+ compiz crashed with SIGSEGV in std::basic_string<...>::basic_string()
+ from unity::launcher::HudLauncherIcon::HudLauncherIcon()::{lambda} from
unity::UBusManager::OnCallback
Changed in unity:
importance: Undecided → High
milestone: none → 5.12.0
milestone: 5.12.0 → 5.10.0
Changed in unity:
importance: High → Critical
Thomi Richards (thomir) wrote :

This was fixed in unity-5.8.0-ubuntu2 package.

Changed in unity:
status: Confirmed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (9.2 KiB)

This bug was fixed in the package unity - 5.10.0-0ubuntu3

---------------
unity (5.10.0-0ubuntu3) precise-proposed; urgency=low

  [ Oliver Grawert ]
  * Enable subarch specific quilt support
  * add linaros disable_standalone-clients.patch to make unity build with GLES

  [ Didier Roche ]
  * remove a symlink and replace with a real file for
    debian/patches/series.<arch> as not supported in non v3 (and we don't
    want v3 format with full source upstream derived branch)

unity (5.10.0-0ubuntu2) precise-proposed; urgency=low

  [ Ricardo Salveti de Araujo ]
  * Enabling build with OpenGL ES2.0 support for ARM and disable maintainer
     mode on that arch to avoid -Werror failure (LP: #980544)

unity (5.10.0-0ubuntu1) precise-proposed; urgency=low

  * New upstream release:
    - bamfdaemon crashed with SIGABRT in g_assertion_message() (LP: #926208)
    - We are using 1 bad hack for compiz hanging on startup (LP: #963264)
    - GConf backend steals glib events from compiz (LP: #965220)
    - when I closed QupZill brawser it crashed and then and then I sow
      worrning that compiz crashed but fire fox and chrome is estle working.
      gtk-window-decorator crashed with SIGSEGV in max_window_name_width()
      (LP: #948580)
    - compiz crashed with SIGSEGV in std::basic_string<...>::basic_string()
      from unity::launcher::HudLauncherIcon::HudLauncherIcon()::{lambda} from
      unity::UBusManager::OnCallback (LP: #964897)
    - unity-panel-service crashed due to heap corruption in g_free() from
      service_proxy_name_changed() [libindicator/indicator-service-
      manager.c:574] (LP: #969360)
    - Opening dash while an application is maximized makes unity completely
      useless, have to relogin (LP: #975103)
    - unity crash on alt-tab (LP: #975168)
    - Top bar - Menus should be condensed to fit panel/overlay of appmenu
      (LP: #655184)
    - Topbar - window controls for maximised windows in the top bar should
      conform to Fitts's law (LP: #839690)
    - [FFe, UIFe] Dash - When the Dash is open and there is a maximised app in
      the background, the top bar background should not disappear
      (LP: #839480)
    - Dash - The inner bottom left, bottom right and top right corners of the
      desktop dash border are rendered incorrectly (LP: #839476)
    - Showdesktoped window contents invisible in window spread (LP: #877778)
    - Maximized windows can be accidentally closed from wrong monitor.
      (LP: #865701)
    - Unity launcher on-screen corruption on resume from suspend with nVidia
      proprietary driver (LP: #915265)
    - Launcher - Inserting items into launcher makes unnecessary animations on
      other monitors (LP: #925021)
    - Far left character in panel (and launcher popups) distorted
      (LP: #927441)
    - Jenkins build failure: SetAcceptKeyNavFocusOnMouseEnter not declared
      (LP: #938037)
    - super+<unbound key> and sometimes super+<number> keys now cause launch
      to wedge with the key hints shown and retains focus instead of selecting
      the requested window (LP: #934084)
    - three-finger move does not move (Precise) (LP: #940612)
    - compiz crashed with SIGSEGV in std::__de...

Read more...

Changed in unity (Ubuntu):
status: Confirmed → Fix Released
Daniel van Vugt (vanvugt) wrote :

No fix was ever committed AFAIK and I just got the same crash in 12.10 with Unity 6.0. So definitely not fixed.

Changed in unity:
status: Fix Released → Confirmed
Changed in unity (Ubuntu):
status: Fix Released → Confirmed
Changed in unity:
milestone: 5.10.0 → 6.2
Daniel van Vugt (vanvugt) wrote :

I know there is always some disagreement as to whether it's appropriate to reopen bugs. For the record, I reopened this one because:
  1. There is no record of a fix ever being committed in Launchpad or the history log of lp:unity; and
  2. The crash continues to happen with Unity 6.0 (bug 1024908).

Omer Akram (om26er) on 2012-07-24
Changed in unity (Ubuntu):
importance: Medium → Critical
Didier Roche (didrocks) on 2012-08-10
Changed in unity:
milestone: 6.2 → 6.4
Tim Penhey (thumper) wrote :

This is a truly horrible stack trace. I can't see how this is failing. I'm going to change the code to not use a lambda in the hope that if this does reoccur, we will have something more reasonable.

Tim Penhey (thumper) on 2012-08-23
Changed in unity:
status: Confirmed → In Progress
assignee: nobody → Tim Penhey (thumper)
Changed in unity:
status: In Progress → Fix Released
Stephen M. Webb (bregma) on 2013-02-17
Changed in unity (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.