compiz crashed with SIGSEGV in g_variant_unref() from unity::launcher::SoftwareCenterLauncherIcon::OnPropertyChanged

Bug #963718 reported by 陈帅 on 2012-03-24
404
This bug affects 70 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
High
Gord Allott
Unity Distro Priority
High
Unassigned
unity (Ubuntu)
High
Unassigned

Bug Description

none

ProblemType: Crash
DistroRelease: Ubuntu 12.04
Package: unity 5.8.0-0ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-20.32-generic-pae 3.2.12
Uname: Linux 3.2.0-20-generic-pae i686
NonfreeKernelModules: nvidia
ApportVersion: 1.95-0ubuntu1
Architecture: i386
CrashCounter: 1
Date: Sat Mar 24 15:20:49 2012
ExecutablePath: /usr/bin/compiz
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Beta i386 (20120301)
ProcCmdline: compiz
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: unity
Title: compiz crashed with SIGSEGV in g_variant_unref()
UpgradeStatus: Upgraded to precise on 2012-03-23 (0 days ago)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo

Related branches

陈帅 (840298390-9) wrote :

StacktraceTop:
 g_variant_unref (value=0xfffffff9) at /build/buildd/glib2.0-2.31.22/./glib/gvariant-core.c:622
 unity::launcher::SoftwareCenterLauncherIcon::OnPropertyChanged (this=0xaeeccb8, params=0xafc604b0) at /build/buildd/unity-5.8.0/plugins/unityshell/src/SoftwareCenterLauncherIcon.cpp:71
 operator() (this=0xa9dc99c, _A_a1=<optimized out>) at /usr/include/sigc++-2.0/sigc++/functors/mem_fun.h:1851
 operator()<_GVariant* const&> (this=0xa9dc998, _A_arg1=<optimized out>) at /usr/include/sigc++-2.0/sigc++/adaptors/adaptor_trait.h:84
 sigc::internal::slot_call1<sigc::bound_mem_functor1<void, unity::launcher::SoftwareCenterLauncherIcon, _GVariant*>, void, _GVariant*>::call_it (rep=0xa9dc980, a_1=@0xbfcfeb70) at /usr/include/sigc++-2.0/sigc++/functors/slot.h:137

Changed in unity (Ubuntu):
importance: Undecided → Medium
tags: removed: need-i386-retrace

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity (Ubuntu):
status: New → Confirmed
tags: added: bugpattern-needed
Didier Roche (didrocks) on 2012-03-26
visibility: private → public
Changed in unity:
status: New → Confirmed
importance: Undecided → High
Changed in unity (Ubuntu):
importance: Medium → High
Changed in unity-distro-priority:
status: New → Fix Committed
importance: Undecided → High
summary: - compiz crashed with SIGSEGV in g_variant_unref()
+ compiz crashed with SIGSEGV in g_variant_unref() from
+ unity::launcher::SoftwareCenterLauncherIcon::OnPropertyChanged
Changed in unity:
milestone: none → 5.10.0
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 5.8.0-0ubuntu2

---------------
unity (5.8.0-0ubuntu2) precise; urgency=low

  * Cherry-picked upstream:
    - fix a crash when software-center is installing an application
      (LP: #963718)
 -- Didier Roche <email address hidden> Mon, 26 Mar 2012 20:19:57 +0200

Changed in unity (Ubuntu):
status: Confirmed → Fix Released
Changed in unity:
status: Confirmed → In Progress
assignee: nobody → Gord Allott (gordallott)
Changed in unity:
status: In Progress → Fix Committed

it lags only in the home lens, the other lenses are working fine
--- On Wed, 3/28/12, Unity Merger <email address hidden> wrote:

From: Unity Merger <email address hidden>
Subject: [Bug 963718] Re: compiz crashed with SIGSEGV in g_variant_unref() from unity::launcher::SoftwareCenterLauncherIcon::OnPropertyChanged
To: <email address hidden>
Date: Wednesday, March 28, 2012, 2:15 PM

** Changed in: unity
       Status: In Progress => Fix Committed

--
You received this bug notification because you are subscribed to a
duplicate bug report (965086).
https://bugs.launchpad.net/bugs/963718

Title:
  compiz crashed with SIGSEGV in g_variant_unref() from
  unity::launcher::SoftwareCenterLauncherIcon::OnPropertyChanged

Status in Unity:
  Fix Committed
Status in Unity Distro Priority:
  Fix Committed
Status in “unity” package in Ubuntu:
  Fix Released

Bug description:
  none

  ProblemType: Crash
  DistroRelease: Ubuntu 12.04
  Package: unity 5.8.0-0ubuntu1
  ProcVersionSignature: Ubuntu 3.2.0-20.32-generic-pae 3.2.12
  Uname: Linux 3.2.0-20-generic-pae i686
  NonfreeKernelModules: nvidia
  ApportVersion: 1.95-0ubuntu1
  Architecture: i386
  CrashCounter: 1
  Date: Sat Mar 24 15:20:49 2012
  ExecutablePath: /usr/bin/compiz
  InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Beta i386 (20120301)
  ProcCmdline: compiz
  SegvReason: reading NULL VMA
  Signal: 11
  SourcePackage: unity
  Title: compiz crashed with SIGSEGV in g_variant_unref()
  UpgradeStatus: Upgraded to precise on 2012-03-23 (0 days ago)
  UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo

To manage notifications about this bug go to:
https://bugs.launchpad.net/unity/+bug/963718/+subscriptions

Didier Roche (didrocks) on 2012-04-12
Changed in unity:
status: Fix Committed → Fix Released
netNurse (subliminal-subotnik) wrote :

Am 12.04.2012 11:23, schrieb Didier Roche:
> ** Changed in: unity
> Status: Fix Committed => Fix Released
>

hallo Didier,

well thanks guys ! ubuntu 12.04 is a awesome one :)

keep going ahead ;)

i have successfuly installed on:

thinkpad t43/t43p ( install fine, works fine :)

thinkpad R52
( coused irritations with the chipset-cooling, system looks broken after
install, couse of overheat !
 the ubuntu seems to adjust alll chipset and cpu settings in bios to
maximum power - system then overheats.
 a readjust to medium powersetting afterinstall did the job.
we had to add some "external-cooling" to gain enugh time to make the
bios new and everything to middle-powersave ;) my vacuum-cleaner did
that job ... LOL
)

thinkpad T520 ( install fine, works fine :)
thinkpad e350 ( install fine, works fine :)

HP -DC7800sff ( works fine )

find the attached foto with the vacuum-cooled R52 as attachment.

regards and all the best

subliminal subotnik

www.subotnik.de

Didier Roche (didrocks) on 2012-04-17
Changed in unity-distro-priority:
status: Fix Committed → Fix Released
To post a comment you must log in.