Ubuntu

Comment 35 for bug 963633

.Compiz v9.0 problem on radeon.

I am using radeon r600g with latest 7.10 git mesa on OpenSuSE 11.3
Also using latest xf86-video-ati driver from git and compiled for myself...
Have linux 2.6.36 vanilla kernel compiled by myself...

I install compiz v9.0 from opensuse's 11.3 repo. After installation I run compiz via "compiz-manager" command than something happen.

I can see background picture. But there is no windows on it. Nothing visible but mouse cursor. Actually when you move mouse, it changes shape at corners of windows. Actually you can resize and move windows but they are just invisible.. I checked compiz output but there is nothing wrong.

After some search I find some errors on my Xorg.0.log. There is multiple lines of this error:

(EE) RADEON(0): [DRI2] DRI2SwapBuffers: bad drawable

So something wrong but don't know what is it actually. I tried with r600 DRI drivers and have same result. It's not related with 3D stack or r600g I think.

Just let you know about the problem...
Thanks.