windows sometimes appear invisible in spread

Bug #963164 reported by Maximilian Federle on 2012-03-23
38
This bug affects 8 people
Affects Status Importance Assigned to Milestone
unity (Ubuntu)
Undecided
Unassigned

Bug Description

After working for a while with frequent window-switching, windows start to display invisible in the spread. Clicking by guessing the invisible windows' positions reveals them again and they are again visible afterwards.

This happens to all sorts of programs that have a few windows open (e.g. Chromium, Nautilus, Gimp...). I can't reproduce this behaviour at will but it is certain to pop up after a while of working with unity.

I have attached a video showing the described problem.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: unity 5.6.0-0ubuntu4
ProcVersionSignature: Ubuntu 3.2.0-20.32~lp961482v1-generic 3.2.12
Uname: Linux 3.2.0-20-generic x86_64
.tmp.unity.support.test.0:

ApportVersion: 1.95-0ubuntu1
Architecture: amd64
CompizPlugins: [core,composite,opengl,compiztoolbox,decor,vpswitch,snap,mousepoll,resize,place,move,wall,grid,regex,imgpng,session,gnomecompat,animation,fade,unitymtgrabhandles,workarounds,scale,expo,ezoom,unityshell]
CompositorRunning: compiz
Date: Fri Mar 23 15:45:40 2012
DistUpgraded: Fresh install
DistroCodename: precise
DistroVariant: ubuntu
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Alpha amd64 (20120309)
MachineType: brunenIT H61M-D2H-USB3
ProcEnviron:
 TERM=xterm
 PATH=(custom, user)
 LANG=de_DE.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.2.0-20-generic root=UUID=215825e9-3387-4f2d-a25d-b8f399d6207f ro quiet splash vt.handoff=7
SourcePackage: unity
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 02/01/2012
dmi.bios.vendor: Award Software International, Inc.
dmi.bios.version: F3
dmi.board.name: H61M-D2H-USB3
dmi.board.vendor: Gigabyte Technology Co., Ltd.
dmi.chassis.type: 3
dmi.chassis.vendor: Gigabyte Technology Co., Ltd.
dmi.modalias: dmi:bvnAwardSoftwareInternational,Inc.:bvrF3:bd02/01/2012:svnbrunenIT:pnH61M-D2H-USB3:pvr:rvnGigabyteTechnologyCo.,Ltd.:rnH61M-D2H-USB3:rvr:cvnGigabyteTechnologyCo.,Ltd.:ct3:cvr:
dmi.product.name: H61M-D2H-USB3
dmi.sys.vendor: brunenIT
version.compiz: compiz 1:0.9.7.0+bzr3035-0ubuntu1
version.ia32-libs: ia32-libs 20090808ubuntu35
version.libdrm2: libdrm2 2.4.32-1ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 8.0.2-0ubuntu2
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 8.0.2-0ubuntu2
version.xserver-xorg-core: xserver-xorg-core 2:1.11.4-0ubuntu7
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.7.0-0ubuntu1
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.99~git20111219.aacbd629-0ubuntu2
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.17.0-1ubuntu4
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20111201+b5534a1-1build2

Maximilian Federle (ppd) wrote :
Maximilian Federle (ppd) wrote :

This doesn't seem to get better with recent updates. As of now, not far from release, ubuntu is not really usable with this bug for anyone doing non-trivial work. (at least on this hardware configuration)

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity (Ubuntu):
status: New → Confirmed
Pablo Almeida (pabloalmeidaff9) wrote :

Same thing happens here. I'm not really sure what causes this, but the program which triggers this the most is Empathy (Especially with the contacts window). And it doesn't seem to get better as updates come.

Pablo Almeida (pabloalmeidaff9) wrote :

Sorry for double posting but I just found a way to reproduce the bug.

Just have an application with multiple windows opened.
Have them both maximized.
Type Super+Ctrl+D to minimize all windows.
Click the previously maximized application icon. This will bring it up front maximized again.
Click the icon again, to alternate to the other window of the same app.

There you go: invisible window.

Maximilian Federle (ppd) wrote :

I can absolutely confirm your way to reproduce this bug. Hopefully this will help pinpointing the problem in compiz/unity.
Hopefully one of the devs will look into this...

Just to make on thing clear: This bug also happens with multiple windows being invisible in spread. Sometimes I have like 10 windows invisible in gimp.

Download full text (3.9 KiB)

Yes, and that's when this bug kills productivity: when you have two
windows, you can just click the empty space, but when you have many,
there's simply no way to know. And you have to click each of them to have
them all visible again.

2012/4/6 Maximilian Federle <email address hidden>

> I can absolutely confirm your way to reproduce this bug. Hopefully this
> will help pinpointing the problem in compiz/unity.
> Hopefully one of the devs will look into this...
>
> Just to make on thing clear: This bug also happens with multiple windows
> being invisible in spread. Sometimes I have like 10 windows invisible in
> gimp.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/963164
>
> Title:
> windows sometimes appear invisible in spread
>
> Status in “unity” package in Ubuntu:
> Confirmed
>
> Bug description:
> After working for a while with frequent window-switching, windows
> start to display invisible in the spread. Clicking by guessing the
> invisible windows' positions reveals them again and they are again
> visible afterwards.
>
> This happens to all sorts of programs that have a few windows open
> (e.g. Chromium, Nautilus, Gimp...). I can't reproduce this behaviour
> at will but it is certain to pop up after a while of working with
> unity.
>
> I have attached a video showing the described problem.
>
> ProblemType: Bug
> DistroRelease: Ubuntu 12.04
> Package: unity 5.6.0-0ubuntu4
> ProcVersionSignature: Ubuntu 3.2.0-20.32~lp961482v1-generic 3.2.12
> Uname: Linux 3.2.0-20-generic x86_64
> .tmp.unity.support.test.0:
>
> ApportVersion: 1.95-0ubuntu1
> Architecture: amd64
> CompizPlugins:
> [core,composite,opengl,compiztoolbox,decor,vpswitch,snap,mousepoll,resize,place,move,wall,grid,regex,imgpng,session,gnomecompat,animation,fade,unitymtgrabhandles,workarounds,scale,expo,ezoom,unityshell]
> CompositorRunning: compiz
> Date: Fri Mar 23 15:45:40 2012
> DistUpgraded: Fresh install
> DistroCodename: precise
> DistroVariant: ubuntu
> InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Alpha amd64
> (20120309)
> MachineType: brunenIT H61M-D2H-USB3
> ProcEnviron:
> TERM=xterm
> PATH=(custom, user)
> LANG=de_DE.UTF-8
> SHELL=/bin/bash
> ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.2.0-20-generic
> root=UUID=215825e9-3387-4f2d-a25d-b8f399d6207f ro quiet splash vt.handoff=7
> SourcePackage: unity
> UpgradeStatus: No upgrade log present (probably fresh install)
> dmi.bios.date: 02/01/2012
> dmi.bios.vendor: Award Software International, Inc.
> dmi.bios.version: F3
> dmi.board.name: H61M-D2H-USB3
> dmi.board.vendor: Gigabyte Technology Co., Ltd.
> dmi.chassis.type: 3
> dmi.chassis.vendor: Gigabyte Technology Co., Ltd.
> dmi.modalias:
> dmi:bvnAwardSoftwareInternational,Inc.:bvrF3:bd02/01/2012:svnbrunenIT:pnH61M-D2H-USB3:pvr:rvnGigabyteTechnologyCo.,Ltd.:rnH61M-D2H-USB3:rvr:cvnGigabyteTechnologyCo.,Ltd.:ct3:cvr:
> dmi.product.name: H61M-D2H-USB3
> dmi.sys.vendor: brunenIT
> version.compiz: compiz 1:0.9.7.0+bzr3035-0ubuntu1
> version.ia32-libs: ia32-libs 20090808ubuntu35
> version.libdrm2: libdrm2 2.4.32-1ubuntu1
> vers...

Read more...

Alan Porter (alan.porter) wrote :

I am seeing the same problem. Right now, I have two windows that are invisible, but that react to the mouse hovering over them. I have one pidgin window and one chromium window in this invisible state.

I can hover my mouse over the pidgin window and the top bar changes to say "Pidgin internet messenger", and I get pop-up status boxes for my buddies. But the actual window is nowhere to be found.

When I hover over the chromium window, the cursor changes whenever it thinks it's over a link, and I can click on the links and the browser loads that page. When I alt-tab, the preview of the window shows that it actually did visit the link. But I can not see the actual window in its normal place.

I do not know of a work-around to get the window to show up again. I have tried (1) alt-tab to the desktop icon (2) alt-F1 to another virtual console and alt-F7 back (3) use the compiz shortcut key to maximize and unmaximize the window (4) use the compiz shortcut to move/resize the window (5) switch to other desktops using ctrl-alt-arrows (6) switch desktops using the compiz expo key.

Interested if others have found a work-around to get the application windows to show up again.

Even more interested in a proper fix.

Alan Porter

Alan Porter (alan.porter) wrote :

A few notes:
- I am running released 12.04, not a development build.
- My video card is AMD/ATI Cedar PRO [Radeon HD 5450].
- The apps that went invisible for me were not necessarily maximized.

Daniel van Vugt (vanvugt) wrote :

Alan, this is a duplicate of a bug that is fix released. If you still experience issues then please put them in a new bug.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers