compiz crashed with SIGSEGV in ObjectPtr() from unity::launcher::Launcher::DesaturateIcons() from unity::launcher::Launcher::OnOverlayShown()

Bug #953963 reported by Aleksander Jerič on 2012-03-13
74
This bug affects 9 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
High
Unassigned
5.0
Incomplete
Undecided
Unassigned
unity (Ubuntu)
Medium
Unassigned

Bug Description

In Compiz config settings manager I've just reenabled Unity plugin when crash happened.

ProblemType: Crash
DistroRelease: Ubuntu 12.04
Package: unity 5.6.0-0ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-18.29-generic 3.2.9
Uname: Linux 3.2.0-18-generic x86_64
ApportVersion: 1.94.1-0ubuntu2
Architecture: amd64
Date: Tue Mar 13 12:53:34 2012
ExecutablePath: /usr/bin/compiz
InstallationMedia: Ubuntu-Server 12.04 LTS "Precise Pangolin" - Alpha amd64 (20120313)
ProcCmdline: compiz
SegvAnalysis:
 Segfault happened at: 0x7fda626982e0 <_ZN5unity8launcher8Launcher15DesaturateIconsEv+48>: mov (%rbx),%rax
 PC (0x7fda626982e0) ok
 source "(%rbx)" (0x00000061) not located in a known VMA region (needed readable region)!
 destination "%rax" ok
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: unity
StacktraceTop:
 unity::launcher::Launcher::DesaturateIcons() () from /usr/lib/compiz/libunityshell.so
 unity::launcher::Launcher::OnOverlayShown(_GVariant*) () from /usr/lib/compiz/libunityshell.so
 unity::UBusManager::OnCallback(_GVariant*, void*) () from /usr/lib/compiz/libunityshell.so
 ?? () from /usr/lib/compiz/libunityshell.so
 g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
Title: compiz crashed with SIGSEGV in unity::launcher::Launcher::DesaturateIcons()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo

Aleksander Jerič (ninjattt) wrote :

StacktraceTop:
 ObjectPtr (other=<optimized out>, this=0x7fff47279a00) at /usr/include/Nux-2.0/NuxCore/ObjectPtr.h:51
 unity::launcher::Launcher::DesaturateIcons (this=<optimized out>) at /build/buildd/unity-5.6.0/plugins/unityshell/src/Launcher.cpp:1273
 unity::launcher::Launcher::OnOverlayShown (this=0x13b1a80, data=0x26db590) at /build/buildd/unity-5.6.0/plugins/unityshell/src/Launcher.cpp:1310
 operator() (_A_a1=@0x7fff47279a78, this=<optimized out>) at /usr/include/sigc++-2.0/sigc++/functors/slot.h:515
 unity::UBusManager::OnCallback (args=0x26db590, user_data=<optimized out>) at /build/buildd/unity-5.6.0/plugins/unityshell/src/UBusWrapper.cpp:67

Changed in unity (Ubuntu):
importance: Undecided → Medium
summary: - compiz crashed with SIGSEGV in
- unity::launcher::Launcher::DesaturateIcons()
+ compiz crashed with SIGSEGV in ObjectPtr()
tags: removed: need-amd64-retrace

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity (Ubuntu):
status: New → Confirmed
Tim Penhey (thumper) on 2012-03-20
visibility: private → public
Changed in unity:
status: New → Triaged
importance: Undecided → High
summary: - compiz crashed with SIGSEGV in ObjectPtr()
+ compiz crashed with SIGSEGV in ObjectPtr() from
+ unity::launcher::Launcher::DesaturateIcons() from
+ unity::launcher::Launcher::OnOverlayShown()
Changed in unity:
milestone: none → 5.12.0
milestone: 5.12.0 → 5.10.0
Didier Roche (didrocks) on 2012-04-12
Changed in unity:
milestone: 5.10.0 → 5.12.0
Changed in unity:
assignee: nobody → Łukasz Zemczak (sil2100)
Łukasz Zemczak (sil2100) wrote :

I seem to get different crashes of compiz in different places when enabling/disabling the unity plugin.

Łukasz Zemczak (sil2100) wrote :

To anyone who could reproduce this problem - do you get the same stacktrace on every crash of the plugin?

Daniel van Vugt (vanvugt) wrote :

Łukasz, all the duplicates seem to suggest the crash happens when toggling plugins in CCSM. Though toggling plugins I'm sure you could trigger some other crashes too.

But it does look like all the duplicates are indeed the same crash. Usually it's due to something being leaked when the unity plugin is closed, and then a callback being called on that leaked object after the plugin was meant to be finished.

Changed in unity:
assignee: Łukasz Zemczak (sil2100) → nobody
Łukasz Zemczak (sil2100) wrote :

I am encountering SIGSEGV crashes, but could not reproduce this particular crash in this particular place. I'll look into why it crashes, but since the reason for it seems to be different, it's not entirely sure if it's the same bug as what I'm encountering (different stack traces and places of crash).

Didier Roche (didrocks) on 2012-04-27
Changed in unity:
milestone: 5.12.0 → 5.14.0

Has anyone been able to reproduce this? I can't get the unity plugin to crash no matter how many times I toggle it off and on.

Changed in unity:
milestone: 5.14.0 → 6.2
Didier Roche (didrocks) on 2012-08-10
Changed in unity:
milestone: 6.2 → 6.4
Changed in unity:
milestone: 6.4 → 6.6
Changed in unity:
milestone: 6.6 → 7.0
Stephen M. Webb (bregma) on 2013-04-04
Changed in unity:
milestone: 7.0.0 → 7.0.1
Changed in unity:
milestone: 7.0.1 → 7.3.1
Changed in unity:
status: Triaged → Fix Released
Changed in unity (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers