Alt+arrows keyboard shortcuts don't invoke Back and Forward navigation

Bug #953783 reported by Ivan Sagalaev on 2012-03-13
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
High
Daniel van Vugt
unity (Ubuntu)
Undecided
Unassigned

Bug Description

TESTCASE:

1. Open a gnome-terminal.
2. While holding Alt, tap arrow keys: Up, Down, Right, Left
3. Verify the terminal shows the keycodes were received as text "ABCD".

ORIGINAL DESCRIPTION:
Summary summarizes it all. Noticed after the latest bunch of updates.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: firefox 11.0~b7+build1-0ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-18.29-generic 3.2.9
Uname: Linux 3.2.0-18-generic x86_64
AddonCompatCheckDisabled: False
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
ApportVersion: 1.94.1-0ubuntu2
Architecture: amd64
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: STAC92xx Analog [STAC92xx Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC1: maniac 1593 F.... pulseaudio
 /dev/snd/controlC0: maniac 1593 F.... pulseaudio
BuildID: 20120309125033
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xc4500000 irq 46'
   Mixer name : 'IDT 92HD81B1X5'
   Components : 'HDA:111d7605,103c1436,00100402'
   Controls : 17
   Simple ctrls : 10
Card1.Amixer.info:
 Card hw:1 'Generic'/'HD-Audio Generic at 0xc4420000 irq 48'
   Mixer name : 'ATI R6xx HDMI'
   Components : 'HDA:1002aa01,00aa0100,00100200'
   Controls : 6
   Simple ctrls : 1
Card1.Amixer.values:
 Simple mixer control 'IEC958',0
   Capabilities: pswitch pswitch-joined penum
   Playback channels: Mono
   Mono: Playback [on]
Channel: beta
Date: Tue Mar 13 00:31:51 2012
ForcedLayersAccel: False
IfupdownConfig:
 auto lo
 iface lo inet loopback
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release amd64 (20111012)
IpRoute:
 default via 192.168.1.1 dev wlan0 proto static
 169.254.0.0/16 dev wlan0 scope link metric 1000
 192.168.1.0/24 dev wlan0 proto kernel scope link src 192.168.1.3 metric 2
Profiles: Profile0 (Default) - LastVersion=11.0/20120309125033 (Running)
RfKill:
 0: phy0: Wireless LAN
  Soft blocked: no
  Hard blocked: no
RunningIncompatibleAddons: False
SourcePackage: firefox
UpgradeStatus: Upgraded to precise on 2012-03-01 (11 days ago)
dmi.bios.date: 12/01/2011
dmi.bios.vendor: Hewlett-Packard
dmi.bios.version: F.26
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: 1436
dmi.board.vendor: Hewlett-Packard
dmi.board.version: 59.24
dmi.chassis.asset.tag: CNU112103Y
dmi.chassis.type: 10
dmi.chassis.vendor: Hewlett-Packard
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnHewlett-Packard:bvrF.26:bd12/01/2011:svnHewlett-Packard:pnHPENVY14NotebookPC:pvr058D120000241910001620100:rvnHewlett-Packard:rn1436:rvr59.24:cvnHewlett-Packard:ct10:cvrChassisVersion:
dmi.product.name: HP ENVY 14 Notebook PC
dmi.product.version: 058D120000241910001620100
dmi.sys.vendor: Hewlett-Packard

Related branches

Ivan Sagalaev (isagalaev) wrote :
Ivan Sagalaev (isagalaev) wrote :

Additional info.

It started to work again after some minutes. Perhaps it's related to a crash that has happened somewhere in the HUD department. I understand that I'm poking a black box here but I think this is related because HUD is activated by Alt. May be it was catching it early somehow…

Didier Roche (didrocks) on 2012-03-13
affects: firefox (Ubuntu) → unity (Ubuntu)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 5.6.0-0ubuntu2

---------------
unity (5.6.0-0ubuntu2) precise; urgency=low

  * debian/patches/01_remove_ungrab_workaround.patch:
    - remove a workaround which makes alt + keys not passing events to other
      apps (LP: #953783)
  * debian/control:
    - add libxfixes build-dep (versionned as there is an ABI break). No cmake
      file was listing it, will fix that upstream as well. ubuntu4 of libxfixes
      need an unity rebuild to avoid not being able to trigger launcher reveal
      (LP: #953778)
 -- Didier Roche <email address hidden> Tue, 13 Mar 2012 12:35:47 +0100

Changed in unity (Ubuntu):
status: New → Fix Released
Didier Roche (didrocks) on 2012-03-13
Changed in unity:
status: New → Triaged
importance: Undecided → High
assignee: nobody → Didier Roche (didrocks)
milestone: none → 5.8.0
Changed in unity:
status: Triaged → In Progress
Daniel van Vugt (vanvugt) wrote :

Confirmed. I can reproduce this now (briefly). And the bug goes away while the unityshell plugin is disabled. It seems like the issue is possibly the global menu creating an active grab. Though the bug went away completely when I restarted the unityshell plugin !?

description: updated
Daniel van Vugt (vanvugt) wrote :

Didier, this is still not fixed in unity 5.6.0-0ubuntu3

I think we need to look for grabs in the panel menu code... And re-check the Alt callback in unityshell.

Didier Roche (didrocks) wrote :

@Daniel: it's working for me and some other folks in the french forum. Pitti noticed that it didn't work for him though, so yeah, there is clearly another thing going on.

Changed in unity:
assignee: Didier Roche (didrocks) → nobody
Changed in unity:
assignee: nobody → Daniel van Vugt (vanvugt)
Changed in unity:
status: In Progress → Fix Committed
Ivan Sagalaev (isagalaev) wrote :

Works for me now with unity 5.6.0-0ubuntu4.
Thanks!

Didier Roche (didrocks) on 2012-03-23
Changed in unity:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers