launcher can not be revealed using mouse

Bug #953778 reported by Martin Mrazik on 2012-03-13
24
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
High
Unassigned
unity (Ubuntu)
High
Unassigned

Bug Description

This happened after dist-upgrade this morning.
I'm unable to reveal launcher using mouse any more. No matter how hard I try, launcher just doesn't show up.
The only way how to access the applications is keyboard which is extremely inconvenient (when I press the super key, dashboard together with the launcher show up so I can workaround it this way).

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: unity 5.6.0-0ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-18.29-generic-pae 3.2.9
Uname: Linux 3.2.0-18-generic-pae i686
ApportVersion: 1.94.1-0ubuntu2
Architecture: i386
CompizPlugins: [core,bailer,detection,composite,opengl,compiztoolbox,decor,resize,snap,regex,vpswitch,imgpng,unitymtgrabhandles,gnomecompat,place,mousepoll,animation,grid,move,session,workarounds,expo,wall,ezoom,fade,scale,unityshell]
Date: Tue Mar 13 08:23:33 2012
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release i386 (20111012)
SourcePackage: unity
UpgradeStatus: Upgraded to precise on 2012-02-17 (24 days ago)

Revision history for this message
Martin Mrazik (mrazik) wrote :
Revision history for this message
Martin Mrazik (mrazik) wrote :

I can not reproduce any more and I'm not exactly sure what happened.
I tried the following:
- using "dpkg -i --force-downgrade" in /var/cache/apt/archive I tried to downgrade to unity_5.4.0+bzr2065ubuntu0
- after the downgrade I logged out/in and I was still able to reproduce the but
- gave up and run dist-upgrade again to go back to 5.6
- had to manually resolve some dependency issues (for some reasons libunity, unity-common were upgraded but unity couldn't because of some dependencies on the 5.4.0+bzr2065)
- logged out/in and it works now :-/

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity (Ubuntu):
status: New → Confirmed
Revision history for this message
Simeon (simeon5) wrote :

i can reproduce this.

Revision history for this message
Jean-Baptiste Lallement (jibel) wrote :

Confirmed after upgrade to unity 5.6

I ran "unity --reset" and set auto-hide in 'appearance/behavior' then the launcher doesn't reveal with the trackpad, the sensitivity doesn't change the behavior.

Changed in unity (Ubuntu):
importance: Undecided → High
Revision history for this message
Jean-Baptiste Lallement (jibel) wrote :

I'm using libxfixes 1:5.0-4ubuntu2

tags: added: qa-manual-testing
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 5.6.0-0ubuntu2

---------------
unity (5.6.0-0ubuntu2) precise; urgency=low

  * debian/patches/01_remove_ungrab_workaround.patch:
    - remove a workaround which makes alt + keys not passing events to other
      apps (LP: #953783)
  * debian/control:
    - add libxfixes build-dep (versionned as there is an ABI break). No cmake
      file was listing it, will fix that upstream as well. ubuntu4 of libxfixes
      need an unity rebuild to avoid not being able to trigger launcher reveal
      (LP: #953778)
 -- Didier Roche <email address hidden> Tue, 13 Mar 2012 12:35:47 +0100

Changed in unity (Ubuntu):
status: Confirmed → Fix Released
Changed in unity:
importance: Undecided → High
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers