compiz crashed with SIGSEGV in std::__detail::_List_node_base::_M_hook() from unity::ui::PointerBarrierWrapper::EmitCurrentData

Bug #944217 reported by Nick Moffitt on 2012-03-01
86
This bug affects 15 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
High
Andrea Azzarone
Unity Distro Priority
High
Unassigned
unity (Ubuntu)
High
Andrea Azzarone

Bug Description

Compiz crashed hard after I unplugged an external monitor.

ProblemType: Crash
DistroRelease: Ubuntu 12.04
Package: unity 5.4.0-0ubuntu2
ProcVersionSignature: Ubuntu 3.2.0-17.27-generic 3.2.6
Uname: Linux 3.2.0-17-generic x86_64
ApportVersion: 1.93-0ubuntu2
Architecture: amd64
Date: Thu Mar 1 18:23:44 2012
EcryptfsInUse: Yes
ExecutablePath: /usr/bin/compiz
ProcCmdline: compiz
ProcEnviron:
 PATH=(custom, user)
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
SegvAnalysis:
 Segfault happened at: 0x7f36ff1aa433 <_ZNSt8__detail15_List_node_base7_M_hookEPS0_+19>: mov %rdi,(%rax)
 PC (0x7f36ff1aa433) ok
 source "%rdi" ok
 destination "(%rax)" (0x00000440) not located in a known VMA region (needed writable region)!
SegvReason: writing NULL VMA
Signal: 11
SourcePackage: unity
StacktraceTop:
 std::__detail::_List_node_base::_M_hook(std::__detail::_List_node_base*) () from /usr/lib/x86_64-linux-gnu/libstdc++.so.6
 unity::ui::PointerBarrierWrapper::EmitCurrentData() () from /usr/lib/compiz/libunityshell.so
 ?? () from /usr/lib/compiz/libunityshell.so
 ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
 g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
Title: compiz crashed with SIGSEGV in std::__detail::_List_node_base::_M_hook()
UpgradeStatus: Upgraded to precise on 2012-02-22 (8 days ago)
UserGroups: adm admin cdrom dialout libvirtd lpadmin plugdev sambashare staff

Related branches

lp:~azzar1/unity/fix-944217
Thomi Richards (community): Approve on 2012-03-27
Nick Moffitt (nick-moffitt) wrote :

This crash has the same stack trace characteristics as bug #863534. However, the latter was already fixed in an earlier package version than the one in this report. This might be a regression or because the problem is in a dependent package.

tags: added: regression-retracer

StacktraceTop:
 std::__detail::_List_node_base::_M_hook (this=0x46f9e10, __position=0x3f1d318) at ../../../../src/libstdc++-v3/src/list.cc:129
 emplace<sigc::slot_base> (__position=<optimized out>, this=<optimized out>) at /usr/include/c++/4.6/bits/list.tcc:92
 insert (__x=..., __position=<optimized out>, this=<optimized out>) at /usr/include/c++/4.6/bits/stl_list.h:1062
 temp_slot_list (slots=<optimized out>, this=0x7fffab7089e0) at /usr/include/sigc++-2.0/sigc++/signal_base.h:183
 emit (_A_a2=..., _A_a1=@0x7fffab708a08, impl=<optimized out>) at /usr/include/sigc++-2.0/sigc++/signal.h:1246

Changed in unity (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity (Ubuntu):
status: New → Confirmed
Didier Roche (didrocks) on 2012-03-13
visibility: private → public
Changed in unity-distro-priority:
status: New → Fix Committed
importance: Undecided → High
Changed in unity:
importance: Undecided → High
Changed in unity (Ubuntu):
importance: Medium → High
Changed in unity:
status: New → Confirmed
Blümchen Blau (bluemchen-blau) wrote :

Happened with:
~$ uname -a
Linux PQMC-12 3.2.0-18-generic-pae #29-Ubuntu SMP Mon Mar 12 00:42:23 UTC 2012 i686 i686 i386 GNU/Linux

on a

-Computer-
Processor : 4x Intel(R) Core(TM) i7-2640M CPU @ 2.80GHz
Memory : 8153MB (895MB used)
Operating System : Ubuntu precise (development branch)
Date/Time : Die 13 Mär 2012 16:30:29 CET
-Display-
Resolution : 1366x768 pixels
OpenGL Renderer : Unknown
X11 Vendor : The X.Org Foundation
-Multimedia-
Audio Adapter : HDA-Intel - HDA Intel PCH
Audio Adapter : ThinkPad EC - ThinkPad Console Audio Control
-Input Devices-
 Lid Switch
 Sleep Button
 Power Button
 AT Translated Set 2 keyboard
 Logitech USB Receiver
 Logitech USB Receiver
 Video Bus
 ThinkPad Extra Buttons
 Integrated Camera
 HDA Intel PCH HDMI/DP,pcm : 8=
 HDA Intel PCH HDMI/DP,pcm : 7=
 HDA Intel PCH HDMI/DP,pcm : 3=
 SynPS/2 Synaptics TouchPad
 TPPS/2 IBM TrackPoint
 ThinkPad HDAPS joystick emulation
 ThinkPad HDAPS accelerometer data
-Printers (CUPS)-
...
-SCSI Disks-
ATA ST320LT007-9ZV14
MATSHITA DVD-RAM UJ8A2
Generic USB SD Reader
Generic USB MS Reader

tags: added: rls-p-tracking
summary: - compiz crashed with SIGSEGV in
- std::__detail::_List_node_base::_M_hook().
+ compiz crashed with SIGSEGV in std::__detail::_List_node_base::_M_hook()
+ from unity::ui::PointerBarrierWrapper::EmitCurrentData
Andrea Azzarone (azzar1) on 2012-03-27
Changed in unity:
assignee: nobody → Andrea Azzarone (andyrock)
milestone: none → 5.10.0
Changed in unity (Ubuntu):
assignee: nobody → Andrea Azzarone (andyrock)
Changed in unity:
status: Confirmed → In Progress
Changed in unity (Ubuntu):
status: Confirmed → In Progress
Tim Penhey (thumper) on 2012-03-28
Changed in unity:
status: In Progress → Fix Committed
Andrea Azzarone (azzar1) on 2012-03-28
Changed in unity (Ubuntu):
status: In Progress → Fix Committed
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu laptop testing tracker.

A list of all reports related to this bug can be found here:
http://laptop.qa.ubuntu.com/qatracker/reports/bugs/944217

tags: added: laptop-testing
Didier Roche (didrocks) on 2012-04-12
Changed in unity:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (9.2 KiB)

This bug was fixed in the package unity - 5.10.0-0ubuntu3

---------------
unity (5.10.0-0ubuntu3) precise-proposed; urgency=low

  [ Oliver Grawert ]
  * Enable subarch specific quilt support
  * add linaros disable_standalone-clients.patch to make unity build with GLES

  [ Didier Roche ]
  * remove a symlink and replace with a real file for
    debian/patches/series.<arch> as not supported in non v3 (and we don't
    want v3 format with full source upstream derived branch)

unity (5.10.0-0ubuntu2) precise-proposed; urgency=low

  [ Ricardo Salveti de Araujo ]
  * Enabling build with OpenGL ES2.0 support for ARM and disable maintainer
     mode on that arch to avoid -Werror failure (LP: #980544)

unity (5.10.0-0ubuntu1) precise-proposed; urgency=low

  * New upstream release:
    - bamfdaemon crashed with SIGABRT in g_assertion_message() (LP: #926208)
    - We are using 1 bad hack for compiz hanging on startup (LP: #963264)
    - GConf backend steals glib events from compiz (LP: #965220)
    - when I closed QupZill brawser it crashed and then and then I sow
      worrning that compiz crashed but fire fox and chrome is estle working.
      gtk-window-decorator crashed with SIGSEGV in max_window_name_width()
      (LP: #948580)
    - compiz crashed with SIGSEGV in std::basic_string<...>::basic_string()
      from unity::launcher::HudLauncherIcon::HudLauncherIcon()::{lambda} from
      unity::UBusManager::OnCallback (LP: #964897)
    - unity-panel-service crashed due to heap corruption in g_free() from
      service_proxy_name_changed() [libindicator/indicator-service-
      manager.c:574] (LP: #969360)
    - Opening dash while an application is maximized makes unity completely
      useless, have to relogin (LP: #975103)
    - unity crash on alt-tab (LP: #975168)
    - Top bar - Menus should be condensed to fit panel/overlay of appmenu
      (LP: #655184)
    - Topbar - window controls for maximised windows in the top bar should
      conform to Fitts's law (LP: #839690)
    - [FFe, UIFe] Dash - When the Dash is open and there is a maximised app in
      the background, the top bar background should not disappear
      (LP: #839480)
    - Dash - The inner bottom left, bottom right and top right corners of the
      desktop dash border are rendered incorrectly (LP: #839476)
    - Showdesktoped window contents invisible in window spread (LP: #877778)
    - Maximized windows can be accidentally closed from wrong monitor.
      (LP: #865701)
    - Unity launcher on-screen corruption on resume from suspend with nVidia
      proprietary driver (LP: #915265)
    - Launcher - Inserting items into launcher makes unnecessary animations on
      other monitors (LP: #925021)
    - Far left character in panel (and launcher popups) distorted
      (LP: #927441)
    - Jenkins build failure: SetAcceptKeyNavFocusOnMouseEnter not declared
      (LP: #938037)
    - super+<unbound key> and sometimes super+<number> keys now cause launch
      to wedge with the key hints shown and retains focus instead of selecting
      the requested window (LP: #934084)
    - three-finger move does not move (Precise) (LP: #940612)
    - compiz crashed with SIGSEGV in std::__de...

Read more...

Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
Didier Roche (didrocks) on 2012-04-24
Changed in unity-distro-priority:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers