[unity 5.6] holding alt and pressing a direction opens the alt-tab list in a buggy way

Bug #943902 reported by Sebastien Bacher on 2012-03-01
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Unity
Fix Released
High
Jason Smith
Unity Distro Priority
High
Unassigned
unity (Ubuntu)
High
Unassigned

Bug Description

Using unity-5.6:

* press alt for a bit of time (it needs to be hold for a bit)
* use an arrow (left, right) while alt is still pressed

the alt-tab ui displays -> it shouldn't display (no tab pressed),
-> and it doesn't close once you stop pressing either

Related branches

summary: - [unity 5.6] holding alt and pressing a direction open the alt-tab list
+ [unity 5.6] holding alt and pressing a direction opens the alt-tab list
in a buggy way
Didier Roche (didrocks) wrote :

Confirming here, it's a regression from 5.4, doesn't happen in precise stack.

Changed in unity (Ubuntu):
status: New → Fix Committed
status: Fix Committed → Triaged
description: updated
Changed in unity:
status: New → Triaged
importance: Undecided → High
Changed in unity (Ubuntu):
importance: Undecided → High
Changed in unity:
milestone: none → 5.6.0
Changed in unity-distro-priority:
status: New → Fix Committed
importance: Undecided → High
Mirco Müller (macslow) on 2012-03-02
Changed in unity:
assignee: nobody → Mirco Müller (macslow)
Neil J. Patel (njpatel) wrote :

It doesn't happen in Chromium, but does happen in other programs, seems like the keypress is falling through to the alt+tab switcher.

Mirco Müller (macslow) on 2012-03-02
Changed in unity:
status: Triaged → In Progress
Mirco Müller (macslow) on 2012-03-02
Changed in unity:
status: In Progress → Triaged
assignee: Mirco Müller (macslow) → nobody
Sebastien Bacher (seb128) wrote :

Undupping, the other bug is on compiz, has a different fix and is not the one mentioned in the merge proposal here, it's easier to keep open that bug which has been used for the tracking

Tim Penhey (thumper) on 2012-03-04
Changed in unity:
assignee: nobody → Jason Smith (jassmith)
status: Triaged → Fix Committed
Didier Roche (didrocks) on 2012-03-12
Changed in unity:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (4.1 KiB)

This bug was fixed in the package unity - 5.6.0-0ubuntu1

---------------
unity (5.6.0-0ubuntu1) precise; urgency=low

  * New upstream release.
    - compiz crashed with SIGSEGV in g_type_check_instance_cast()
      (LP: #862972)
    - compiz crashed with SIGABRT in __gnu_cxx::__verbose_terminate_handler()
      (LP: #926793)
    - compiz crashed with SIGSEGV in gdk_pixbuf_get_width() (LP: #937421)
    - Unity causes ibus to not work correctly (spaces incorrectly placed)
      (LP: #880876)
    - Dash - update Dash keyboard shortcuts so the 'CTRL + TAB' switches
      between Lenses and 'TAB' by itself moves the focus between categories
      (LP: #891648)
    - HUD - closing a window with <Alt>+<F4> opens the hud (LP: #923410)
    - unity-applications-daemon crashed with SIGSEGV in
      dee_sequence_model_free_row() (LP: #916356)
    - Launcher, Window Management - Launcher reveal should not be triggered
      when dragging a window (LP: #928805)
    - lenses are loaded on start, should be lazy loaded (LP: #929506)
    - Trash icon jumps about when trying to drag an icon onto it (LP: #932365)
    - HUD loses keypresses for the first second after opening (LP: #932906)
    - HUD doesn't give the focus back to the active application after dash/hud
      use (LP: #934061)
    - Launcher - unpinned apps show with empty pips in the launcher as if they
      exist on another workspace (LP: #937898)
    - Unity Dash should support Keywords parameter in .desktop (formerly X
      -GNOME-Keywords or X-AppInstall-Keywords) (LP: #941231)
    - Support FD.o Desktop Actions spec (LP: #942042)
    - Unity hangs when touching my touchpad/trackpad (LP: #942625)
    - [regression] Pressing alt doesn't show the menu title bar in top panel
      (LP: #943194)
    - Alt + F (or other mnemonic) doesn't work in gnome-terminal (LP: #943239)
    - [unity 5.6] Using Alt+F1 or Alt+F2 sends a ";3P" or ";3Q" to the active
      windows (LP: #943456)
    - [unity 5.6] holding alt and pressing a direction opens the alt-tab list
      in a buggy way (LP: #943902)
    - [unity-5.6] can't enter accents (^o->) in the dash since recent updates
      (LP: #944674)
    - Dash - Keyboard navigation for search filters is broken (LP: #844033)
    - Dash - If mouse highlights one icon in grid, keyboard navigation
      highlights another, so there are 2 highlighted icons (LP: #817436)
    - Alt+Tab default delay of 150ms is too long (LP: #888636)
    - Keyboard shortcut - F10 shortcut is used to show menu and this is wrong
      (LP: #878492)
    - Dash - Currently the app lens doesn't show applications that are
      available for purchase (LP: #916121)
    - Chromium is running, but not showing in launcher or alt-tab.
      (LP: #918474)
    - Dash - Different states of rating stars, and dimensions (LP: #924884)
    - alt-tab confused by a multiple instances of an application on different
      workspaces (LP: #925484)
    - Launcher - Icons are not colorized properly (LP: #930949)
    - Remove glow from Alt-tab edge and Search Field image assets
      (LP: #933578)
    - "Left Mouse Drag" and "Middle Mouse Drag" should be translatable
      (LP: #930510)
    - Launcher switcher...

Read more...

Changed in unity (Ubuntu):
status: Triaged → Fix Released
Tim Penhey (thumper) on 2012-03-14
Changed in unity-distro-priority:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers