compiz crashed with SIGSEGV in unity::dash::ResultView::~ResultView() from unity::dash::ResultViewGrid::~ResultViewGrid() from nux::Object::Destroy() from nux::Object::UnReference()

Bug #942286 reported by cliff tinker on 2012-02-27
46
This bug affects 7 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
High
Brandon Schaefer
unity (Ubuntu)
High
Unassigned
Precise
High
Unassigned

Bug Description

SRU testcase

1. install unity from precise-proposed
2. make sure unity does not crash while enabling/disabling a plugin in CCSM

crashes evry time i change the settings

ProblemType: Crash
DistroRelease: Ubuntu 12.04
Package: libnux-2.0-0 2.4.0-0ubuntu2
ProcVersionSignature: Ubuntu 3.2.0-17.27-generic 3.2.6
Uname: Linux 3.2.0-17-generic x86_64
NonfreeKernelModules: fglrx
ApportVersion: 1.93-0ubuntu2
Architecture: amd64
CrashCounter: 1
Date: Mon Feb 27 22:23:49 2012
ExecutablePath: /usr/bin/compiz
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Alpha amd64 (20120201.2)
ProcCmdline: compiz
ProcEnviron:
 LANGUAGE=en_GB:en
 PATH=(custom, no user)
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
SegvAnalysis:
 Segfault happened at: 0x7fcbefbb026e: mov %r12,0x10(%rcx)
 PC (0x7fcbefbb026e) ok
 source "%r12" ok
 destination "0x10(%rcx)" (0x300000b0002e914) not located in a known VMA region (needed writable region)!
SegvReason: writing unknown VMA
Signal: 11
SourcePackage: nux
StacktraceTop:
 unity::dash::ResultView::~ResultView() () from /usr/lib/compiz/libunityshell.so
 unity::dash::ResultViewGrid::~ResultViewGrid() () from /usr/lib/compiz/libunityshell.so
 unity::dash::ResultViewGrid::~ResultViewGrid() () from /usr/lib/compiz/libunityshell.so
 nux::Object::Destroy() () from /usr/lib/libnux-core-2.0.so.0
 nux::Object::UnReference() () from /usr/lib/libnux-core-2.0.so.0
Title: compiz crashed with SIGSEGV in unity::dash::ResultView::~ResultView()
UpgradeStatus: Upgraded to precise on 2012-02-26 (1 days ago)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo

Related branches

cliff tinker (cliff5555) wrote :

StacktraceTop:
 unity::dash::ResultView::~ResultView (this=0x2127d20, __in_chrg=<optimized out>) at /build/buildd/unity-5.4.0/plugins/unityshell/src/ResultView.cpp:72
 unity::dash::ResultViewGrid::~ResultViewGrid (this=0x2127d20, __in_chrg=<optimized out>) at /build/buildd/unity-5.4.0/plugins/unityshell/src/ResultViewGrid.cpp:107
 unity::dash::ResultViewGrid::~ResultViewGrid (this=0x2127d20, __in_chrg=<optimized out>) at /build/buildd/unity-5.4.0/plugins/unityshell/src/ResultViewGrid.cpp:110
 nux::Object::Destroy (this=0x2127d20) at ./Object.cpp:338
 nux::Object::UnReference (this=0x2127d20) at ./Object.cpp:299

Changed in nux (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in nux (Ubuntu):
status: New → Confirmed
visibility: private → public
summary: compiz crashed with SIGSEGV in unity::dash::ResultView::~ResultView()
+ from unity::dash::ResultViewGrid::~ResultViewGrid() from
+ nux::Object::Destroy() from nux::Object::UnReference()
affects: nux (Ubuntu) → unity (Ubuntu)
Changed in unity:
status: New → Confirmed
importance: Undecided → High
Changed in unity (Ubuntu):
importance: Medium → High
Changed in unity:
milestone: none → 5.12.0
Changed in unity:
assignee: nobody → Brandon Schaefer (brandontschaefer)
Changed in unity (Ubuntu):
status: Confirmed → Fix Committed
Changed in unity:
status: Confirmed → Fix Committed
Omer Akram (om26er) on 2012-04-26
description: updated
Omer Akram (om26er) on 2012-04-26
Changed in unity (Ubuntu Precise):
status: Fix Committed → Confirmed
Didier Roche (didrocks) on 2012-04-27
Changed in unity:
status: Fix Committed → Fix Released

Hello cliff, or anyone else affected,

Accepted unity into precise-proposed. The package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in unity (Ubuntu Precise):
status: Confirmed → Fix Committed
tags: added: verification-needed

since applying the update CCSM occasionally freezes when enabling a
plug-in and will crash the desktop I can still get to a console (ttty3)
where I have tried restarting lightdm and restarting the X-server and
compiz, sometimes sudo restart lightdm does get the desktop going again,
but usually I have to sudo reboot.
After rebooting the plugin seems to work but when I try to enable or
disable anything it freezes again and I end up having to reboot again.
so mixed results so far
Cliff Tinker
--
John Clifford Tinker

On Thu, 2012-04-26 at 09:55 +0000, Omer Akram wrote:

> ** Description changed:
>
> + SRU testcase
> +
> + 1. install unity from precise-proposed
> + 2. make sure unity does not crash while enabling/disabling a plugin in CCSM
> +
> crashes evry time i change the settings
>
> ProblemType: Crash
> DistroRelease: Ubuntu 12.04
> Package: libnux-2.0-0 2.4.0-0ubuntu2
> ProcVersionSignature: Ubuntu 3.2.0-17.27-generic 3.2.6
> Uname: Linux 3.2.0-17-generic x86_64
> NonfreeKernelModules: fglrx
> ApportVersion: 1.93-0ubuntu2
> Architecture: amd64
> CrashCounter: 1
> Date: Mon Feb 27 22:23:49 2012
> ExecutablePath: /usr/bin/compiz
> InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Alpha amd64 (20120201.2)
> ProcCmdline: compiz
> ProcEnviron:
> - LANGUAGE=en_GB:en
> - PATH=(custom, no user)
> - LANG=en_GB.UTF-8
> - SHELL=/bin/bash
> + LANGUAGE=en_GB:en
> + PATH=(custom, no user)
> + LANG=en_GB.UTF-8
> + SHELL=/bin/bash
> SegvAnalysis:
> - Segfault happened at: 0x7fcbefbb026e: mov %r12,0x10(%rcx)
> - PC (0x7fcbefbb026e) ok
> - source "%r12" ok
> - destination "0x10(%rcx)" (0x300000b0002e914) not located in a known VMA region (needed writable region)!
> + Segfault happened at: 0x7fcbefbb026e: mov %r12,0x10(%rcx)
> + PC (0x7fcbefbb026e) ok
> + source "%r12" ok
> + destination "0x10(%rcx)" (0x300000b0002e914) not located in a known VMA region (needed writable region)!
> SegvReason: writing unknown VMA
> Signal: 11
> SourcePackage: nux
> StacktraceTop:
> - unity::dash::ResultView::~ResultView() () from /usr/lib/compiz/libunityshell.so
> - unity::dash::ResultViewGrid::~ResultViewGrid() () from /usr/lib/compiz/libunityshell.so
> - unity::dash::ResultViewGrid::~ResultViewGrid() () from /usr/lib/compiz/libunityshell.so
> - nux::Object::Destroy() () from /usr/lib/libnux-core-2.0.so.0
> - nux::Object::UnReference() () from /usr/lib/libnux-core-2.0.so.0
> + unity::dash::ResultView::~ResultView() () from /usr/lib/compiz/libunityshell.so
> + unity::dash::ResultViewGrid::~ResultViewGrid() () from /usr/lib/compiz/libunityshell.so
> + unity::dash::ResultViewGrid::~ResultViewGrid() () from /usr/lib/compiz/libunityshell.so
> + nux::Object::Destroy() () from /usr/lib/libnux-core-2.0.so.0
> + nux::Object::UnReference() () from /usr/lib/libnux-core-2.0.so.0
> Title: compiz crashed with SIGSEGV in unity::dash::ResultView::~ResultView()
> UpgradeStatus: Upgraded to precise on 2012-02-26 (1 days ago)
> UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
>
> ** Also affects: unity (Ubuntu Precise)
> Importance: High
> Status: Fix Committed
>

Launchpad Janitor (janitor) wrote :
Download full text (6.0 KiB)

This bug was fixed in the package unity - 5.12-0ubuntu1

---------------
unity (5.12-0ubuntu1) precise-proposed; urgency=low

  * New upstream release.
    - Launcher, Alt-Tab - clicking on launcher item or selecting a app in Alt-
      Tab raises all app windows, not just most recently focused (LP: #959339)
    - [heap corruption?] compiz crashed with SIGSEGV in _int_malloc() from
      g_realloc() from ... from g_dbus_connection_send_message_with_reply()
      from g_object_unref() from unity::dash::HomeLens::Impl::~Impl() from
      unity::dash::HomeLens::~HomeLens() (LP: #931201)
    - compiz crashed with SIGSEGV in _int_malloc() from __libc_calloc() from
      XOpenDisplay() from nux::WindowThread::ThreadCtor() (LP: #947844)
    - Regression: Installing apps causes a terrible visual glitch-- have to
      restart X.org. (LP: #981168)
    - Window management - unity doesn't realise when applications bring their
      windows to the front (LP: #802816)
    - Dash - Clicking on the desktop dash border should do nothing, *NOT*
      close the dash (LP: #839472)
    - [FFe, UIFe] HUD - The HUD does not respect launcher icon size settings
      in autohide mode (LP: #921506)
    - compiz crashed with SIGSEGV in g_volume_get_mount() (LP: #918548)
    - multiple instances or double icons of application detected on bamfdaemon
      respawn (LP: #928912)
    - Panel is transparent when Dash is open; no blur no average BG color
      (LP: #965323)
    - Unity crashes with SIGSEGV when hitting debug DBus interface hard
      (LP: #979429)
    - compiz crashed with SIGSEGV in _int_malloc() from g_object_unref() from
      unity::dash::Model<unity::dash::FilterAdaptor>::~Model() (LP: #941750)
    - indicators menu are sometimes cut off at screen edge (LP: #883317)
    - the shortcut keys in workspace section of the shortcut overlay aren't
      translated (LP: #980828)
    - [regression] Dash keeps repainting unnecessarily (LP: #980924)
    - compiz crashed with SIGSEGV in nux::NTextureData::ClearData() from
      nux::NTextureData::~NTextureData() from nux::Texture2D::~Texture2D()
      (LP: #952378)
    - compiz crashed with SIGSEGV in g_object_unref() from
      unity::dash::Settings::~Settings() from
      unity::UnityScreen::~UnityScreen() (LP: #981764)
    - compiz crashed with SIGSEGV in unity::dash::ResultView::~ResultView()
      from unity::dash::ResultViewGrid::~ResultViewGrid() from
      nux::Object::Destroy() from nux::Object::UnReference() (LP: #942286)
    - compiz crashed with SIGSEGV in
      ends_with_iter_select<__gnu_cxx::__normal_iterator<char const*,
      std::basic_string<char> >, char const*, boost::algorithm::is_iequal>()
      from unity::ui::PointerBarrierWrapper::EmitCurrentData() (LP: #983268)
    - Chinese can't be shown completely in dash filter (LP: #984583)
    - [Unity 5.10] compiz crashed with SIGSEGV in
      unity::hud::HudIconTextureSource::ColorForIcon() from
      unity::hud::Icon::Icon() from emit from unity::IconTexture::IconLoaded
      (LP: #983646)
    - [regression] Close button does not close the dash/HUD (LP: #986264)
    - compiz crashed with SIGSEGV in g_volume_eject_with_operation_finish()
      fro...

Read more...

Changed in unity (Ubuntu):
status: Confirmed → Fix Released
Changed in unity (Ubuntu Precise):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers