Ubuntu

Alt-Tab switcher doesn't show LibreOffice windows

Reported by Jussi Lind on 2012-02-27
120
This bug affects 26 people
Affects Status Importance Assigned to Milestone
Unity
High
Unassigned
unity (Ubuntu)
Undecided
Unassigned

Bug Description

Steps to Reproduce:
1. Open any document by double clicking it in Nautilus.
2. Try switching between some applications
3. Then switch to Libreoffice Writer

What happens:
You will notice that the file is correctly opened in Libreoffice Writer or any other libreoffice corresponding program. However the icon shown in the launcher, alt-tab switcher is the generic libreoffice started icon and not the specific libreoffice writer icon. On trying to switch to writer, it cannot be selected. In fact pressing the icon on the launcher does not also switch to libreoffice.

What should happen:
The switcher and launcher show first the correct icon. Also it should be possible to switch to the libreoffice window.

Please note that this does not happen if you open writer first, and then open the file using the open dialog. This only happens when you open the file from nautilus which then launches libreoffice.

---- Original Description ---
Steps to reproduce:
1) Log out & log in again
2) Open some windows e.g. software center, browser
3) Open LibreOffice Calc
4) Try to switch to the LibreOffice window by using Alt-Tab

What happened:
The switcher doesn't show the LibreOffice window at all and it cannot be selected. There's also something random in this, I can reproduce 7/10.

Expected:
The switcher shows the LibreOffice window and it can be selected.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: unity 5.4.0-0ubuntu2
ProcVersionSignature: Ubuntu 3.2.0-17.27-generic 3.2.6
Uname: Linux 3.2.0-17-generic i686
NonfreeKernelModules: nvidia
.proc.driver.nvidia.gpus.0: Error: [Errno 21] Is a directory: '/proc/driver/nvidia/gpus/0'
.proc.driver.nvidia.registry: Binary: ""
.proc.driver.nvidia.version:
 NVRM version: NVIDIA UNIX x86 Kernel Module 295.20 Mon Feb 6 20:25:38 PST 2012
 GCC version: gcc version 4.6.2 (Ubuntu/Linaro 4.6.2-16ubuntu1)
.tmp.unity.support.test.0:

ApportVersion: 1.93-0ubuntu2
Architecture: i386
CompizPlugins: [core,bailer,detection,composite,opengl,decor,compiztoolbox,mousepoll,snap,copytex,resize,vpswitch,move,place,workarounds,wall,imgpng,fade,grid,regex,unitymtgrabhandles,gnomecompat,session,expo,ezoom,scale,unityshell]
CompositorRunning: compiz
Date: Mon Feb 27 22:24:57 2012
DistUpgraded: Log time: 2012-02-26 21:56:29.995317
DistroCodename: precise
DistroVariant: ubuntu
DkmsStatus:
 nvidia-current, 295.20, 3.0.0-16-generic, i686: installed
 nvidia-current, 295.20, 3.2.0-17-generic, i686: installed
 virtualbox, 4.1.8, 3.0.0-16-generic, i686: installed
 virtualbox, 4.1.8, 3.2.0-17-generic, i686: installed
GraphicsCard:
 NVIDIA Corporation GT218 [GeForce 210] [10de:0a65] (rev a2) (prog-if 00 [VGA controller])
   Subsystem: eVga.com. Corp. Device [3842:1313]
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release i386 (20091028.5)
JockeyStatus:
 xorg:nvidia_current - NVIDIA accelerated graphics driver (Proprietary, Enabled, In use)
 xorg:nvidia_current_updates - NVIDIA accelerated graphics driver (post-release updates) (Proprietary, Disabled, Not in use)
MachineType: System manufacturer P5QL PRO
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.2.0-17-generic root=UUID=3291f5c1-36ad-4d87-ae23-b0a666e24b0b ro splash quiet splash vt.handoff=7
SourcePackage: unity
UpgradeStatus: Upgraded to precise on 2012-02-26 (0 days ago)
dmi.bios.date: 07/01/2009
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 1004
dmi.board.asset.tag: To Be Filled By O.E.M.
dmi.board.name: P5QL PRO
dmi.board.vendor: ASUSTeK Computer INC.
dmi.board.version: Rev 1.xx
dmi.chassis.asset.tag: Asset-1234567890
dmi.chassis.type: 3
dmi.chassis.vendor: Chassis Manufacture
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr1004:bd07/01/2009:svnSystemmanufacturer:pnP5QLPRO:pvrSystemVersion:rvnASUSTeKComputerINC.:rnP5QLPRO:rvrRev1.xx:cvnChassisManufacture:ct3:cvrChassisVersion:
dmi.product.name: P5QL PRO
dmi.product.version: System Version
dmi.sys.vendor: System manufacturer
version.compiz: compiz 1:0.9.7.0~bzr2995-0ubuntu5
version.libdrm2: libdrm2 2.4.30-1ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 8.0.1-0ubuntu2
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 8.0.1-0ubuntu2
version.nvidia-graphics-drivers: nvidia-graphics-drivers N/A
version.xserver-xorg-core: xserver-xorg-core 2:1.11.4-0ubuntu4
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.6.99.901+git20120126-0ubuntu2
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.99~git20111219.aacbd629-0ubuntu2
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.17.0-1ubuntu4
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20111201+b5534a1-1build2

Jussi Lind (jussi-lind) wrote :
Jussi Lind (jussi-lind) on 2012-02-27
description: updated
Bilal Akhtar (bilalakhtar) wrote :

This is probably a duplicate of another bug involving the same behavior with Gedit, but I can't find it now...

Binho RbSoft (binhorbsoft) wrote :

This bug report is not a duplicate of bug #875835! They are very different! The duplicate status is wrong!

For this: "The switcher doesn't show the LibreOffice window at all and it cannot be selected." I did this:

Logout, then log back in again using Unity 2D, then log back out and back in with 3D. The problem was solved for me.

Source: http://askubuntu.com/questions/66802/why-doesnt-the-libreoffice-icon-appear-on-my-launcher-when-running

Daniel van Vugt (vanvugt) wrote :

This is probably the same root cause as bug 899120.

Changed in unity:
milestone: none → 5.14.0
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity (Ubuntu):
status: New → Confirmed
Omer Akram (om26er) wrote :

Just tried the steps you provided with unity 5.12-0ubuntu1.1 so I believe the issue might have got with the latest of BAMF and unity. Can you please re-test and let us know of the situation.

Changed in unity:
status: New → Incomplete
Changed in unity (Ubuntu):
status: Confirmed → Incomplete
Volker Prior (volker-prior) wrote :

I can confirm as well the buggy behaviour (Ubuntu 12.04 64bit) as the proposed solution (log in using Unity 2D, log out and log in again using Unity 3D).

Changed in unity:
milestone: 5.14.0 → 5.16.0
Nekhelesh Ramananthan (nik90) wrote :

I can reproduce this bug in Unity 5.14Ubuntu1. Hence marking confirmed. I have also updated the description to reproduce this bug consistently.

Changed in unity:
status: Incomplete → Confirmed
Changed in unity (Ubuntu):
status: Incomplete → Confirmed
description: updated
description: updated
Changed in unity:
milestone: 5.16.0 → 5.18.0
Changed in unity:
importance: Undecided → High
Timo Jyrinki (timo-jyrinki) wrote :

There was a recent BAMF fix in bug 1026426 for 12.10 that should be backported to 12.04 LTS as well.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers