compiz crashed with SIGSEGV in _int_malloc() from g_object_unref() from unity::dash::Model<unity::dash::FilterAdaptor>::~Model()

Bug #941750 reported by Nick Payne on 2012-02-27
102
This bug affects 12 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
High
Brandon Schaefer
unity (Ubuntu)
High
Unassigned
Precise
High
Unassigned

Bug Description

SRU testcase

1. install Unity from precise-proposed
2. make sure unity does not crash while enabling/disabling a plugin from CCSM

Trying to set wobbly windows

ProblemType: Crash
DistroRelease: Ubuntu 12.04
Package: libnux-2.0-0 2.4.0-0ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-17.27-generic 3.2.6
Uname: Linux 3.2.0-17-generic x86_64
ApportVersion: 1.93-0ubuntu2
Architecture: amd64
CrashCounter: 1
Date: Mon Feb 27 15:07:01 2012
ExecutablePath: /usr/bin/compiz
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Alpha amd64 (20120216)
ProcCmdline: compiz
ProcEnviron:
 LANGUAGE=en_AU:en
 PATH=(custom, no user)
 LANG=en_AU.UTF-8
 SHELL=/bin/bash
SegvAnalysis:
 Segfault happened at: 0x7f122651a21b: mov %r14,0x10(%rsi)
 PC (0x7f122651a21b) ok
 source "%r14" ok
 destination "0x10(%rsi)" (0x200000b00025d14) not located in a known VMA region (needed writable region)!
SegvReason: writing unknown VMA
Signal: 11
SourcePackage: nux
StacktraceTop:
 ?? () from /lib/x86_64-linux-gnu/libc.so.6
 calloc () from /lib/x86_64-linux-gnu/libc.so.6
 g_malloc0 () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
 g_object_new_valist () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
 g_object_new () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
Title: compiz crashed with SIGSEGV in calloc()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo

Related branches

Nick Payne (nick-payne) wrote :

StacktraceTop:
 _int_malloc (av=0x7f1226850720, bytes=512) at malloc.c:3667
 __libc_calloc (n=<optimized out>, elem_size=<optimized out>) at malloc.c:3274
 g_malloc0 (n_bytes=<optimized out>) at /build/buildd/glib2.0-2.31.18/./glib/gmem.c:189
 g_object_new_valist (object_type=139715353309824, first_property_name=0x7f1220e63a03 "data", var_args=0x7fff3e88e918) at /build/buildd/glib2.0-2.31.18/./gobject/gobject.c:1793
 g_object_new (object_type=139715353309824, first_property_name=0x7f1220e63a03 "data") at /build/buildd/glib2.0-2.31.18/./gobject/gobject.c:1545

Changed in compiz (Ubuntu):
importance: Undecided → Medium
summary: - compiz crashed with SIGSEGV in calloc()
+ compiz crashed with SIGSEGV in _int_malloc()
tags: removed: need-amd64-retrace

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in compiz (Ubuntu):
status: New → Confirmed
Daniel van Vugt (vanvugt) wrote :

This bug is similar to bug 931201. Both of which are under finiPlugin (plugin list changing).

summary: - compiz crashed with SIGSEGV in _int_malloc()
+ compiz crashed with SIGSEGV in _int_malloc() from g_object_unref() from
+ unity::dash::Model<unity::dash::FilterAdaptor>::~Model()
visibility: private → public
affects: compiz (Ubuntu) → unity (Ubuntu)
Changed in unity:
status: New → Confirmed
milestone: none → 5.12.0
importance: Undecided → Medium
tags: added: bugpattern-needed
Changed in unity:
assignee: nobody → Brandon Schaefer (brandontschaefer)
Changed in unity:
status: Confirmed → Fix Committed
Changed in unity:
importance: Medium → High
Changed in unity (Ubuntu):
importance: Medium → High
Omer Akram (om26er) on 2012-04-26
description: updated
Didier Roche (didrocks) on 2012-04-27
Changed in unity:
status: Fix Committed → Fix Released

Hello Nick, or anyone else affected,

Accepted unity into precise-proposed. The package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in unity (Ubuntu Precise):
status: Confirmed → Fix Committed
tags: added: verification-needed
Launchpad Janitor (janitor) wrote :
Download full text (6.0 KiB)

This bug was fixed in the package unity - 5.12-0ubuntu1

---------------
unity (5.12-0ubuntu1) precise-proposed; urgency=low

  * New upstream release.
    - Launcher, Alt-Tab - clicking on launcher item or selecting a app in Alt-
      Tab raises all app windows, not just most recently focused (LP: #959339)
    - [heap corruption?] compiz crashed with SIGSEGV in _int_malloc() from
      g_realloc() from ... from g_dbus_connection_send_message_with_reply()
      from g_object_unref() from unity::dash::HomeLens::Impl::~Impl() from
      unity::dash::HomeLens::~HomeLens() (LP: #931201)
    - compiz crashed with SIGSEGV in _int_malloc() from __libc_calloc() from
      XOpenDisplay() from nux::WindowThread::ThreadCtor() (LP: #947844)
    - Regression: Installing apps causes a terrible visual glitch-- have to
      restart X.org. (LP: #981168)
    - Window management - unity doesn't realise when applications bring their
      windows to the front (LP: #802816)
    - Dash - Clicking on the desktop dash border should do nothing, *NOT*
      close the dash (LP: #839472)
    - [FFe, UIFe] HUD - The HUD does not respect launcher icon size settings
      in autohide mode (LP: #921506)
    - compiz crashed with SIGSEGV in g_volume_get_mount() (LP: #918548)
    - multiple instances or double icons of application detected on bamfdaemon
      respawn (LP: #928912)
    - Panel is transparent when Dash is open; no blur no average BG color
      (LP: #965323)
    - Unity crashes with SIGSEGV when hitting debug DBus interface hard
      (LP: #979429)
    - compiz crashed with SIGSEGV in _int_malloc() from g_object_unref() from
      unity::dash::Model<unity::dash::FilterAdaptor>::~Model() (LP: #941750)
    - indicators menu are sometimes cut off at screen edge (LP: #883317)
    - the shortcut keys in workspace section of the shortcut overlay aren't
      translated (LP: #980828)
    - [regression] Dash keeps repainting unnecessarily (LP: #980924)
    - compiz crashed with SIGSEGV in nux::NTextureData::ClearData() from
      nux::NTextureData::~NTextureData() from nux::Texture2D::~Texture2D()
      (LP: #952378)
    - compiz crashed with SIGSEGV in g_object_unref() from
      unity::dash::Settings::~Settings() from
      unity::UnityScreen::~UnityScreen() (LP: #981764)
    - compiz crashed with SIGSEGV in unity::dash::ResultView::~ResultView()
      from unity::dash::ResultViewGrid::~ResultViewGrid() from
      nux::Object::Destroy() from nux::Object::UnReference() (LP: #942286)
    - compiz crashed with SIGSEGV in
      ends_with_iter_select<__gnu_cxx::__normal_iterator<char const*,
      std::basic_string<char> >, char const*, boost::algorithm::is_iequal>()
      from unity::ui::PointerBarrierWrapper::EmitCurrentData() (LP: #983268)
    - Chinese can't be shown completely in dash filter (LP: #984583)
    - [Unity 5.10] compiz crashed with SIGSEGV in
      unity::hud::HudIconTextureSource::ColorForIcon() from
      unity::hud::Icon::Icon() from emit from unity::IconTexture::IconLoaded
      (LP: #983646)
    - [regression] Close button does not close the dash/HUD (LP: #986264)
    - compiz crashed with SIGSEGV in g_volume_eject_with_operation_finish()
      fro...

Read more...

Changed in unity (Ubuntu):
status: Confirmed → Fix Released
Changed in unity (Ubuntu Precise):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers