Ubuntu

On multi-monitor, mouse gets stuck in the middle, especially going right to left

Reported by Clint Byrum on 2012-02-22
82
This bug affects 16 people
Affects Status Importance Assigned to Milestone
unity (Ubuntu)
Undecided
Unassigned

Bug Description

I spoke with DBO in #ubuntu-desktop, and he assured me this is by design.

When I use multiple monitors, I'd expect a smooth transition of the mouse from screen to screen.

Instead the mouse pauses briefly, presumably to allow the reveal of the launcher. However, even if I go slow so the launcher does not show, then I am stuck in this position and have to move my mouse much further to get it to the other screen.

This is really hard to get used to, and perhaps needs some refinement.

I'd prefer to see the mouse pass through most of the time, and only on very direct behavior, would the launcher be shown. Its also really unclear to me why it also stops while going left->right since there is nothing to reveal.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: unity 5.4.0-0ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-17.26-generic 3.2.6
Uname: Linux 3.2.0-17-generic x86_64
NonfreeKernelModules: nvidia wl
ApportVersion: 1.92-0ubuntu1
Architecture: amd64
CompizPlugins: [core,bailer,detection,composite,opengl,decor,vpswitch,move,gnomecompat,compiztoolbox,imgpng,grid,mousepoll,place,regex,resize,snap,session,unitymtgrabhandles,animation,wall,expo,fade,ezoom,workarounds,scale,unityshell]
Date: Tue Feb 21 22:49:11 2012
InstallationMedia: Xubuntu 10.10 "Maverick Meerkat" - Release amd64 (20101008.1)
ProcEnviron:
 TERM=xterm
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: unity
UpgradeStatus: Upgraded to precise on 2011-07-14 (222 days ago)

Clint Byrum (clint-fewbar) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity (Ubuntu):
status: New → Confirmed
Omer Akram (om26er) wrote :

>> why it also stops while going left->right since there is nothing to reveal.

Design says that if you have a maximized browser window of the left monitor and you want to go quickly to the scrollbar to go down the page is a usecase for this specific behavior.

Paul Kishimoto (khaeru) wrote :

…but this occurs even when there is nothing on the left monitor.

Clint Byrum (clint-fewbar) wrote :

Agreed. If nothing else, change it so it only slows / sticks when there is a scroll bar to try and interact with. That seems reasonable and simple to detect.

I've had to get a bigger mouse pad to use because I have to move my mouse about 20% further left/right because of this new behavior.. seems like it needs more thought, or an option to turn it off altogether.

Paul Kishimoto (khaeru) wrote :

I've upgraded to Precise on a second machine, and the problem seems less acute.

The difference is that this computer has a mouse with high sensitivity. If I approach the monitor border very quickly, the cursor passes through without getting stuck.

Using the trackball I have on my other system, it's very difficult to move the cursor that quickly, so it almost always gets stuck.

So it seems there *is* a threshold velocity for this behaviour, but it has been set too high. Either it should be lowered, or made configurable.

Simply increasing the trackball sensitivity to avoid this new feature is not a solution.

Andrew Austin (andrewaclt) wrote :

I also ran into this bug tonight.

One workaround is the "Launcher Edge Stop Overcome Pressure" setting. You can set this number lower by installing CompizConfig setting manager . You can't set this to 0, unfortunately, but setting it to 1 did make a noticable difference to me. Directions for finding this setting can be found here: http://askubuntu.com/questions/109338/how-do-i-disable-mouse-magnet-on-middle-edge-with-multi-monitors

Another setting that looks promising is the setting called "Edge Stop Velocity".

Paul Kishimoto (khaeru) wrote :

With 5.6.0-0ubuntu1 today, it has become noticeably more sticky moving left-to-right.

Laurent Dinclaux (dreadlox) wrote :

Yes this is a productivity breaker. I just want one luancher on one screen why can't I define that ?

Also when it is need the pressure needed to show the launcher is to much.

I was one that loved unity since the bigining but this bug is slowing me down in my work.

Jesse Johnson (holocronweaver) wrote :

With the latest updates in Precise, there are now settings to adjust this sticky behavior and where your Unity launcher appears. Take a look in System Settings -> Displays.

Clint Byrum (clint-fewbar) wrote :

\o/

Thank you!

Actually the other thing that helped mitigate this for me and may be preferrable for some people was to change the reveal area to top left corner. This meant less stickiness. But ultimately, I'm quite happy to have the ability to have no stickiness. :)

Changed in unity (Ubuntu):
status: Confirmed → Fix Released
Ohad (ohadle) wrote :

The issue was definitely annoying, and being able to switch it off sure helps. However, changing the default behaviour requires some digging around and seems to me too much work for the average user (myself included).

I think a solution like slowing the mouse down only when something's actually there would be better (someone suggested it before).

Elijah Lynn (elijah-lynn) wrote :

In reference to comment #10 - This seems to be the same setting as what is in CCSM and is great to have it there but it seems that when I select "laptop" from the list it removes the menu from my laptop and places it on the secondary monitor instead. This is what CCSM does as well. I am using the Nvidia Settings manager if it matters, the laptop is set to primary display in nvidia settings.

Right now with latest 12.04 there is no way for me to disable this second menu.

BigglesPiP (abdawson) wrote :

I find this slightly irritating, but would be very happy if it only did it going from right to left, and the speed to crash past it was lower.

Elijah Lynn (elijah-lynn) wrote :

Biggles, I found that the best thing to do right now is to disable the second launcher menu. After the latest update yesterday my system is recognizing the correct monitor as laptop/primary now so disabling it works as designed.

Sidarth Dasari (sirsid) wrote :

Ive disabled this option in the display window and I've disabled the launcher on the right monitor, yet the stickyness randomly still comes back! Anyone else have this issue?

Daniel van Vugt (vanvugt) wrote :

Sidarth: If you have any remaining problems, please log a new bug by running:
    ubuntu-bug unity

This bug is marked Fix Released so should not be used any more.

Elijah Lynn (elijah-lynn) wrote :

I don't think it is valid to mark this as "Fix released". This is UI bug is still present by default isn't it?

Excerpts from Elijah Lynn's message of 2012-12-05 16:58:47 UTC:
> I don't think it is valid to mark this as "Fix released". This is UI bug
> is still present by default isn't it?
>

No, *this bug* was fixed. Anything that has changed or is being noticed
now, while perhaps related, is not *this bug*.

Please do come back and comment on this bug with a link to your new one,
so that users who find this one can look at that one too, and also so that
the search engines will connect the two and perhaps raise the importance
of the other one since it will change more often being a new bug.

Elijah Lynn (elijah-lynn) wrote :

Clint, is there a link to the code that fixed this in this issue? I don't know how to read these issues that well and I can't find it. I

Thanks,

Elijah

Clint Byrum (clint-fewbar) wrote :

Excerpts from Elijah Lynn's message of 2012-12-05 19:39:42 UTC:
> Clint, is there a link to the code that fixed this in this issue? I
> don't know how to read these issues that well and I can't find it. I
>

Not the specific code. But basically, you can turn the feature off in the
"Behavior" settings, which fixes my original complaint. If that ability
is not working, then you have a legitimate complaint, but that is not
the same as my bug, which was that there was no way to even turn it off
or change the behavior.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers