compiz crashed with SIGSEGV in gdk_pixbuf_get_width()

Bug #937421 reported by Bulat Nigmatullin on 2012-02-21
94
This bug affects 16 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
Critical
Gord Allott
Unity Distro Priority
Critical
Unassigned
unity (Ubuntu)
Critical
Canonical Desktop Experience Team
Precise
Critical
Canonical Desktop Experience Team

Bug Description

1) lsb_release -rd
Description: Ubuntu precise (development branch)
Release: 12.04

2) apt-cache policy unity
unity:
  Installed: 5.4.0-0ubuntu1
  Candidate: 5.4.0-0ubuntu1
  Version table:
 *** 5.4.0-0ubuntu1 0
        500 http://ru.archive.ubuntu.com/ubuntu/ precise/main amd64 Packages
        100 /var/lib/dpkg/status

3) I was working in my IDE ( IntelliJ IDEA) and pressed Ctrl + Alt + L shortcut to apply refactoring. Screen lock already rebinded to Win + L . Ctrl + Alt + L worked in my IDE yesterday. Today moning I've first installed latest updates, then restarted comp and started to work.
4) Crash report dialog appeared.

ProblemType: Crash
DistroRelease: Ubuntu 12.04
Package: unity 5.4.0-0ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-17.26-generic 3.2.6
Uname: Linux 3.2.0-17-generic x86_64
ApportVersion: 1.92-0ubuntu1
Architecture: amd64
Date: Tue Feb 21 08:44:57 2012
EcryptfsInUse: Yes
ExecutablePath: /usr/bin/compiz
ProcCmdline: compiz
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SegvAnalysis:
 Segfault happened at: 0x7ff515b0836e <gdk_pixbuf_get_width+14>: mov (%rbx),%rdx
 PC (0x7ff515b0836e) ok
 source "(%rbx)" (0xa7730a7730a7730) not located in a known VMA region (needed readable region)!
 destination "%rdx" ok
SegvReason: reading unknown VMA
Signal: 11
SourcePackage: unity
StacktraceTop:
 gdk_pixbuf_get_width () from /usr/lib/x86_64-linux-gnu/libgdk_pixbuf-2.0.so.0
 unity::hud::HudIconTextureSource::ColorForIcon(_GdkPixbuf*) () from /usr/lib/compiz/libunityshell.so
 ?? () from /usr/lib/compiz/libunityshell.so
 unity::IconTexture::IconLoaded(std::string const&, unsigned int, _GdkPixbuf*) () from /usr/lib/compiz/libunityshell.so
 unity::IconLoader::Impl::CoalesceTasksCb(unity::IconLoader::Impl*) () from /usr/lib/compiz/libunityshell.so
Title: compiz crashed with SIGSEGV in gdk_pixbuf_get_width()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo

Related branches

Bulat Nigmatullin (bulatka) wrote :

StacktraceTop:
 gdk_pixbuf_get_width (pixbuf=<optimized out>) at gdk-pixbuf.c:581
 unity::hud::HudIconTextureSource::ColorForIcon (this=0x3fce850, pixbuf=0xa7730a7730a7730) at /build/buildd/unity-5.4.0/plugins/unityshell/src/HudIconTextureSource.cpp:47
 operator() (this=0x26b9800, texture=<optimized out>) at /build/buildd/unity-5.4.0/plugins/unityshell/src/HudIcon.cpp:60
 emit (_A_a1=@0x7fff454ad308, impl=0x327f680) at /usr/include/sigc++-2.0/sigc++/signal.h:1010
 emit (_A_a1=@0x7fff454ad308, this=<optimized out>) at /usr/include/sigc++-2.0/sigc++/signal.h:2781

Changed in unity (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity (Ubuntu):
status: New → Confirmed
Jean-Baptiste Lallement (jibel) wrote :

reproduced by pressing CTRL+ALT to exit a VM that captured the cursor

visibility: private → public
Changed in unity (Ubuntu):
importance: Medium → High
assignee: nobody → Canonical Desktop Experience Team (canonical-dx-team)
tags: added: qa-manual-testing
tags: added: rls-mgr-p-tracking
Jean-Baptiste Lallement (jibel) wrote :

Setting to critical it occurs pretty frequently when I press <ALT>

Changed in unity (Ubuntu Precise):
importance: High → Critical
Didier Roche (didrocks) wrote :

Gord told he will look into it.

Changed in unity:
milestone: none → 5.6.0
importance: Undecided → Critical
status: New → Confirmed
assignee: nobody → Gord Allott (gordallott)
Changed in unity-distro-priority:
status: New → Confirmed
importance: Undecided → Critical
Tim Penhey (thumper) on 2012-03-01
Changed in unity:
status: Confirmed → In Progress
Changed in unity:
status: In Progress → Fix Committed
Didier Roche (didrocks) on 2012-03-12
Changed in unity:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (4.1 KiB)

This bug was fixed in the package unity - 5.6.0-0ubuntu1

---------------
unity (5.6.0-0ubuntu1) precise; urgency=low

  * New upstream release.
    - compiz crashed with SIGSEGV in g_type_check_instance_cast()
      (LP: #862972)
    - compiz crashed with SIGABRT in __gnu_cxx::__verbose_terminate_handler()
      (LP: #926793)
    - compiz crashed with SIGSEGV in gdk_pixbuf_get_width() (LP: #937421)
    - Unity causes ibus to not work correctly (spaces incorrectly placed)
      (LP: #880876)
    - Dash - update Dash keyboard shortcuts so the 'CTRL + TAB' switches
      between Lenses and 'TAB' by itself moves the focus between categories
      (LP: #891648)
    - HUD - closing a window with <Alt>+<F4> opens the hud (LP: #923410)
    - unity-applications-daemon crashed with SIGSEGV in
      dee_sequence_model_free_row() (LP: #916356)
    - Launcher, Window Management - Launcher reveal should not be triggered
      when dragging a window (LP: #928805)
    - lenses are loaded on start, should be lazy loaded (LP: #929506)
    - Trash icon jumps about when trying to drag an icon onto it (LP: #932365)
    - HUD loses keypresses for the first second after opening (LP: #932906)
    - HUD doesn't give the focus back to the active application after dash/hud
      use (LP: #934061)
    - Launcher - unpinned apps show with empty pips in the launcher as if they
      exist on another workspace (LP: #937898)
    - Unity Dash should support Keywords parameter in .desktop (formerly X
      -GNOME-Keywords or X-AppInstall-Keywords) (LP: #941231)
    - Support FD.o Desktop Actions spec (LP: #942042)
    - Unity hangs when touching my touchpad/trackpad (LP: #942625)
    - [regression] Pressing alt doesn't show the menu title bar in top panel
      (LP: #943194)
    - Alt + F (or other mnemonic) doesn't work in gnome-terminal (LP: #943239)
    - [unity 5.6] Using Alt+F1 or Alt+F2 sends a ";3P" or ";3Q" to the active
      windows (LP: #943456)
    - [unity 5.6] holding alt and pressing a direction opens the alt-tab list
      in a buggy way (LP: #943902)
    - [unity-5.6] can't enter accents (^o->) in the dash since recent updates
      (LP: #944674)
    - Dash - Keyboard navigation for search filters is broken (LP: #844033)
    - Dash - If mouse highlights one icon in grid, keyboard navigation
      highlights another, so there are 2 highlighted icons (LP: #817436)
    - Alt+Tab default delay of 150ms is too long (LP: #888636)
    - Keyboard shortcut - F10 shortcut is used to show menu and this is wrong
      (LP: #878492)
    - Dash - Currently the app lens doesn't show applications that are
      available for purchase (LP: #916121)
    - Chromium is running, but not showing in launcher or alt-tab.
      (LP: #918474)
    - Dash - Different states of rating stars, and dimensions (LP: #924884)
    - alt-tab confused by a multiple instances of an application on different
      workspaces (LP: #925484)
    - Launcher - Icons are not colorized properly (LP: #930949)
    - Remove glow from Alt-tab edge and Search Field image assets
      (LP: #933578)
    - "Left Mouse Drag" and "Middle Mouse Drag" should be translatable
      (LP: #930510)
    - Launcher switcher...

Read more...

Changed in unity (Ubuntu Precise):
status: Confirmed → Fix Released
Didier Roche (didrocks) on 2012-03-14
Changed in unity-distro-priority:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers