Ubuntu

Unity shortcut overlay needs to include shortcut for video lens

Reported by Nekhelesh Ramananthan on 2012-02-21
50
This bug affects 10 people
Affects Status Importance Assigned to Milestone
Ayatana Design
Low
John Lea
Unity
Low
Barneedhar
unity (Ubuntu)
Low
Unassigned

Bug Description

The Unity Keyboard Shortcut overlay is currently missing the keyboard shortcut for the video lens SUPER + V which was recently added since Unity 5.4.

Screenshot attached. As you can see from the screenshot the keyboard shortcut is missing.

----------------------------------------
Desired solution:

- Add shortcut to video lens as specified in "12.04 Unity Shortcuts" spec ( https://docs.google.com/a/canonical.com/document/d/1jqeKtIJwqLtl58Wk_fqjr9Rrgxn9zsouCYOo-cZsLSE/edit )

- Contact Rosie or Otto for the updated visual design

Nekhelesh Ramananthan (nik90) wrote :
Changed in unity:
status: New → Confirmed
Omer Akram (om26er) wrote :

that's the same for any other lense as well? its not specific to video lens

Changed in unity:
status: Confirmed → Incomplete
status: Incomplete → Confirmed
Omer Akram (om26er) wrote :

please ignore the last comment ;-)

Barneedhar (barneedhar) wrote :

@omer: I can't submit a branch because ssh is not possible in my network. If anyone wants to submit a branch on my behalf, feel free to do so. I will attach the patch from the duplicate report here.

Omer Akram (om26er) wrote :

andy, can you please review the change

Changed in unity:
assignee: nobody → Andrea Azzarone (andyrock)
Andrea Azzarone (andyrock) wrote :

> andy, can you please review the change

We need design input.

Nekhelesh Ramananthan (nik90) wrote :

I do not understand why this needs design input considering that the shortcuts for other lenses installed by default is shown in the shortcut overlay. As can be seen in the patch, it is merely adding one more line of code. Please let me know if it is necessary to bring this issue in the unity mailing list.

Andrea Azzarone (andyrock) wrote :

@nik90
We need design input becuse the layout of the shortcut is really fixed. Adding an item can break the entire layout. So we need a mockup :)

Changed in unity:
status: Confirmed → Incomplete
assignee: Andrea Azzarone (andyrock) → nobody
John Lea (johnlea) on 2012-04-18
description: updated
tags: added: udp
Changed in ayatana-design:
assignee: nobody → John Lea (johnlea)
importance: Undecided → Low
status: New → Triaged
Changed in unity:
status: Incomplete → Confirmed
Changed in unity (Ubuntu):
status: New → Confirmed
Changed in unity:
milestone: none → backlog

The attachment "Patch to add the shortcut for video lens" of this bug report has been identified as being a patch. The ubuntu-reviewers team has been subscribed to the bug report so that they can review the patch. In the event that this is in fact not a patch you can resolve this situation by removing the tag 'patch' from the bug report and editing the attachment so that it is not flagged as a patch. Additionally, if you are member of the ubuntu-reviewers team please also unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by Brian Murray. Please contact him regarding any issues with the action taken in this bug report.]

tags: added: patch
Changed in unity (Ubuntu):
status: Confirmed → Triaged
Changed in unity:
status: Confirmed → Triaged
importance: Undecided → Low
Changed in unity (Ubuntu):
importance: Undecided → Low
Barneedhar (barneedhar) on 2012-07-16
Changed in unity:
status: Triaged → In Progress
assignee: nobody → Barneedhar (barneedhar)
Barneedhar (barneedhar) wrote :
John Lea (johnlea) wrote :

Screenshot reviewed and approved by design, many thanks!

Barneedhar (barneedhar) on 2012-08-03
Changed in unity:
status: In Progress → Fix Committed
Changed in unity:
milestone: backlog → 6.2
Changed in unity (Ubuntu):
status: Triaged → Fix Committed
Didier Roche (didrocks) on 2012-08-10
Changed in unity:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (3.9 KiB)

This bug was fixed in the package unity - 6.2.0-0ubuntu1

---------------
unity (6.2.0-0ubuntu1) quantal-proposed; urgency=low

  [ Adam Conrad ]
  * Removed debian/patches/libgeis-rename.patch

  [ Łukasz 'sil2100' Zemczak ]
  * debian/rules:
    - added override for dh_shlibdeps to point it to the private directory of
      libunity-protocol-private.so
  * debian/unity.lintian-overrides,
    debian/libunity-core-6.0-5.lintian-overrides:
    - added override to silence the binary-or-shlib-defines-rpath error, since
      we are forced to use RPATH in our case

  [ Didier Roche ]
  * New upstream release.
    - [nvidia] compiz crashed with SIGSEGV in
      nux::GraphicsEngine::QRP_GLSL_Color() from
      nux::GraphicsEngine::QRP_Color() from nux::BasePainter::PaintBackground
      (LP: #982626)
    - Launcher - when a user starts dragging a item, any folded launcher icons
      that are valid drop receptacles should unfold. (LP: #839717)
    - running applications without an icon use a blank icon (LP: #886778)
    - compiz crashed with SIGSEGV in
      unity::ui::KeyboardUtil::GetKeycodeAboveKeySymbol() (LP: #920258)
    - still some accent issues with unity/nux (LP: #950740)
    - Launcher doesn't autoscroll when holding an icon (can't reach trash)
      (LP: #987223)
    - Purchased items are not being added to the Unity launcher (LP: #925014)
    - [GLES] framebuffer output scaled incorrect in both blur and items above
      shell with multimonitor (LP: #1016789)
    - [regression] [unity 6.0] Fullscreen windows flicker and/or never redraw
      properly if panel_opacity<1.0 or dash is opened. (LP: #1024911)
    - panel and launcher blinks when using libreoffice presenter/spreadsheet
      (LP: #1024459)
    - compiz crashed with SIGSEGV in
      unity::ui::EdgeBarrierController::Impl::OnPointerBarrierEvent()
      (LP: #1020075)
    - Update to 1.6.4 (LP: #1014850)
    - [nvidia] unity crashed in nux::GraphicsEngine::QRP_GLSL_1Tex
      (glDrawArrays) (LP: #1031554)
    - Dragging image from firefox/chrome to dock causes lagg/freeze
      (LP: #772445)
    - Launcher, Dash - Showing dash, via super key, with a quicklist shown
      doesn't work (LP: #913994)
    - REGRESSION: can't type characters with accent (dead keys) (LP: #961741)
    - Launcher wrongly shows top tooltip when peforming the accordion effect
      (LP: #980942)
    - Unity Launcher Fails To Auto-Hide When Enabled & Installing Commercial
      Software (LP: #1002440)
    - logging out/in with mounted drives causes unity launcher icons to be
      duplicated (LP: #1010714)
    - Mounted volume icons doubled up in launcher (LP: #1010858)
    - Launcher - when a user starts dragging a item, the launcher icons that
      are *not* valid drop receptacles should be tinted (LP: #1020891)
    - Alt+F4 does not close the hud when Numlock or Capslock are on.
      (LP: #1022801)
    - Unity shortcut overlay needs to include shortcut for video lens
      (LP: #937334)
    - padding between last quicklist item and bottom edge is non-deterministic
      (changes randomly) (LP: #955158)
    - give a way to remove 'Show Desktop' from the Alt-Tab items
      (LP: #1014346)
    - Multi...

Read more...

Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
John Lea (johnlea) on 2012-10-15
Changed in ayatana-design:
status: Triaged → Fix Released
tags: added: reviewedbydesignq
removed: patch udp
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers