unity-panel-service crashed with SIGSEGV in g_hash_table_foreach()

Bug #937119 reported by Dave Morley on 2012-02-20
62
This bug affects 12 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
High
Marco Trevisan (Treviño)
Unity Distro Priority
High
Unassigned
unity (Ubuntu)
High
Marco Trevisan (Treviño)

Bug Description

This crash is created by using the following ldtp script.

#!/usr/bin/env python

import os
import sys
import unittest
import ldtp
import time

start_time = time.time()

class ss_of_USC(unittest.TestCase):
    def setUp(self):
        ldtp.launchapp('software-center')
        assert ldtp.waittillguiexist('frmUbuntuSoftwareCentre')
        self.msgs = []
        a = "Time taken for the frame to open is " + str(time.time() - start_time)
        self.msgs.append(a)

    def tearDown(self):
        ldtp.selectmenuitem('frmUbuntuSoftwareCentre', 'mnuClose')
        assert ldtp.waittillguinotexist('frmUbuntuSoftwareCentre')
        c = "This test took a total of " + str(time.time() - start_time)
        self.msgs.append(c)
        print '\n'.join(self.msgs)

    def test_1(self):
        ldtp.waittillguiexist('frmUbuntuSoftwareCentre', 'btnAccessories')
        assert ldtp.objectexist('frmUbuntuSoftwareCentre', 'btnAccessories')
        b = "Time taken from start to find the Accessories button " + str(time.time() - start_time)
        self.msgs.append(b)

if __name__ == "__main__":
    unittest.main()

This crash is very reproducible with this script, which just times how long certain parts of USC take to load.

ProblemType: Crash
DistroRelease: Ubuntu 12.04
Package: unity-services 5.4.0-0ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-17.26-generic 3.2.6
Uname: Linux 3.2.0-17-generic x86_64
ApportVersion: 1.91-0ubuntu1
Architecture: amd64
CompizPlugins: [core,bailer,detection,composite,opengl,decor,imgpng,vpswitch,gnomecompat,resize,mousepoll,compiztoolbox,grid,wall,move,regex,snap,animation,place,workarounds,session,fade,expo,ezoom,scale,unityshell]
Date: Mon Feb 20 17:49:39 2012
ExecutablePath: /usr/lib/unity/unity-panel-service
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Alpha amd64 (20120117)
ProcCmdline: /usr/lib/unity/unity-panel-service
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, no user)
 LANGUAGE=en_GB:en
 LANG=en_GB.UTF-8
SegvAnalysis:
 Segfault happened at: 0x405d02: cmp %rsi,(%rdx)
 PC (0x00405d02) ok
 source "%rsi" ok
 destination "(%rdx)" (0x0000863f) not located in a known VMA region (needed writable region)!
SegvReason: writing NULL VMA
Signal: 11
SourcePackage: unity
StacktraceTop:
 ?? ()
 ?? () from /usr/lib/x86_64-linux-gnu/gtk-3.0/modules/libatk-bridge.so
 g_hash_table_foreach () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
 ?? () from /usr/lib/x86_64-linux-gnu/gtk-3.0/modules/libatk-bridge.so
 ?? () from /usr/lib/x86_64-linux-gnu/gtk-3.0/modules/libatk-bridge.so
Title: unity-panel-service crashed with SIGSEGV in g_hash_table_foreach()
UpgradeStatus: Upgraded to precise on 2012-02-13 (7 days ago)
UserGroups: adm admin cdrom dip lpadmin plugdev sambashare sudo

Related branches

Revision history for this message
Dave Morley (davmor2) wrote :
visibility: private → public
Revision history for this message
Apport retracing service (apport) wrote :

StacktraceTop:
 panel_indicator_entry_accessible_get_n_children (accessible=<optimized out>) at /build/buildd/unity-5.4.0/services/panel-indicator-entry-accessible.c:254
 ?? ()
 ?? ()
 ?? ()
 ?? ()

Revision history for this message
Apport retracing service (apport) wrote : Stacktrace.txt
Revision history for this message
Apport retracing service (apport) wrote : ThreadStacktrace.txt
tags: added: apport-failed-retrace
tags: removed: need-amd64-retrace
Revision history for this message
Bilal Akhtar (bilalakhtar) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better.

However, processing it in order to get sufficient information for the developers failed (it does not generate an useful symbolic stack trace). This might be caused by some outdated packages which were installed on your system at the time of the report. Please upgrade your system to the latest package versions. If you still encounter the crash, please file a new report.

Thank you for your understanding, and sorry for the inconvenience!

P.S. This seems like a crash with ATK, so if you go on to file another bug, do file it with GTK 3.0 too.

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity (Ubuntu):
status: New → Confirmed
Revision history for this message
Gema Gomez (gema) wrote :

Can someone bother running the code that Dave attached to the problem and get it fixed? This is a blocker for testing and should be a high priority item on any development team.

Didier Roche (didrocks) on 2012-03-06
Changed in unity:
status: New → Confirmed
importance: Undecided → High
Changed in unity (Ubuntu):
importance: Undecided → High
Changed in unity-distro-priority:
status: New → Confirmed
importance: Undecided → High
status: Confirmed → Fix Committed
tags: added: rls-p-tracking
Changed in unity:
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
Changed in unity (Ubuntu):
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
Changed in unity:
status: Confirmed → In Progress
Changed in unity (Ubuntu):
status: Confirmed → In Progress
Changed in unity:
milestone: none → 5.8.0
Tim Penhey (thumper) on 2012-03-21
Changed in unity:
status: In Progress → Fix Committed
Didier Roche (didrocks) on 2012-03-23
Changed in unity:
status: Fix Committed → Fix Released
Didier Roche (didrocks) on 2012-03-23
Changed in unity-distro-priority:
status: Fix Committed → Fix Released
Revision history for this message
Launchpad Janitor (janitor) wrote :
Download full text (5.4 KiB)

This bug was fixed in the package unity - 5.8.0-0ubuntu1

---------------
unity (5.8.0-0ubuntu1) precise-proposed; urgency=low

  * New upstream release.
    - New "push mouse offscreen" feature really difficult to get (LP: #923749)
    - unity-2d-panel crashed with SIGSEGV in
      unity::indicator::DBusIndicators::Impl::RequestSyncAll() (LP: #864737)
    - Pressing "Alt+Enter" causes compiz to crash in CompOption::value() from
      unity::UnityScreen::showLauncherKeyTerminate (LP: #960957)
    - SEGSIGV after unplugging external monitor (LP: #962693)
    - Background colorization should use a different heuristic (LP: #865239)
    - compiz+unity3d generates > 50 wakeups a second on idle system
      (LP: #917210)
    - [FFe, UIFe] HUD - The HUD does not respect launcher autohide or icon
      size settings (LP: #921506)
    - clicking on folders in the file lens does not open nautilus
      (LP: #921665)
    - No text inside multirange filters (LP: #927710)
    - can't alt-tab restore minimized uis which have an instance on another
      workspace (LP: #933397)
    - Ubuntu Software Center Unity launcher integration is not working
      (LP: #932280)
    - The line separator between the launcher and the dash is cleared when
      selecting a category (LP: #941082)
    - unity-panel-service crashed with SIGSEGV in g_hash_table_foreach()
      (LP: #937119)
    - Alt-F10 locks up Unity (LP: #948522)
    - multimonitor, launcher: Provide an option to display either a single
      launcher or a launcher on each display in a multi-monitor environment
      (LP: #950136)
    - multimonitor: Please give me a way to turn off sticky monitor edges
      (LP: #946104)
    - Unity 5.6: key bindings (such as Super) don't work on empty workspace or
      on slow/loaded systems (LP: #953089)
    - Alt+arrows keyboard shortcuts don't invoke Back and Forward navigation
      (LP: #953783)
    - HUD is sending 2 menu signals instead of 1 (LP: #956878)
    - 6th item of HUD not fully visible (LP: #957229)
    - HUD: seems to trigger operations more than once (LP: #960503)
    - Launcher gets always desaturated when using HUD on secondary monitor
      (LP: #961169)
    - [5.8 pre staging] launcher is displayed on the left screen, not the
      primary one (LP: #961281)
    - launcher icons do not re-saturate after dash is closed (LP: #961844)
    - Launcher shows arrows for applications on all workspaces (LP: #961977)
    - Dash - Implement overlay scrollbars in Dash (LP: #608124)
    - [UIFe] Dash - No message displayed when no results are returned in the
      Dash (LP: #711199)
    - Dash - "See more..." line should be base-aligned with section header
      (LP: #748101)
    - Dash - Missing category separator line in dash (LP: #850984)
    - Dash and Launcher - As soon as a user starts dragging a file from the
      Dash, there is a 'flicker' before the Launcher icons that are valid drop
      receptacles re-saturate (LP: #863230)
    - Dash - When multiple results have equal string match relevancy ranking,
      those with equal ranking should be then sorted by frequency of use.
      (LP: #871900)
    - Keyboard shortcut - F10 shortcut is used to show m...

Read more...

Changed in unity (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers