Hard to resize windows

Bug #933198 reported by Dan Kegel on 2012-02-16
34
This bug affects 8 people
Affects Status Importance Assigned to Milestone
Ayatana Design
Undecided
Unassigned
unity (Ubuntu)
Undecided
Unassigned

Bug Description

http://njpatel.blogspot.com/2011/03/of-borders-and-shadows.html and
https://bugs.launchpad.net/ubuntu/+source/metacity/+bug/160311
both claim that this is fixed, but here on Precise alpha 2, I am having
a real hard time resizing windows. Even grabbing the lower right
corner is almost impossible. The app I have the most trouble with is
Terminal. The dang newfangled scrollbar thingy gets in the way.
Chrome is a bit better off since it has an old style scrollbar, but even
it is difficult.

Oh, please, give us back a big fat area to grab when resizing...

Dan Kegel (dank) on 2012-02-16
tags: added: usability
Bilal Akhtar (bilalakhtar) wrote :

Doesn't it have quite a large area already where you can grab it? Atleast that's the case here.

Dan Kegel (dank) wrote :

Nope. That's what the bug's about: there is only a two-pixel or maybe one-pixel sweet spot.
That's hard to hit with a mouse, and nearly impossible to hit with a trackpad.
And when there's a vertical overlay scrollbar (as there is in terminal after
it outputs a few dozen lines), it's even harder.

Do you need a screenshot movie so you can see what I'm talking about?

Dan Kegel (dank) wrote :

I think the sweet spot on the corner is still big horizontally,
but vertically it has collapsed to just one or two pixels,
probably due to the new vertical overlay scrollbar implementation.

Omer Akram (om26er) wrote :

dan are you using unity-2d? can you attach a screenshot of your desktop please?

Changed in unity (Ubuntu):
status: New → Incomplete
Dan Kegel (dank) wrote :

It looks like I'm using unity-2d. But the problem has magically fixed itself;
there is now a nice big visible dotted corner on both 'terminal' and 'gedit'.
So I guess somebody was aware of the problem and was working on it already...?

Changed in unity (Ubuntu):
status: Incomplete → Fix Released
Dan Kegel (dank) wrote :

overlay-scrollbar (0.2.15-0ubuntu1) may have fixed this; its release notes say something about resizing.

jerrylamos (jerrylamos) wrote :

Workaround, use Alt-F8 then arrow keys to resize, then enter to finish. A bit more involved but does work.

Jerry

Felix Haller (felixhaller) wrote :

also in beta with todays unity 5.6.0 updates

Dan Kegel (dank) wrote :

Damn, it's back. This time I'm using unity 3d, not unity 2d,
on a fully updated precise system.

Daniel van Vugt (vanvugt) wrote :

Dan, the regression of this bug is being tracked in bug 953839.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers