Unity freeze, crashes when trying to restart - GPU lockup with IPEHR: 0x7a000002

Bug #932900 reported by Michael Hall on 2012-02-15
90
This bug affects 18 people
Affects Status Importance Assigned to Milestone
mesa (Ubuntu)
Undecided
Unassigned
unity (Ubuntu)
Undecided
Unassigned

Bug Description

Unity froze on my when initiating the workspace switcher (which had been working previously in the same session). I switched to ctrl+alt+F1 to get to a command prompt, ran unity --replace, but that kept crashing.

Output from unity --replace:

unity-panel-service: no process found
Checking if settings need to be migrated ...no
Checking if internal files need to be migrated ...no
Backend : gconf
Integration : true
Profile : unity
Adding plugins
Initializing core options...done
compiz (core) - Error: Couldn't load plugin 'bailer'
compiz (core) - Error: Couldn't load plugin 'detection'
Initializing composite options...done
Initializing opengl options...done
Initializing decor options...done
Initializing vpswitch options...done
Initializing move options...done
Initializing place options...done
Initializing grid options...done
Initializing annotate options...done
Initializing snap options...done
Initializing obs options...done
Initializing session options...done
Initializing mousepoll options...done
Initializing resize options...done
Initializing animation options...done
Initializing workarounds options...done
Initializing gnomecompat options...done
compiz (expo) - Warn: failed to bind image to texture
Initializing expo options...done
Initializing ezoom options...done
Initializing wall options...done
Initializing fade options...done
Initializing scale options...done

Screen geometry changed:
   0x0x1280x800

intel_do_flush_locked failed: Input/output error

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: unity 5.2.0-0ubuntu4
ProcVersionSignature: Ubuntu 3.2.0-16.25-generic-pae 3.2.6
Uname: Linux 3.2.0-16-generic-pae i686
NonfreeKernelModules: wl
.tmp.unity.support.test.0:

ApportVersion: 1.91-0ubuntu1
Architecture: i386
CompizPlugins: [core,bailer,detection,composite,opengl,decor,vpswitch,compiztoolbox,move,place,grid,annotate,snap,obs,session,mousepoll,resize,regex,imgpng,animation,workarounds,gnomecompat,expo,ezoom,wall,fade,scale,unityshell,scaleaddon,scalefilter]
CompositorRunning: compiz
Date: Wed Feb 15 12:06:36 2012
DistUpgraded: Log time: 2012-01-23 11:49:43.962217
DistroCodename: precise
DistroVariant: ubuntu
GraphicsCard:
 Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (primary) [8086:2a02] (rev 0c) (prog-if 00 [VGA controller])
   Subsystem: Dell Latitude D630 [1028:01f9]
   Subsystem: Dell Device [1028:01f9]
InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release i386 (20100429)
MachineType: Dell Inc. Latitude D630
PccardctlIdent:
 Socket 0:
   no product info available
PccardctlStatus:
 Socket 0:
   no card
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.2.0-16-generic-pae root=UUID=cdf53458-c5c8-4260-9504-6da8a8a22fd1 ro quiet splash vt.handoff=7
SourcePackage: unity
UpgradeStatus: Upgraded to precise on 2012-01-23 (22 days ago)
dmi.bios.date: 06/20/2008
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A12
dmi.board.name: 0KU184
dmi.board.vendor: Dell Inc.
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Inc.
dmi.modalias: dmi:bvnDellInc.:bvrA12:bd06/20/2008:svnDellInc.:pnLatitudeD630:pvr:rvnDellInc.:rn0KU184:rvr:cvnDellInc.:ct8:cvr:
dmi.product.name: Latitude D630
dmi.sys.vendor: Dell Inc.
version.compiz: compiz 1:0.9.7.0~bzr2995-0ubuntu1
version.libdrm2: libdrm2 2.4.30-1ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 8.0~rc2-0ubuntu5
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 8.0~rc2-0ubuntu5
version.xserver-xorg-core: xserver-xorg-core 2:1.11.4-0ubuntu3
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.6.99.901+git20120126-0ubuntu2
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.99~git20111219.aacbd629-0ubuntu2
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.17.0-1ubuntu3
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20111201+b5534a1-1build2

Michael Hall (mhall119) wrote :
Bilal Akhtar (bilalakhtar) wrote :

Seems like an IO error with the driver lock. Weird, this should never happen.

Is this fixed now? If not, try rebooting. If that doesn't fix this, it's a driver bug.

David Barth (dbarth) wrote :

Right, it's most probably a driver issue "intel_do_flush_locked failed: Input/output error".

We could add that to the xorg bug list, but Bryce will ask for a reproducible test case i guess.

Changed in unity (Ubuntu):
status: New → Invalid
affects: xserver-xorg-video-intel (Ubuntu) → mesa (Ubuntu)
Bryce Harrington (bryce) wrote :

Yes, either steps to reproduce the problem or a stacktrace (ideally BOTH) are needed.

This may be resolved in mesa 8.0.1. It would be worth testing xorg-edgers (where we have a recent git snapshot for mesa) and see if that solves it.

Changed in mesa (Ubuntu):
status: New → Incomplete
summary: - Unity freeze, crashes when trying to restart
+ Unity freeze, crashes when trying to restart - intel_do_flush_locked
+ failed: Input/output error

Here, instead of xorg-edgers use this PPA. I pulled out just the mesa package, so should be easier to install/uninstall for you:

https://launchpad.net/~ubuntu-x-swat/+archive/mesa-8.0.1

Bryce Harrington (bryce) on 2012-02-27
Changed in mesa (Ubuntu):
status: Incomplete → New
status: New → Incomplete
Bryce Harrington (bryce) wrote :

8.0.1 is now included in Ubuntu. Since there's been no comment I'll go ahead and assume that fixed it. If not, reopen and if you can get a test case we'll go from there.

Changed in mesa (Ubuntu):
status: Incomplete → Fix Released
Giovanni Pardini (gio.pardini) wrote :

The bug still occurs to me with mesa 8.0.1-0ubuntu5.

Actually, on my system it is quite easy to make compiz crash, by just starting chromium-browser and trying to use the WebGL version of google maps.

Giovanni Pardini (gio.pardini) wrote :

Here is the unity stacktrace.

Giovanni Pardini (gio.pardini) wrote :

Is there any way to reopen this bug?
It still occurs to me...

Nikita Tsukanov (keks9n) wrote :

Hm. I've got "intel_do_flush_locked failed: Input/output error" while playing Red Alert 3 Uprising. It repsoduces itself at a certain point of one of the maps.

Nikita Tsukanov (keks9n) wrote :

Dmesg:
[ 392.316357] [drm] Changing LVDS panel from (-hsync, -vsync) to (-hsync, +vsync)
[ 520.052825] [drm:i915_hangcheck_elapsed] *ERROR* Hangcheck timer elapsed... GPU hung
[ 520.052835] [drm] capturing error event; look for more information in /debug/dri/0/i915_error_state
[ 520.063530] [drm:i915_wait_request] *ERROR* i915_wait_request returns -11 (awaiting 77202 at 77199, next 77203)
[ 526.643310] [drm:i915_hangcheck_elapsed] *ERROR* Hangcheck timer elapsed... GPU hung
[ 526.643330] [drm:i915_wait_request] *ERROR* i915_wait_request returns -11 (awaiting 77239 at 77235, next 77240)
[ 533.549912] [drm:i915_hangcheck_elapsed] *ERROR* Hangcheck timer elapsed... GPU hung
[ 533.549933] [drm:i915_wait_request] *ERROR* i915_wait_request returns -11 (awaiting 77346 at 77343, next 77347)
[ 540.564560] [drm:i915_hangcheck_elapsed] *ERROR* Hangcheck timer elapsed... GPU hung
[ 540.564587] [drm:i915_wait_request] *ERROR* i915_wait_request returns -11 (awaiting 77407 at 77402, next 77408)
[ 547.047000] [drm:i915_hangcheck_elapsed] *ERROR* Hangcheck timer elapsed... GPU hung
[ 547.047039] [drm:i915_wait_request] *ERROR* i915_wait_request returns -11 (awaiting 77429 at 77426, next 77430)
[ 553.437409] [drm:i915_hangcheck_elapsed] *ERROR* Hangcheck timer elapsed... GPU hung
[ 553.437458] [drm:i915_wait_request] *ERROR* i915_wait_request returns -11 (awaiting 77439 at 77435, next 77440)
[ 559.815814] [drm:i915_hangcheck_elapsed] *ERROR* Hangcheck timer elapsed... GPU hung
[ 559.815843] [drm:i915_wait_request] *ERROR* i915_wait_request returns -11 (awaiting 77445 at 77442, next 77446)
[ 566.584785] [drm:i915_hangcheck_elapsed] *ERROR* Hangcheck timer elapsed... GPU hung
[ 566.584835] [drm:i915_wait_request] *ERROR* i915_wait_request returns -11 (awaiting 77471 at 77467, next 77472)

/sys/kernel/debug/dri/0/i915_error_state attached

Ursula Junque (ursinha) wrote :

This just happened to me, same thing. Unity keeps crashing and the last error message is "intel_do_flush_locked failed: Input/output error". The current mesa version is the latest one available on Precise, same goes with unity. Should we reopen this bug or file a new one?

Bryce Harrington (bryce) on 2012-08-28
Changed in mesa (Ubuntu):
status: Fix Released → Confirmed
Bryce Harrington (bryce) wrote :

Reopening.

From comment 8, Unity is just getting stuck waiting for the GPU to come back, but the GPU has locked.

Ursula, would be helpful to get /sys/kernel/debug/dri/0/i915_error_state from you as well when your system locks up. If you also have IPEHR: 0x7a000002 in your renderer command stream then it may be the same bug as Giovanni.

Bryce Harrington (bryce) wrote :

In checking Ursula's i915_error_state, she doesn't have IPEHR: 0x7a000002 so we're treating it as a different bug for now.

Giovanni, I've put mesa 8.0.3 into precise-proposed. I would suggest your next step (if you're still reproducing this bug) is to update your mesa to t he one in proposed and see if that resolves the lockup issue.

summary: - Unity freeze, crashes when trying to restart - intel_do_flush_locked
- failed: Input/output error
+ Unity freeze, crashes when trying to restart - GPU lockup with IPEHR:
+ 0x7a000002
Etienne Blanc (etienne-blanc) wrote :

I don't know if that will help, but I have the same intel_do_flush_locked io error sometimes. I create a java program under eclipse using lwjgl (OpenGL version: 2.1 Mesa 8.0.4).
And I would greatly appreciate any work around the problem for sure!
Thanks,
Etienne Blanc

Maik Macho (nuda1998) wrote :

I do not know if it will help either, but replacing "sna" with "uxa" in /etc/X11/xorg.conf ( or creating a new file with these contents:

Section "Device"
        Identifier "intel"
        Driver "intel"
        Option "AccelMethod" "uxa"
EndSection

) will at least make gnome-shell / unity / ... run. The problem: graphics problems (transparency, smoothing, performance, ...).

My graphics card is defined as "Mobile Intel® 4 Series Express Chipset Family" in Windows, as "Mobile Intel® GM45 Express Chipset x86/MMX/SSE2 " in the Settings and yells about i915 hangs in dmesg on boot-time when running with SNA.

I would like if there will be a fix for that without changing the "AccelMethod" option.

Sabuj Pattanayek (sabujp) wrote :

This happens for me with several applications, e.g. glxgears, cheese, flash 11.2 r202 in firefox (but not in google-chrome with pepper flash) on 13.04. It was ok with 12.04 and 12.10 .

00:02.0 VGA compatible controller: Intel Corporation Core Processor Integrated Graphics Controller (rev 12)
Dell Vostro 3400

libgl1-mesa-dri:amd64 9.1.1-0ubuntu3
libgl1-mesa-dri:i386 9.1.1-0ubuntu3
libgl1-mesa-glx:amd64 9.1.1-0ubuntu3
libgl1-mesa-glx:i386 9.1.1-0ubuntu3
xserver-xorg-video-intel 2:2.21.6-0ubuntu

uxa seems to "work" but I see this at the end of Xorg.0.log :

[455319.129] (EE) intel(0): Detected a hung GPU, disabling acceleration.
[455319.129] (EE) intel(0): When reporting this, please include i915_error_state from debugfs and the full dmesg.

If I don't use uxa I can get the programs to work if I use :

LIBGL_ALWAYS_SOFTWARE=1 ./program (e.g. glxgears)

This reliably happens to me when dragging a firefox window from one monitor to another in 13.04. As above, unity --replace fails and I have to reboot the computer to make it work again. It seems to have started just a week or two ago.

Hardware/software info:

Dell Latitude E6410
00:02.0 VGA compatible controller [0300]: Intel Corporation Core Processor Integrated Graphics Controller [8086:0046] (rev 02)

ii libgl1-mesa-dri:amd64 9.1.7-1ubuntu2 amd64 free implementation of the OpenGL API -- DRI modules
ii xserver-xorg-video-intel 2:2.21.6-0ubuntu4.3 amd64 X.Org X server -- Intel i8xx, i9xx display driver

In dmesg, I see:

[ 280.763186] [drm:i915_hangcheck_hung] *ERROR* Hangcheck timer elapsed... GPU hung
[ 280.763195] [drm] capturing error event; look for more information in /debug/dri/0/i915_error_state
[ 282.750114] [drm:i915_hangcheck_hung] *ERROR* Hangcheck timer elapsed... GPU hung
[ 282.750272] [drm:i915_reset] *ERROR* GPU hanging too fast, declaring wedged!
[ 282.750275] [drm:i915_reset] *ERROR* Failed to reset chip.

I'm not sure how to see /debug/dri/0/i915_error_state - is there a /debug filesystem I can mount or something?

Ah, I see. Here is my i915_error_state

Sorry for the spam, but this just happened again. This time I was dragging a Terminal window around which was running "top" while the machine was under load (load average between 4 and 5). I didn't cross monitors so that's probably a red herring.

Everything froze, but by switching to VT 1 and back (Ctrl-Alt-F1, Ctrl-Alt-F7) I was able to regain control by relaunching unity with LIBGL_ALWAYS_SOFTWARE=1 from that window.

I am sure I didn't have this problem just a week or two ago, sorry I can't be more specific other than that I am running 13.04.

To post a comment you must log in.