compiz/unity crashes when switching task (Alt-Tab) - always

Bug #931163 reported by David Verbeiren on 2012-02-12
20
This bug affects 3 people
Affects Status Importance Assigned to Milestone
unity (Ubuntu)
Medium
Unassigned

Bug Description

No task switcher shows up; instead window decorations disappear, keyboard interaction is lost. Usually unityquickly restarts but sometimes it doesn't and I have to kill my session.
Happens regardless of applications running.
Ubuntu 11.10 with default settings.
Hardware: Intel® Core™ i5-2430M; using HD3000 integrated graphics

ProblemType: Crash
DistroRelease: Ubuntu 11.10
Package: unity 4.28.0-0ubuntu2
ProcVersionSignature: Ubuntu 3.0.0-15.26-generic 3.0.13
Uname: Linux 3.0.0-15-generic i686
ApportVersion: 1.23-0ubuntu4
Architecture: i386
Date: Sun Feb 12 22:52:53 2012
ExecutablePath: /usr/bin/compiz
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release i386 (20111012)
ProcCmdline: compiz
SegvAnalysis:
 Segfault happened at: 0x1a9d091 <_ZN5unity8switcher18SwitcherController28CompareSwitcherItemsPriorityEP20AbstractLauncherIconS3_+33>: mov (%esi),%eax
 PC (0x01a9d091) ok
 source "(%esi)" (0x2b55c668) not located in a known VMA region (needed readable region)!
 destination "%eax" ok
SegvReason: reading unknown VMA
Signal: 11
SourcePackage: unity
StacktraceTop:
 unity::switcher::SwitcherController::CompareSwitcherItemsPriority(AbstractLauncherIcon*, AbstractLauncherIcon*) () from /usr/lib/compiz/libunityshell.so
 void std::__insertion_sort<__gnu_cxx::__normal_iterator<AbstractLauncherIcon**, std::vector<AbstractLauncherIcon*, std::allocator<AbstractLauncherIcon*> > >, bool (*)(AbstractLauncherIcon*, AbstractLauncherIcon*)>(__gnu_cxx::__normal_iterator<AbstractLauncherIcon**, std::vector<AbstractLauncherIcon*, std::allocator<AbstractLauncherIcon*> > >, __gnu_cxx::__normal_iterator<AbstractLauncherIcon**, std::vector<AbstractLauncherIcon*, std::allocator<AbstractLauncherIcon*> > >, bool (*)(AbstractLauncherIcon*, AbstractLauncherIcon*)) () from /usr/lib/compiz/libunityshell.so
 unity::switcher::SwitcherController::Show(unity::switcher::SwitcherController::ShowMode, unity::switcher::SwitcherController::SortMode, bool, std::vector<AbstractLauncherIcon*, std::allocator<AbstractLauncherIcon*> >) () from /usr/lib/compiz/libunityshell.so
 UnityScreen::altTabInitiateCommon(CompAction*, unsigned int, std::vector<CompOption, std::allocator<CompOption> >&) () from /usr/lib/compiz/libunityshell.so
 UnityScreen::altTabForwardInitiate(CompAction*, unsigned int, std::vector<CompOption, std::allocator<CompOption> >&) () from /usr/lib/compiz/libunityshell.so
Title: compiz crashed with SIGSEGV in unity::switcher::SwitcherController::CompareSwitcherItemsPriority()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

David Verbeiren (dverbeir) wrote :

StacktraceTop:
 unity::switcher::SwitcherController::CompareSwitcherItemsPriority (first=0x9586510, second=0x2b55c668) at /build/buildd/unity-4.28.0/plugins/unityshell/src/SwitcherController.cpp:354
 std::__insertion_sort<__gnu_cxx::__normal_iterator<AbstractLauncherIcon**, std::vector<AbstractLauncherIcon*, std::allocator<AbstractLauncherIcon*> > >, bool (*)(AbstractLauncherIcon*, AbstractLauncherIcon*)> (__first=..., __last=..., __comp=0x1a9d070 <unity::switcher::SwitcherController::CompareSwitcherItemsPriority(AbstractLauncherIcon*, AbstractLauncherIcon*)>) at /usr/include/c++/4.6/bits/stl_algo.h:2129
 __final_insertion_sort<__gnu_cxx::__normal_iterator<AbstractLauncherIcon**, std::vector<AbstractLauncherIcon*> >, bool (*)(AbstractLauncherIcon*, AbstractLauncherIcon*)> (__last=<optimized out>, __first=<optimized out>, __comp=<optimized out>) at /usr/include/c++/4.6/bits/stl_algo.h:2201
 sort<__gnu_cxx::__normal_iterator<AbstractLauncherIcon**, std::vector<AbstractLauncherIcon*> >, bool (*)(AbstractLauncherIcon*, AbstractLauncherIcon*)> (__comp=<optimized out>, __last=<optimized out>, __first=<optimized out>) at /usr/include/c++/4.6/bits/stl_algo.h:5370
 unity::switcher::SwitcherController::Show (this=0x94850f0, show=unity::switcher::SwitcherController::ALL, sort=unity::switcher::SwitcherController::FOCUS_ORDER, reverse=false, results=...) at /build/buildd/unity-4.28.0/plugins/unityshell/src/SwitcherController.cpp:74

Changed in unity (Ubuntu):
importance: Undecided → Medium
tags: removed: need-i386-retrace
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity (Ubuntu):
status: New → Confirmed
visibility: private → public
Jason Smith (jassmith) wrote :

This bug is fixed in trunk and 5.2 I believe

Changed in unity (Ubuntu):
status: Confirmed → Fix Released

Will this fix be released for Oneiric? It's a regression that occurred relatively recently, so I shouldn't have to wait for Precise to get the fix.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers