lenses are loaded on start, should be lazy loaded

Bug #929506 reported by Sebastien Bacher on 2012-02-09
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
High
Michal Hruby
Unity Distro Priority
High
Unassigned
unity-2d
High
Unassigned
unity (Ubuntu)
High
Michal Hruby

Bug Description

Using unity trunk from today (but precise 5.2 does the same), all the lenses are loaded at loading which slow down loading, shouldn't they be lazy loaded on first dash use?

That's due to the new dash code according to mhr3

Related branches

Didier Roche (didrocks) on 2012-02-09
Changed in unity-distro-priority:
status: New → Triaged
importance: Undecided → High
Changed in unity:
status: New → Triaged
importance: Undecided → High
Changed in unity (Ubuntu):
status: New → Triaged
importance: Undecided → High
Changed in unity:
milestone: none → 5.4.0
Omer Akram (om26er) on 2012-02-13
Changed in unity:
assignee: nobody → Michal Hruby (mhr3)
status: Triaged → In Progress
Changed in unity (Ubuntu):
status: Triaged → In Progress
assignee: nobody → Michal Hruby (mhr3)
Didier Roche (didrocks) on 2012-02-14
Changed in unity:
milestone: 5.4.0 → 5.6.0
David Barth (dbarth) on 2012-02-17
Changed in unity (Ubuntu):
milestone: none → ubuntu-12.04-beta-1
Changed in unity-2d:
status: New → Confirmed
importance: Undecided → High
Tim Penhey (thumper) on 2012-02-20
tags: added: distro-priority
Changed in unity:
status: In Progress → Fix Committed
Martin Pitt (pitti) on 2012-03-02
Changed in unity (Ubuntu):
milestone: ubuntu-12.04-beta-1 → ubuntu-12.04-beta-2
Didier Roche (didrocks) on 2012-03-12
Changed in unity:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (4.1 KiB)

This bug was fixed in the package unity - 5.6.0-0ubuntu1

---------------
unity (5.6.0-0ubuntu1) precise; urgency=low

  * New upstream release.
    - compiz crashed with SIGSEGV in g_type_check_instance_cast()
      (LP: #862972)
    - compiz crashed with SIGABRT in __gnu_cxx::__verbose_terminate_handler()
      (LP: #926793)
    - compiz crashed with SIGSEGV in gdk_pixbuf_get_width() (LP: #937421)
    - Unity causes ibus to not work correctly (spaces incorrectly placed)
      (LP: #880876)
    - Dash - update Dash keyboard shortcuts so the 'CTRL + TAB' switches
      between Lenses and 'TAB' by itself moves the focus between categories
      (LP: #891648)
    - HUD - closing a window with <Alt>+<F4> opens the hud (LP: #923410)
    - unity-applications-daemon crashed with SIGSEGV in
      dee_sequence_model_free_row() (LP: #916356)
    - Launcher, Window Management - Launcher reveal should not be triggered
      when dragging a window (LP: #928805)
    - lenses are loaded on start, should be lazy loaded (LP: #929506)
    - Trash icon jumps about when trying to drag an icon onto it (LP: #932365)
    - HUD loses keypresses for the first second after opening (LP: #932906)
    - HUD doesn't give the focus back to the active application after dash/hud
      use (LP: #934061)
    - Launcher - unpinned apps show with empty pips in the launcher as if they
      exist on another workspace (LP: #937898)
    - Unity Dash should support Keywords parameter in .desktop (formerly X
      -GNOME-Keywords or X-AppInstall-Keywords) (LP: #941231)
    - Support FD.o Desktop Actions spec (LP: #942042)
    - Unity hangs when touching my touchpad/trackpad (LP: #942625)
    - [regression] Pressing alt doesn't show the menu title bar in top panel
      (LP: #943194)
    - Alt + F (or other mnemonic) doesn't work in gnome-terminal (LP: #943239)
    - [unity 5.6] Using Alt+F1 or Alt+F2 sends a ";3P" or ";3Q" to the active
      windows (LP: #943456)
    - [unity 5.6] holding alt and pressing a direction opens the alt-tab list
      in a buggy way (LP: #943902)
    - [unity-5.6] can't enter accents (^o->) in the dash since recent updates
      (LP: #944674)
    - Dash - Keyboard navigation for search filters is broken (LP: #844033)
    - Dash - If mouse highlights one icon in grid, keyboard navigation
      highlights another, so there are 2 highlighted icons (LP: #817436)
    - Alt+Tab default delay of 150ms is too long (LP: #888636)
    - Keyboard shortcut - F10 shortcut is used to show menu and this is wrong
      (LP: #878492)
    - Dash - Currently the app lens doesn't show applications that are
      available for purchase (LP: #916121)
    - Chromium is running, but not showing in launcher or alt-tab.
      (LP: #918474)
    - Dash - Different states of rating stars, and dimensions (LP: #924884)
    - alt-tab confused by a multiple instances of an application on different
      workspaces (LP: #925484)
    - Launcher - Icons are not colorized properly (LP: #930949)
    - Remove glow from Alt-tab edge and Search Field image assets
      (LP: #933578)
    - "Left Mouse Drag" and "Middle Mouse Drag" should be translatable
      (LP: #930510)
    - Launcher switcher...

Read more...

Changed in unity (Ubuntu):
status: In Progress → Fix Released
Didier Roche (didrocks) on 2012-03-14
Changed in unity-distro-priority:
status: Triaged → Fix Released
Gerry Boland (gerboland) on 2012-03-14
Changed in unity-2d:
milestone: none → 5.8
status: Confirmed → Fix Committed
Didier Roche (didrocks) on 2012-03-15
Changed in unity-2d:
milestone: 5.8 → 5.7
Didier Roche (didrocks) on 2012-03-19
Changed in unity-2d:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers