Log nautilus file operations with Zeitgeist

Bug #927544 reported by Siegfried Gevatter on 2012-02-06
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Nautilus
Confirmed
Wishlist
Unity
Fix Released
Medium
Siegfried Gevatter
nautilus (Ubuntu)
Wishlist
Siegfried Gevatter
unity (Ubuntu)
Undecided
Unassigned

Bug Description

Logging file creation and move events with Zeitgeist will make sure they can be found from Unity.

This patch is part of a bigger effort to enhance Zeitgeist integration into the desktop. It goes together with Gtk 2+3 patches to ensure that save+open dialogs log to Zeitgeist as well as some improvements to the Zeitgeist Datahub. This means we can compile a feature matrix ala:

                                   O P
Log files from Qt apps in Gnome - +
Log files from KDE apps/sessions - +
Save attachment in Thunderbird - +
Save attachment in Evolution - +
Download outside ~/Downloads in FF - +
Copied file with Nautilus - +
Renamed file with Nautilus - +
Moved file with Nautilus - +
Print to PDF or PS - + (is this branch landed? (for gtk 2+3?))
Copy/create file by other mean - -
Rename file by other mean - -
Move file by other mean - -

Related branches

Changed in nautilus (Ubuntu):
assignee: nobody → Siegfried Gevatter (rainct)
Changed in nautilus:
importance: Unknown → Medium
status: Unknown → New
Sebastien Bacher (seb128) wrote :

Thank Siegfried, I will try to review that this bug

Changed in nautilus (Ubuntu):
importance: Undecided → Wishlist
status: New → Confirmed
Sebastien Bacher (seb128) wrote :

I've uploaded nautilus with that patch to https://launchpad.net/~ubuntu-desktop/+archive/ppa for testing

description: updated
summary: - Log file operations with Zeitgeist
+ Log nautilus file operations with Zeitgeist
Changed in unity:
assignee: nobody → Siegfried Gevatter (rainct)
importance: Undecided → Medium
milestone: none → 5.6.0
status: New → In Progress
Changed in nautilus (Ubuntu):
status: Confirmed → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nautilus - 1:3.3.90-0ubuntu4

---------------
nautilus (1:3.3.90-0ubuntu4) precise; urgency=low

  * debian/control.in:
    - Build-Depends on libzeitgeist-dev
  * debian/patches/02_additional_marge_for_unity.patch:
    - dropped, it's not required with the current launcher hidding
      behaviour (it was to deal with intellihide) and create margin issues
      (lp: #936958)
  * debian/patches/zg_activity_logging.patch:
    - "Logging file creation and move events with Zeitgeist will make sure
       they can be found from Unity", thanks Siegfried Gevatter (lp: #927544)

  [ Michael Terry ]
  * debian/patches/22_fix_crash_from_extra_slot_ref.patch:
    - Don't crash when emptying the trash while unmounting an SD card
      LP: #929031
 -- Sebastien Bacher <email address hidden> Thu, 01 Mar 2012 21:24:46 +0100

Changed in nautilus (Ubuntu):
status: In Progress → Fix Released
Didier Roche (didrocks) on 2012-03-12
Changed in unity:
milestone: 5.6.0 → 5.8.0
Didier Roche (didrocks) on 2012-03-23
Changed in unity:
milestone: 5.8.0 → 5.10.0
Omer Akram (om26er) on 2012-03-27
Changed in unity:
status: In Progress → Fix Released
milestone: 5.10.0 → none
Changed in nautilus:
importance: Medium → Wishlist
status: New → Confirmed
gf (gf-interlinks) wrote :

Hello Siegfried,
Thank you for submitting this bug and reporting a problem with nautilus file operations. You made this bug report in 2012 and there have been several versions of Ubuntu since then.

Could you confirm that this is no longer a problem and that we can close the ticket?
If it is still a problem, are you still interested in finding a solution to this bug?
If you are, could you run the following (only once):
apport-collect 927544
and upload the updated logs and and any other logs that are relevant for this particular issue.

Thank you again for helping make Ubuntu better.
G

Changed in unity (Ubuntu):
status: New → Incomplete
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.