compiz crashed with SIGABRT in __gnu_cxx::__verbose_terminate_handler()

Bug #926793 reported by Thomas on 2012-02-04
152
This bug affects 24 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
Critical
Brandon Schaefer
unity (Ubuntu)
Critical
Unassigned

Bug Description

It just crashed when I was in the "run" windows (ALT+F2) and whanted to paste my command there....

ProblemType: Crash
DistroRelease: Ubuntu 12.04
Package: unity 5.2.0-0ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-12.21-generic-pae 3.2.2
Uname: Linux 3.2.0-12-generic-pae i686
NonfreeKernelModules: nvidia
ApportVersion: 1.91-0ubuntu1
Architecture: i386
Date: Sat Feb 4 19:02:18 2012
EcryptfsInUse: Yes
ExecutablePath: /usr/bin/compiz
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Alpha i386 (20120201.1)
ProcCmdline: compiz
ProcEnviron:
 PATH=(custom, user)
 LANG=de_DE.UTF-8
 SHELL=/bin/bash
Signal: 6
SourcePackage: unity
StacktraceTop:
 raise () from /lib/i386-linux-gnu/libc.so.6
 abort () from /lib/i386-linux-gnu/libc.so.6
 __gnu_cxx::__verbose_terminate_handler() () from /usr/lib/i386-linux-gnu/libstdc++.so.6
 ?? () from /usr/lib/i386-linux-gnu/libstdc++.so.6
 std::terminate() () from /usr/lib/i386-linux-gnu/libstdc++.so.6
Title: compiz crashed with SIGABRT in raise()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo

Related branches

Thomas (t.c) wrote :

StacktraceTop:
 __gnu_cxx::__verbose_terminate_handler () at ../../../../src/libstdc++-v3/libsupc++/vterminate.cc:95
 __cxxabiv1::__terminate (handler=0xb6f8cff0 <__gnu_cxx::__verbose_terminate_handler()>) at ../../../../src/libstdc++-v3/libsupc++/eh_terminate.cc:40
 std::terminate () at ../../../../src/libstdc++-v3/libsupc++/eh_terminate.cc:50
 __cxxabiv1::__cxa_throw (obj=0xaaee410, tinfo=0xb6fb8f2c, dest=0xb6f34c00 <std::out_of_range::~out_of_range()>) at ../../../../src/libstdc++-v3/libsupc++/eh_throw.cc:83
 std::__throw_out_of_range (__s=0xb6f97da3 "basic_string::insert") at ../../../../src/libstdc++-v3/src/functexcept.cc:82

Changed in unity (Ubuntu):
importance: Undecided → Medium
summary: - compiz crashed with SIGABRT in raise()
+ compiz crashed with SIGABRT in __gnu_cxx::__verbose_terminate_handler()
tags: removed: need-i386-retrace
Thomas (t.c) on 2012-02-06
visibility: private → public
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity (Ubuntu):
status: New → Confirmed
Viorel Lazar (viorelmarius) wrote :

the crash appear when ctrl+v pressed over already selected text in unity dash search, but if I delete the text and then paste the content it's no problem. Also it should support right clic mouse actions ( but it doesn't )

yeah, as i wrote. i accidentally pasted the text from the clipboard and ht enter..

thanks a lot.

-------- Original-Nachricht --------
> Datum: Tue, 21 Feb 2012 11:02:26 -0000
> Von: Viorel Lazar <email address hidden>
> An: <email address hidden>
> Betreff: [Bug 926793] Re: compiz crashed with SIGABRT in __gnu_cxx::__verbose_terminate_handler()

> the crash appear when ctrl+v pressed over already selected text in unity
> dash search, but if I delete the text and then paste the content it's no
> problem. Also it should support right clic mouse actions ( but it
> doesn't )
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (936128).
> https://bugs.launchpad.net/bugs/926793
>
> Title:
> compiz crashed with SIGABRT in
> __gnu_cxx::__verbose_terminate_handler()
>
> Status in “unity” package in Ubuntu:
> Confirmed
>
> Bug description:
> It just crashed when I was in the "run" windows (ALT+F2) and whanted
> to paste my command there....
>
> ProblemType: Crash
> DistroRelease: Ubuntu 12.04
> Package: unity 5.2.0-0ubuntu1
> ProcVersionSignature: Ubuntu 3.2.0-12.21-generic-pae 3.2.2
> Uname: Linux 3.2.0-12-generic-pae i686
> NonfreeKernelModules: nvidia
> ApportVersion: 1.91-0ubuntu1
> Architecture: i386
> Date: Sat Feb 4 19:02:18 2012
> EcryptfsInUse: Yes
> ExecutablePath: /usr/bin/compiz
> InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Alpha i386
> (20120201.1)
> ProcCmdline: compiz
> ProcEnviron:
> PATH=(custom, user)
> LANG=de_DE.UTF-8
> SHELL=/bin/bash
> Signal: 6
> SourcePackage: unity
> StacktraceTop:
> raise () from /lib/i386-linux-gnu/libc.so.6
> abort () from /lib/i386-linux-gnu/libc.so.6
> __gnu_cxx::__verbose_terminate_handler() () from
> /usr/lib/i386-linux-gnu/libstdc++.so.6
> ?? () from /usr/lib/i386-linux-gnu/libstdc++.so.6
> std::terminate() () from /usr/lib/i386-linux-gnu/libstdc++.so.6
> Title: compiz crashed with SIGABRT in raise()
> UpgradeStatus: No upgrade log present (probably fresh install)
> UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu/+source/unity/+bug/926793/+subscriptions

--

Anne-Minou Fengler
Tel: 0049 (0)1525 3709513
e-Mail: <email address hidden>

Omer Akram (om26er) on 2012-02-21
Changed in unity (Ubuntu):
importance: Medium → Critical
Changed in unity:
importance: Undecided → Critical
status: New → Confirmed
Tim Penhey (thumper) on 2012-02-22
Changed in unity:
milestone: none → 5.6.0
Tim Penhey (thumper) on 2012-02-23
Changed in unity:
status: Confirmed → In Progress
assignee: nobody → Brandon Schaefer (brandontschaefer)

Fix:
In the unity.text-entry-im branch

Test Coverage:
In the unity-fix-middle-paste-reg branch

Changed in unity:
status: In Progress → Fix Committed
tags: added: bugpattern-needed
blackgoat-bj (oliveryty) wrote :

The hotkey "ctrl+F2" is not so easy to use.... It always broke...

Didier Roche (didrocks) on 2012-03-12
Changed in unity:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (4.1 KiB)

This bug was fixed in the package unity - 5.6.0-0ubuntu1

---------------
unity (5.6.0-0ubuntu1) precise; urgency=low

  * New upstream release.
    - compiz crashed with SIGSEGV in g_type_check_instance_cast()
      (LP: #862972)
    - compiz crashed with SIGABRT in __gnu_cxx::__verbose_terminate_handler()
      (LP: #926793)
    - compiz crashed with SIGSEGV in gdk_pixbuf_get_width() (LP: #937421)
    - Unity causes ibus to not work correctly (spaces incorrectly placed)
      (LP: #880876)
    - Dash - update Dash keyboard shortcuts so the 'CTRL + TAB' switches
      between Lenses and 'TAB' by itself moves the focus between categories
      (LP: #891648)
    - HUD - closing a window with <Alt>+<F4> opens the hud (LP: #923410)
    - unity-applications-daemon crashed with SIGSEGV in
      dee_sequence_model_free_row() (LP: #916356)
    - Launcher, Window Management - Launcher reveal should not be triggered
      when dragging a window (LP: #928805)
    - lenses are loaded on start, should be lazy loaded (LP: #929506)
    - Trash icon jumps about when trying to drag an icon onto it (LP: #932365)
    - HUD loses keypresses for the first second after opening (LP: #932906)
    - HUD doesn't give the focus back to the active application after dash/hud
      use (LP: #934061)
    - Launcher - unpinned apps show with empty pips in the launcher as if they
      exist on another workspace (LP: #937898)
    - Unity Dash should support Keywords parameter in .desktop (formerly X
      -GNOME-Keywords or X-AppInstall-Keywords) (LP: #941231)
    - Support FD.o Desktop Actions spec (LP: #942042)
    - Unity hangs when touching my touchpad/trackpad (LP: #942625)
    - [regression] Pressing alt doesn't show the menu title bar in top panel
      (LP: #943194)
    - Alt + F (or other mnemonic) doesn't work in gnome-terminal (LP: #943239)
    - [unity 5.6] Using Alt+F1 or Alt+F2 sends a ";3P" or ";3Q" to the active
      windows (LP: #943456)
    - [unity 5.6] holding alt and pressing a direction opens the alt-tab list
      in a buggy way (LP: #943902)
    - [unity-5.6] can't enter accents (^o->) in the dash since recent updates
      (LP: #944674)
    - Dash - Keyboard navigation for search filters is broken (LP: #844033)
    - Dash - If mouse highlights one icon in grid, keyboard navigation
      highlights another, so there are 2 highlighted icons (LP: #817436)
    - Alt+Tab default delay of 150ms is too long (LP: #888636)
    - Keyboard shortcut - F10 shortcut is used to show menu and this is wrong
      (LP: #878492)
    - Dash - Currently the app lens doesn't show applications that are
      available for purchase (LP: #916121)
    - Chromium is running, but not showing in launcher or alt-tab.
      (LP: #918474)
    - Dash - Different states of rating stars, and dimensions (LP: #924884)
    - alt-tab confused by a multiple instances of an application on different
      workspaces (LP: #925484)
    - Launcher - Icons are not colorized properly (LP: #930949)
    - Remove glow from Alt-tab edge and Search Field image assets
      (LP: #933578)
    - "Left Mouse Drag" and "Middle Mouse Drag" should be translatable
      (LP: #930510)
    - Launcher switcher...

Read more...

Changed in unity (Ubuntu):
status: Confirmed → Fix Released
Taras (tiras-dude) wrote :

Recurfaced in Saucy AMD64 Intel graphics card.

El 18/09/13 18:04, Taras escribió:
> Recurfaced in Saucy AMD64 Intel graphics card.
>
You can then open a new report as explained at
https://wiki.ubuntu.com/ReportingBugs.

tags: added: saucy
tags: removed: saucy
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers