application reopens itself when last instance is closed from windows/application switcher

Bug #926406 reported by Jean-Baptiste Lallement on 2012-02-03
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Fix Released
Brandon Schaefer
Fix Released
Brandon Schaefer
unity (Ubuntu)

Bug Description

1. Launch an application (nautilus, gedit, gcalctool, ...)
2. Activate the windows switcher (ALT+Grave) and select the window
3. Keep ALT pressed and close it with the keyboard shortcut ALT+F4
4. Release ALT to close the switcher

The application reopens. Same result if the application is closed from the application switcher

It should stay closed.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: unity 5.2.0-0ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-12.21-generic 3.2.2
Uname: Linux 3.2.0-12-generic x86_64
ApportVersion: 1.91-0ubuntu1
Architecture: amd64
CompizPlugins: [core,bailer,detection,composite,opengl,decor,mousepoll,vpswitch,regex,animation,snap,expo,move,compiztoolbox,place,grid,imgpng,gnomecompat,wall,ezoom,workarounds,resize,fade,unitymtgrabhandles,scale,session,unityshell]
Date: Sat Feb 4 00:16:36 2012
EcryptfsInUse: Yes
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release amd64 (20111012)
 PATH=(custom, user)
SourcePackage: unity
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Jean-Baptiste Lallement (jibel) wrote :
summary: - application reopens itself when last instance is closed from windows
- switcher
+ application reopens itself when last instance is closed from
+ windows/application switcher
description: updated
David Barth (dbarth) on 2012-02-15
Changed in unity (Ubuntu):
assignee: nobody → Jason Smith (jassmith)
importance: Undecided → Medium
Changed in unity:
milestone: none → 5.6.0
assignee: nobody → Jason Smith (jassmith)
importance: Undecided → Medium
status: New → Triaged
Changed in unity (Ubuntu):
status: New → Triaged
milestone: none → ubuntu-12.04-beta-1
Martin Pitt (pitti) on 2012-03-02
Changed in unity (Ubuntu):
milestone: ubuntu-12.04-beta-1 → ubuntu-12.04-beta-2
Didier Roche (didrocks) on 2012-03-12
Changed in unity:
milestone: 5.6.0 → 5.8.0
Didier Roche (didrocks) on 2012-03-23
Changed in unity:
milestone: 5.8.0 → 5.10.0
Martin Pitt (pitti) on 2012-03-30
Changed in unity (Ubuntu):
milestone: ubuntu-12.04-beta-2 → ubuntu-12.04
Didier Roche (didrocks) on 2012-04-12
Changed in unity:
milestone: 5.10.0 → 5.12.0
Didier Roche (didrocks) on 2012-04-27
Changed in unity:
milestone: 5.12.0 → 5.14.0
Changed in unity:
assignee: Jason Smith (jassmith) → nobody
Changed in unity (Ubuntu):
assignee: Jason Smith (jassmith) → nobody
Nick Dedekind (nick-dedekind) wrote :

I believe Alt+F4 closes the window that had focus when you opened the switcher, not the currently selected app in the switcher.

I think that either Alt+F4 needs to be intercepted and thrown away when the switcher is open, or it needs to close the currently selected app in the switcher.

Changed in unity:
assignee: nobody → Brandon Schaefer (brandontschaefer)
status: Triaged → In Progress
Changed in unity:
status: In Progress → Fix Committed
Changed in unity:
milestone: 5.14.0 → 6.0
Omer Akram (om26er) on 2012-06-28
Changed in unity (Ubuntu):
status: Triaged → Fix Committed
milestone: ubuntu-12.04 → none
Didier Roche (didrocks) on 2012-07-10
Changed in unity:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (5.8 KiB)

This bug was fixed in the package unity - 6.0.0-0ubuntu1

unity (6.0.0-0ubuntu1) quantal-proposed; urgency=low

  [ Didier Roche ]
  * debian/rules, debian/control, debian/unity-autopilot.install:
    - install new unity-autopilot package, containing autopilot bindings and
      test for Unity
    - add some python build-dep for executing
    - use dh_python2 and add some python:Depends dep for automatic python
      version detection
  * debian/control:
    - remove gnome-desktop dependency: not needed upstream anymore
    - unity Breaks older lenses due to path change
    - remove libgdu in build-dep
  * debian/libunity-core-6.0-5.install, debian/libunity-core-6.0-dev.install,
    - version bump in libunity-core, change soname

  [ Matthieu Baerts (matttbe) ]
  * Update apport hook for python3 ; thanks to Edward Donovan (LP: #1013171)

  [ Łukasz 'sil2100' Zemczak ]
  * New upstream release.
    - compiz crashed with SIGSEGV in get_current_slide() from
      unity::BGHash::OnSlideshowTransition() (LP: #889625)
    - Unity is visible on top of fullscreen apps (LP: #734908)
    - App icon on the Unity Launcher lost track of running instance
      (LP: #772063)
    - unity crashed with NameError in reset_unity_compiz_profile(): global
      name 'GError' is not defined (LP: #778470)
    - compiz crashed with SIGSEGV in CompWindow::id() from getPaintMask()
      [compizminimizedwindowhandler.h] from unity::UnityWindow::glPaint()
      (LP: #851982)
    - HUD - Formatting of text in the auto-complete is wrong (LP: #939436)
    - [regression] Launcher is silent to screen reader users (LP: #949448)
    - still some accent issues with unity/nux (LP: #950740)
    - [regression] [precise] 3D apps run much slower under Unity (LP: #987304)
    - No launcher icon or Alt+Tab entry for Gimp windows (LP: #995916)
    - Locked smuxi launcher icon does not indicate smuxi running status
      (LP: #999820)
    - When number of workspaces is set to 1, the Spread no longer works
      (LP: #996604)
    - Much slower OpenGL frame rates with unityshell loaded, than plain compiz
      (LP: #988079)
    - Port to libudisks2 (LP: #1012000)
    - Desktop, Launcher and menu bar still visible when screen locked
      (LP: #886605)
    - Searching in the HUD freezes unity (LP: #1016239)
    - Dragged icons rendered under dash (LP: #1021541)
    - Regression in Launcher keyboard navigation (with Alt+F1) (LP: #1021549)
    - Unity dash is is much slower/laggy after revision 2469. (LP: #1021665)
    - Dash and Launcher - As soon as a user starts dragging a file from the
      Dash, there is a 'flicker' before the Launcher icons that are valid drop
      receptacles re-saturate (LP: #863230)
    - Dash - when a file is dragged from the Dash (Dash home, file lens, or
      music lens) and dropped on a Launcher icon, the Dash should
      automatically close (LP: #865168)
    - Refreshing active blur makes the dash painfully slow (LP: #874230)
    - Open dash, press Alt+f1 - dash remains open (LP: #919209)
    - application reopens itself when last instance is closed from
      windows/application switcher (LP: #926406)
    - HUD D...


Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers