Overlay should refer to "Menu Bar" not "Top Bar"

Bug #926213 reported by Jeremy Bicha on 2012-02-03
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ayatana Design
Undecided
Matthew Paul Thomas
Unity
Fix Released
Low
Unassigned
unity (Ubuntu)
Low
Unassigned

Bug Description

Hold the Super/Windows key to open the keyboard shortcuts help overlay. At the bottom left, it says "top bar" but it should say "menu bar.

https://wiki.ubuntu.com/MenuBar

Examples of "menu bar" usage
In Time & Date Settings, switch to the Clock tab. It says "Show a clock in the menu bar."
In the battery menu, it says "Show Time in Menu Bar".

Branch attached.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: unity 5.2.0-0ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-12.21-generic 3.2.2
Uname: Linux 3.2.0-12-generic x86_64
ApportVersion: 1.91-0ubuntu1
Architecture: amd64
CompizPlugins: [core,bailer,detection,composite,opengl,decor,mousepoll,vpswitch,regex,animation,snap,expo,move,compiztoolbox,place,grid,imgpng,gnomecompat,wall,ezoom,workarounds,resize,fade,unitymtgrabhandles,scale,session,unityshell]
Date: Fri Feb 3 12:05:31 2012
SourcePackage: unity
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Jeremy Bicha (jbicha) wrote :
Robert Roth (evfool) on 2012-02-03
Changed in unity (Ubuntu):
status: New → Confirmed
importance: Undecided → Low
Omer Akram (om26er) wrote :

please link your branch here as well.

Changed in unity:
status: New → Confirmed
importance: Undecided → Low

At first glance, this looks correct.

However, in the tablet, tv and other form factors, we have indicators
but not menus. I wonder whether that doesn't suggest a different name,
like 'panel'?

Jeremy Bicha (jbicha) wrote :

As doctormo pointed out in a recent Ayatana discussion that unfortunately I can't seem to be able to link to today:

> "Panel' is a normal noun for anything made with a wood finish"

I suppose "bar" is an overloaded term too, but I think bar makes more sense on a computer to non-GNOME 2 users than panel does.

I believe the consensus from multiple Ayatana (& Documentation) discussions over the past year or so is that we should use either "top bar" or "menu bar" and be consistent about it. Mark, you are of course aware that indicators are menus. In fact, in user documentation, I prefer to call indicators "status menus" as presented at https://wiki.ubuntu.com/MenuBar

I strongly prefer "menu bar" even if the bar doesn't contain app menus because it will still have status menus, and app menus won't be going away from Ubuntu's standard home/office install any time soon.

Mark Shuttleworth (sabdfl) wrote :

OK, +1 from me to Menu Bar. Let's get a read from MPT, if he's +1 too
then you can consider it done.

Mark

Matthew Paul Thomas (mpt) wrote :

Thanks Jeremy. I think normally "menu bar" shouldn't be capitalized, but in this case it looks to be used as a category title where they're all capitalized, so it's fine.

As for "indicators", the indistinctness of that term was demonstrated in bug 891975 where Ubuntu.com site authors used it to refer to launcher elements. But that problem may be best tackled separately.

Changed in ayatana-design:
assignee: nobody → Matthew Paul Thomas (mpt)
status: New → Fix Committed
Andrea Azzarone (azzar1) on 2012-03-05
Changed in unity:
status: Confirmed → Fix Committed
Changed in unity (Ubuntu):
status: Confirmed → Fix Committed
Didier Roche (didrocks) on 2012-03-12
Changed in unity:
milestone: none → 5.6.0
Didier Roche (didrocks) on 2012-03-12
Changed in unity:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (4.1 KiB)

This bug was fixed in the package unity - 5.6.0-0ubuntu1

---------------
unity (5.6.0-0ubuntu1) precise; urgency=low

  * New upstream release.
    - compiz crashed with SIGSEGV in g_type_check_instance_cast()
      (LP: #862972)
    - compiz crashed with SIGABRT in __gnu_cxx::__verbose_terminate_handler()
      (LP: #926793)
    - compiz crashed with SIGSEGV in gdk_pixbuf_get_width() (LP: #937421)
    - Unity causes ibus to not work correctly (spaces incorrectly placed)
      (LP: #880876)
    - Dash - update Dash keyboard shortcuts so the 'CTRL + TAB' switches
      between Lenses and 'TAB' by itself moves the focus between categories
      (LP: #891648)
    - HUD - closing a window with <Alt>+<F4> opens the hud (LP: #923410)
    - unity-applications-daemon crashed with SIGSEGV in
      dee_sequence_model_free_row() (LP: #916356)
    - Launcher, Window Management - Launcher reveal should not be triggered
      when dragging a window (LP: #928805)
    - lenses are loaded on start, should be lazy loaded (LP: #929506)
    - Trash icon jumps about when trying to drag an icon onto it (LP: #932365)
    - HUD loses keypresses for the first second after opening (LP: #932906)
    - HUD doesn't give the focus back to the active application after dash/hud
      use (LP: #934061)
    - Launcher - unpinned apps show with empty pips in the launcher as if they
      exist on another workspace (LP: #937898)
    - Unity Dash should support Keywords parameter in .desktop (formerly X
      -GNOME-Keywords or X-AppInstall-Keywords) (LP: #941231)
    - Support FD.o Desktop Actions spec (LP: #942042)
    - Unity hangs when touching my touchpad/trackpad (LP: #942625)
    - [regression] Pressing alt doesn't show the menu title bar in top panel
      (LP: #943194)
    - Alt + F (or other mnemonic) doesn't work in gnome-terminal (LP: #943239)
    - [unity 5.6] Using Alt+F1 or Alt+F2 sends a ";3P" or ";3Q" to the active
      windows (LP: #943456)
    - [unity 5.6] holding alt and pressing a direction opens the alt-tab list
      in a buggy way (LP: #943902)
    - [unity-5.6] can't enter accents (^o->) in the dash since recent updates
      (LP: #944674)
    - Dash - Keyboard navigation for search filters is broken (LP: #844033)
    - Dash - If mouse highlights one icon in grid, keyboard navigation
      highlights another, so there are 2 highlighted icons (LP: #817436)
    - Alt+Tab default delay of 150ms is too long (LP: #888636)
    - Keyboard shortcut - F10 shortcut is used to show menu and this is wrong
      (LP: #878492)
    - Dash - Currently the app lens doesn't show applications that are
      available for purchase (LP: #916121)
    - Chromium is running, but not showing in launcher or alt-tab.
      (LP: #918474)
    - Dash - Different states of rating stars, and dimensions (LP: #924884)
    - alt-tab confused by a multiple instances of an application on different
      workspaces (LP: #925484)
    - Launcher - Icons are not colorized properly (LP: #930949)
    - Remove glow from Alt-tab edge and Search Field image assets
      (LP: #933578)
    - "Left Mouse Drag" and "Middle Mouse Drag" should be translatable
      (LP: #930510)
    - Launcher switcher...

Read more...

Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
Nick Tait (jnick-tait) on 2012-04-26
Changed in ayatana-design:
status: Fix Committed → Fix Released
tags: added: reviewedbydesignp
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers