Chromium is running, but not showing in launcher or alt-tab.

Bug #918474 reported by Newfie on 2012-01-19
32
This bug affects 6 people
Affects Status Importance Assigned to Milestone
BAMF
Undecided
Unassigned
Unity
Fix Released
Medium
Jason Smith
Unity Distro Priority
Medium
Unassigned
bamf (Ubuntu)
Undecided
Unassigned
unity (Ubuntu)
Medium
Unassigned

Bug Description

The Chromium browser doesn't seem to be detected as running by Unity.

How to reproduce:

1) Install chromium-browser
2) Add it to your launcher
3) Press the Chromium icon in the launcher.
4) Chromium launchers, but the icon keeps pulsing and eventually goes dim.
5) Try alt-tabbing to the chromium window.

This doesn't happen every time, but it happens enough to be annoying.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: unity 5.0.0-0ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-9.16-generic 3.2.1
Uname: Linux 3.2.0-9-generic x86_64
.tmp.unity.support.test.0:

ApportVersion: 1.90-0ubuntu2
Architecture: amd64
CasperVersion: 1.299
CompizPlugins: [core,bailer,detection,composite,opengl,compiztoolbox,decor,gnomecompat,grid,imgpng,mousepoll,move,place,regex,resize,session,snap,vpswitch,wall,animation,expo,ezoom,fade,scale,unityshell,workarounds]
CompositorRunning: compiz
Date: Thu Jan 19 00:23:08 2012
DistUpgraded: Fresh install
DistroCodename: precise
DistroVariant: ubuntu
GraphicsCard:
 nVidia Corporation G86 [GeForce 8400M GS] [10de:0427] (rev a1) (prog-if 00 [VGA controller])
   Subsystem: Hewlett-Packard Company Device [103c:30cd]
LiveMediaBuild: Ubuntu 12.04 LTS "Precise Pangolin" - Alpha amd64 (20120118)
MachineType: Hewlett-Packard Pavilion dv2817ca (KP044UA#ABC)
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: initrd=/ubninit file=/cdrom/preseed/hostname.seed boot=casper quiet splash -- BOOT_IMAGE=/ubnkern
SourcePackage: unity
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 08/26/2008
dmi.bios.vendor: Phoenix
dmi.bios.version: F.2D
dmi.board.name: 30CE
dmi.board.vendor: Wistron
dmi.board.version: 80.52
dmi.chassis.type: 10
dmi.chassis.vendor: Hewlett-Packard
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnPhoenix:bvrF.2D:bd08/26/2008:svnHewlett-Packard:pnPaviliondv2817ca(KP044UA#ABC):pvrF.2D:rvnWistron:rn30CE:rvr80.52:cvnHewlett-Packard:ct10:cvrN/A:
dmi.product.name: Pavilion dv2817ca (KP044UA#ABC)
dmi.product.version: F.2D
dmi.sys.vendor: Hewlett-Packard
version.compiz: compiz 1:0.9.6+bzr20110929-0ubuntu8
version.ia32-libs: ia32-libs 20090808ubuntu33
version.libdrm2: libdrm2 2.4.30-1ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 7.11-0ubuntu4
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 7.11-0ubuntu4
version.xserver-xorg-core: xserver-xorg-core 2:1.10.4-1ubuntu6
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.6.0-1ubuntu13
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.99~git20110811.g93fc084-0ubuntu1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.15.901-1ubuntu4
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20111201+b5534a1-1

Newfie (mn-newfie) wrote :
Newfie (mn-newfie) wrote :

Happened again, so I recorded it for reference.

Omer Akram (om26er) on 2012-01-20
Changed in unity:
importance: Undecided → Medium
status: New → Confirmed
Changed in unity (Ubuntu):
importance: Undecided → Medium
status: New → Confirmed
Didier Roche (didrocks) on 2012-01-20
Changed in unity-distro-priority:
status: New → Fix Committed
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in bamf (Ubuntu):
status: New → Confirmed
David Barth (dbarth) wrote :

@jassmith: feel free to reassign to Marco if needed

Changed in unity:
assignee: nobody → Jason Smith (jassmith)
milestone: none → 5.6.0
Tim Penhey (thumper) on 2012-02-20
tags: added: distro-priority
Didier Roche (didrocks) on 2012-02-20
Changed in unity-distro-priority:
importance: Undecided → Medium
Jason Smith (jassmith) wrote :

This should be resolved with a memory corruption patch that went in not long ago

Changed in unity:
status: Confirmed → Fix Released
Omer Akram (om26er) on 2012-02-22
Changed in unity (Ubuntu):
status: Confirmed → Fix Released
Changed in bamf (Ubuntu):
status: Confirmed → Fix Released
Changed in bamf:
status: New → Fix Released
Didier Roche (didrocks) on 2012-03-14
Changed in unity-distro-priority:
status: Fix Committed → Fix Released
Adolfo Jayme (fitojb) on 2014-01-11
no longer affects: bamf (Ubuntu Quantal)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers