ibus not getting focus

Bug #915828 reported by Brandon Schaefer on 2012-01-13
26
This bug affects 3 people
Affects Status Importance Assigned to Milestone
OEM Priority Project
Critical
Canonical Desktop Experience Team
Precise
Undecided
Unassigned
Unity
Fix Released
Critical
Brandon Schaefer
unity (Ubuntu)
Critical
Unassigned

Bug Description

The nux::FocusChanged signal was removed; now OnFocusIn() and OnFocusOut() does not get called in IMTextEntry.cpp.

Related branches

Changed in unity:
assignee: nobody → Brandon Schaefer (brandontschaefer)
Changed in unity:
status: New → Confirmed
Didier Roche (didrocks) on 2012-02-01
Changed in unity (Ubuntu):
status: New → Confirmed
Tim Penhey (thumper) on 2012-02-02
Changed in unity:
status: Confirmed → Triaged
status: Triaged → In Progress
importance: Undecided → Critical
milestone: none → 5.4.0
Changed in oem-priority:
assignee: nobody → Canonical Desktop Experience Team (canonical-dx-team)
Changed in oem-priority:
status: New → Confirmed
importance: Undecided → Critical
Omer Akram (om26er) on 2012-02-13
Changed in unity (Ubuntu):
status: Confirmed → In Progress
importance: Undecided → Critical
Michal Hruby (mhr3) on 2012-02-14
Changed in unity:
status: In Progress → Fix Committed
Didier Roche (didrocks) on 2012-02-17
Changed in unity:
status: Fix Committed → Fix Released
Didier Roche (didrocks) on 2012-02-20
Changed in unity (Ubuntu):
status: In Progress → Fix Released
Ray Wang (raywang) wrote :

Hi,This is tested in beta1 release, and looks like it's fixed, but there are two problems I'm not sure it comes with.
1. Click dash show nothing except the search bar
2. After the installation finished (Simplified Chinese selected at the first page), it prompts language support is not completely installed, and you have to add the input method (Pinyin) manually from input method settings before enter the character on dash search bar

Ray Wang (raywang) wrote :

Other than that, when you active ibus on dash search bar, input something to launch an application ,and click "Super" key to launch dash search bar in order to start another application, the ibus popup menu is disappeared, and not able to show up anymore (characters selection popup)

Changed in oem-priority:
status: Confirmed → Fix Released

@Ray

Hello, I have tested that myself and was a concern of mine. I am unable to get the character window to disappear from the dash no matter how hard I try. If you get a chance to post a screen shot of the pop up window disappearing and make sure you up to date with the current release 5.8? I hope that problem has been resolved. If it hasn't please let me know!

The other problem you have is more of how ibus works. You need to move the input engine (ibus-pinyin) to the active list. This should only effect you on a fresh install.

Cheers.

Ray Wang (raywang) wrote :

Thanks @Brandon, I will update this as long as I get the chance to look into it.
Anyway, if you want to get that window to disappear, you could open an editable application like gedit, and press CTRL + SPACE to close ibus.

Hope that helps

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers