Top panel/global menu not shown and window not focused when switching to open application from the dash/HUD

Bug #909870 reported by Twig on 2011-12-29
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
High
Marco Trevisan (Treviño)
unity (Ubuntu)
Medium
Marco Trevisan (Treviño)

Bug Description

Steps to reproduce:

1) Click on the dash Home icon

2) Instead of using the dash, click on one of the icons on the sidebar of an application that is already running

3) The application moves to the foreground but the title bar is not usable and only becomes so when you either:

a) Click on the application window
b) Click on the application icon in the sidebar

What I would expect to happen is that the application moves to the foreground and the title bar is usable immediately.

Hope this makes sense. Have not tried with applications on the sidebar which aren't running.

Thanks,
Twig.

Related branches

Changed in unity (Ubuntu):
status: New → Confirmed
importance: Undecided → Medium
Changed in unity:
status: New → Confirmed
importance: Undecided → Medium
status: Confirmed → Triaged
Changed in unity (Ubuntu):
status: Confirmed → Triaged

Confirmed in 13.04, Unity 6.6.0

This is not the case for closed applications, only for currently open applications

summary: - unity and dash incorrect behaviour
+ Top panel/global menu not shown when switching to open application from
+ the dash
tags: added: raring
summary: - Top panel/global menu not shown when switching to open application from
- the dash
+ Top panel/global menu not shown and window not focused when switching to
+ open application from the dash
Changed in unity:
importance: Medium → High
milestone: none → 7.1.1
Changed in unity:
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
Changed in unity (Ubuntu):
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
Changed in unity:
status: Triaged → In Progress
Changed in unity (Ubuntu):
status: Triaged → In Progress
summary: Top panel/global menu not shown and window not focused when switching to
- open application from the dash
+ open application from the dash/HUD
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:unity at revision None, scheduled for release in unity, milestone 7.1.1

Changed in unity:
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 7.1.1+13.10.20131004-0ubuntu1

---------------
unity (7.1.1+13.10.20131004-0ubuntu1) saucy; urgency=low

  [ Brandon Schaefer ]
  * Break the bump detection by moving to the first icon, then down 5
    pixels. Since bump detection needs to move in 3 different
    directions.
  * Move the switcher Alt+<ArrowKey> shortcut handling into nux, from
    compiz. Now nux handles these events instead of compiz. This way its
    makes much more sense code wise and we no longer ungrab the arrow
    gets from X... so Alt+LeftArrow will no longer open the hud. (LP:
    #969039)

  [ Andrea Azzarone ]
  * Fix bad redrawing of dash overlay scrollbar connector. (LP:
    #1233195)
  * Update icon_under_mouse before process mouse movemnt in the tooltip
    manager. (LP: #1172769, #1233666)
  * Hide the tooltip when an app is closed. (LP: #1172769)

  [ Marco Trevisan (Treviño) ]
  * TestIMTextEntry: fix failing tests with IBus, use TEST_F and TEST_P.
  * CairoBaseWindow: only regenerate blur texture when visible and
    damaged. (LP: #1233109)
  * CairoBaseWindow: add fade animator to control both QL and Tooltip
    Removing the animator from LauncherIcon, and handling the tooltip
    animation inside the QL and Tooltip base class.
  * PanelService: close a menu and re-send the keyevent when handling a
    combination Or when we try to open HUD/Dash. Also, close the active
    menu if a new application is opened and focused. (LP: #10905,
    #1234457, #1197071)
  * SimpleLauncherIcon: we need to restore the focus when closing the
    Overlay for activation. (LP: #909870)
  * LauncherIcon: don't try to show again quicklists or tooltip if
    center changed, just move them. (LP: #1234778)
  * AbstractLauncherIcon: add static icon_size property. (LP: #1073103)

  [ Christopher Lee ]
  * Preparing autopilot tests for an upcoming update in autopilot 1.3.

  [ Ubuntu daily release ]
  * Automatic snapshot from revision 3554
 -- Ubuntu daily release <email address hidden> Fri, 04 Oct 2013 05:23:43 +0000

Changed in unity (Ubuntu):
status: In Progress → Fix Released
Stephen M. Webb (bregma) wrote :

Fix Released in Nux Unity 7.1.1.

Changed in unity:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers