Ubuntu

Windows "flash" on focus change

Reported by Giacomo Mirabassi on 2011-12-13
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Unity
Undecided
Unassigned
unity (Ubuntu)
Undecided
Unassigned

Bug Description

The following behaviour appeared just after the upgrade to oneiric:

If I have two windows on desktop overlaying each other, when I click on the background one the window comes to front then disappears for less than a second and then reappears.

This doesn't happen if the two windows are separated. It happens 100% of times.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: unity 4.24.0-0ubuntu2b1
ProcVersionSignature: Ubuntu 3.0.0-14.23-generic 3.0.9
Uname: Linux 3.0.0-14-generic x86_64
NonfreeKernelModules: nvidia
.proc.driver.nvidia.gpus.0: Error: [Errno 21] È una directory: '/proc/driver/nvidia/gpus/0'
.proc.driver.nvidia.registry: Binary: ""
.proc.driver.nvidia.version:
 NVRM version: NVIDIA UNIX x86_64 Kernel Module 280.13 Wed Jul 27 16:53:56 PDT 2011
 GCC version: gcc version 4.6.1 (Ubuntu/Linaro 4.6.1-9ubuntu3)
.tmp.unity.support.test.0:

ApportVersion: 1.23-0ubuntu4
Architecture: amd64
CheckboxSubmission: 314916486e0ed6e8561c71e1f04094ea
CheckboxSystem: 406f15b68f9586a1c15edfaa65f4ea11
CompizPlugins: [core,bailer,detection,composite,opengl,decor,place,compiztoolbox,grid,move,imgpng,vpswitch,resize,mousepoll,wall,regex,gnomecompat,screenshot,session,animation,wobbly,unitymtgrabhandles,fade,scale,expo,workarounds,unityshell,scaleaddon]
CompositorRunning: compiz
Date: Tue Dec 13 12:57:37 2011
DistUpgraded: Log time: 2011-11-21 16:26:20.585229
DistroCodename: oneiric
DistroVariant: ubuntu
GraphicsCard:
 nVidia Corporation G98 [GeForce 9200M GS] [10de:06e8] (rev a1) (prog-if 00 [VGA controller])
   Subsystem: Hewlett-Packard Company Device [103c:3629]
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release amd64 (20091027)
JockeyStatus:
 xorg:nvidia_173 - NVIDIA accelerated graphics driver (Proprietary, Disabled, Not in use)
 firmware:dvb_usb - Firmware for DVB cards (Proprietary, Enabled, In use)
 xorg:nvidia_173_updates - NVIDIA accelerated graphics driver (post-release updates) (Proprietary, Disabled, Not in use)
 xorg:nvidia_current - NVIDIA accelerated graphics driver (Proprietary, Enabled, In use)
 xorg:nvidia_current_updates - NVIDIA accelerated graphics driver (post-release updates) (Proprietary, Disabled, Not in use)
MachineType: Hewlett-Packard HP Pavilion dv6 Notebook PC
ProcEnviron:
 PATH=(custom, no user)
 LANG=it_IT.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.0.0-14-generic root=UUID=ed205904-b0c8-4fa7-99f4-a67ce78fc365 ro quiet splash vt.handoff=7
SourcePackage: unity
UpgradeStatus: Upgraded to oneiric on 2011-11-21 (21 days ago)
dmi.bios.date: 11/14/2008
dmi.bios.vendor: Hewlett-Packard
dmi.bios.version: F.02
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: 3629
dmi.board.vendor: Quanta
dmi.board.version: 18.0B
dmi.chassis.type: 10
dmi.chassis.vendor: Quanta
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnHewlett-Packard:bvrF.02:bd11/14/2008:svnHewlett-Packard:pnHPPaviliondv6NotebookPC:pvrF.02:rvnQuanta:rn3629:rvr18.0B:cvnQuanta:ct10:cvrN/A:
dmi.product.name: HP Pavilion dv6 Notebook PC
dmi.product.version: F.02
dmi.sys.vendor: Hewlett-Packard
version.compiz: compiz 1:0.9.6+bzr20110929-0ubuntu6
version.ia32-libs: ia32-libs 20090808ubuntu26
version.libdrm2: libdrm2 2.4.26-1ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 7.11-0ubuntu3
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 7.11-0ubuntu3
version.nvidia-graphics-drivers: nvidia-graphics-drivers N/A
version.xserver-xorg: xserver-xorg 1:7.6+7ubuntu7
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.6.0-1ubuntu13
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.99~git20110811.g93fc084-0ubuntu1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.15.901-1ubuntu2.1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20110411+8378443-1

Giacomo Mirabassi (giacmir) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity (Ubuntu):
status: New → Confirmed
roemer2201 (roemer2201) wrote :

Check Compiz Settings Manager:
Go to Animations -> Focus Animations -> Select the one Animation -> click "edit" -> Set "Focus Effect" to "None"

Does this solve your problem?

Giacomo Mirabassi (giacmir) wrote :

Yes, disable focus effect solves the problem. thanks.

roemer2201 (roemer2201) wrote :

Nice, but I still having the same effect when switching to a different workspace. I have Desktop-Cube and Cube-Rotation enabled.

roemer2201 (roemer2201) wrote :

The Error I menntioned in the last comment here can be found on this site:

https://bugs.launchpad.net/ubuntu/+source/compiz/+bug/876198

Changed in unity (Ubuntu):
status: Confirmed → Fix Released
Changed in unity:
status: New → Fix Released
Giacomo Mirabassi (giacmir) wrote :

Well, i don't think that "fix released" is the correct status for this bug. Actually you suggested me a workaround of the problem, but the problem itself is not fixed. I think that "confirmed" is still the best status for this.

Changed in unity (Ubuntu):
status: Fix Released → Confirmed
Changed in unity:
status: Fix Released → Confirmed
Omer Akram (om26er) wrote :

thanks for your bug report. Is that still an issue in Ubuntu 12.04? Can you please test that and let us know?

Changed in unity:
status: Confirmed → Incomplete
Changed in unity (Ubuntu):
status: Confirmed → Incomplete
tags: added: regression-release
removed: regression-update
Giacomo Mirabassi (giacmir) wrote :

I'm sorry, I'm not using Ubuntu anymore and haven't tried 12.04. Now I'm on Debian with KDE. Thanks for the attention.

If it is possible to enable proprietary nvidia drivers using a live image I will try that way, but the result could be not so affordable.

Omer Akram (om26er) wrote :

since you no longer use Ubuntu and we are not sure how to test the issue I am going to close the bug.

Changed in unity:
status: Incomplete → Invalid
Changed in unity (Ubuntu):
status: Incomplete → Invalid
To post a comment you must log in.