unity-panel-service crashed with SIGSEGV in g_simple_async_result_complete()

Bug #902827 reported by Per-Inge on 2011-12-11
128
This bug affects 30 people
Affects Status Importance Assigned to Milestone
Unity
Expired
Undecided
Unassigned
unity (Ubuntu)
Undecided
Unassigned

Bug Description

The crash happened when I installed Spotify, directly after installation of 12.04 daily build 11/12. Spotify installed OK and Spotify's icon was presented in the panel.
The panel was set to full transparency.

ProblemType: Crash
DistroRelease: Ubuntu 12.04
Package: unity-services 4.24.0-0ubuntu2b1
ProcVersionSignature: Ubuntu 3.2.0-4.10-generic 3.2.0-rc5
Uname: Linux 3.2.0-4-generic x86_64
NonfreeKernelModules: nvidia
.proc.driver.nvidia.gpus.0: Error: [Errno 21] Is a directory: '/proc/driver/nvidia/gpus/0'
.proc.driver.nvidia.registry: Binary: ""
.proc.driver.nvidia.version:
 NVRM version: NVIDIA UNIX x86_64 Kernel Module 285.05.09 Fri Sep 23 17:31:57 PDT 2011
 GCC version: gcc version 4.6.2 (Ubuntu/Linaro 4.6.2-7ubuntu1)
.tmp.unity.support.test.0:

ApportVersion: 1.90-0ubuntu1
Architecture: amd64
CompizPlugins: [core,bailer,detection,composite,opengl,compiztoolbox,decor,mousepoll,regex,vpswitch,gnomecompat,animation,place,move,grid,snap,wall,resize,imgpng,session,expo,unitymtgrabhandles,workarounds,fade,scale,ezoom,unityshell]
CompositorRunning: compiz
Date: Sun Dec 11 17:31:49 2011
DistUpgraded: Fresh install
DistroCodename: precise
DistroVariant: ubuntu
DkmsStatus:
 nvidia-current, 285.05.09, 3.2.0-3-generic, x86_64: installed
 nvidia-current, 285.05.09, 3.2.0-4-generic, x86_64: installed
ExecutablePath: /usr/lib/unity/unity-panel-service
GraphicsCard:
 nVidia Corporation G92 [GeForce GTS 250] [10de:0615] (rev a2) (prog-if 00 [VGA controller])
   Subsystem: Giga-byte Technology Device [1458:34c7]
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Alpha amd64 (20111211)
JockeyStatus:
 firmware:dvb_usb - Firmware for DVB cards (Proprietary, Disabled, Not in use)
 xorg:nvidia_current - NVIDIA accelerated graphics driver (Proprietary, Enabled, In use)
 xorg:nvidia_current_updates - NVIDIA accelerated graphics driver (post-release updates) (Proprietary, Disabled, Not in use)
MachineType: Gigabyte Technology Co., Ltd. GA-MA770-UD3
ProcCmdline: /usr/lib/unity/unity-panel-service
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, no user)
 LANG=en_US.UTF-8
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.2.0-4-generic root=UUID=36a22e88-7be6-4349-87d5-fb194890f624 ro quiet splash vt.handoff=7
SegvAnalysis:
 Segfault happened at: 0x7f54f9267d79: mov 0x30(%rbx),%rdi
 PC (0x7f54f9267d79) ok
 source "0x30(%rbx)" (0xaaaaaaaaaaaaaada) not located in a known VMA region (needed readable region)!
 destination "%rdi" ok
SegvReason: reading unknown VMA
Signal: 11
SourcePackage: unity
StacktraceTop:
 ?? () from /usr/lib/x86_64-linux-gnu/libdbusmenu-glib.so.4
 g_simple_async_result_complete () from /usr/lib/x86_64-linux-gnu/libgio-2.0.so.0
 ?? () from /usr/lib/x86_64-linux-gnu/libgio-2.0.so.0
 g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
 ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
Title: unity-panel-service crashed with SIGSEGV in g_simple_async_result_complete()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
XorgConf:
 Section "Device"
  Identifier "Default Device"
  Option "NoLogo" "True"
 EndSection
dmi.bios.date: 07/08/2010
dmi.bios.vendor: Award Software International, Inc.
dmi.bios.version: FKb
dmi.board.name: GA-MA770-UD3
dmi.board.vendor: Gigabyte Technology Co., Ltd.
dmi.board.version: x.x
dmi.chassis.type: 3
dmi.chassis.vendor: Gigabyte Technology Co., Ltd.
dmi.modalias: dmi:bvnAwardSoftwareInternational,Inc.:bvrFKb:bd07/08/2010:svnGigabyteTechnologyCo.,Ltd.:pnGA-MA770-UD3:pvr:rvnGigabyteTechnologyCo.,Ltd.:rnGA-MA770-UD3:rvrx.x:cvnGigabyteTechnologyCo.,Ltd.:ct3:cvr:
dmi.product.name: GA-MA770-UD3
dmi.sys.vendor: Gigabyte Technology Co., Ltd.
version.compiz: compiz 1:0.9.6+bzr20110929-0ubuntu8
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.27-1ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 7.11-0ubuntu4
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 7.11-0ubuntu4
version.nvidia-graphics-drivers: nvidia-graphics-drivers N/A
version.xserver-xorg-core: xserver-xorg-core 2:1.10.4-1ubuntu6
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.6.0-1ubuntu13
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.99~git20110811.g93fc084-0ubuntu1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.15.901-1ubuntu4
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20110411+8378443-1

Per-Inge (per-inge-hallin) wrote :
visibility: private → public

StacktraceTop:
 ?? ()
 ?? ()
 ?? ()

tags: added: apport-failed-retrace
tags: removed: need-amd64-retrace
Per-Inge (per-inge-hallin) wrote :

Seems to happen always when Spotify is started the 1:st time after installation on a fresh installed Precise system.
Spotify is installed according to the methode described on this page
http://www.spotify.com/se/download/previews/

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity (Ubuntu):
status: New → Confirmed
Didier Roche (didrocks) on 2012-02-01
Changed in unity:
status: New → Confirmed
dtx_2503@yahoo.com (dtx-2503) wrote :

Mine crash when I start View Your Mind, Maximize. Here is the video of my desktop.
Here the info when run "vym -v"

VYM - View Your Mind (c) 2004-2011 Uwe Drechsel
   Version: 2.0.3
Build date: 2011-11-07
  Codename: Production release

userdce (userdce) wrote :

I tried to maximize-minimize spotify and it happened

Omer Akram (om26er) wrote :

thanks for the bug report. please try to obtain a stacktrace by following the procedure here https://wiki.ubuntu.com/Unity/FilingBugs#Getting_a_stack_trace or just report a new bug report by opening the unity-panel-serivice named crash file in /var/crash folder

Changed in unity:
status: Confirmed → Incomplete
Changed in unity (Ubuntu):
status: Confirmed → Incomplete
James (jamesasgrim) wrote :

This also affects me, I am using the precise Beta1, installed according to http://www.spotify.com/uk/download/previews/ . Same crash, but it crashes every startup, so Spotify is unusable. I get the main app up, but it seems to be when it's trying to load the album icons etc. on the homepage. Screenshot attached. Running on the command line yields this output:

$ spotify
Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",
10:14:17.342 I [breakpad.cpp:36] Registered Breakpad for product: spotify
10:14:17.343 I [translate.cpp:123] Reloading all languages
10:14:17.372 I [breakpad.cpp:94] Searching for crashdumps: /home/james/.cache/spotify/*.dmp
10:14:19.724 I [breakpad.cpp:105] Not allowed to upload file
QDBusArgument: write from a read-only object
10:14:20.015 I [ap:1754] Connecting to AP C4.spotify.com:4070
10:14:20.078 I [offline-mgr:2146] Storage has been cleaned
10:14:20.120 I [upnp:517] 192.168.1.254: got external ip 0x50AFC245
10:14:20.120 I [ap:1212] Connected to AP: 78.31.8.114:4070
10:14:20.968 I [upnp:465] 192.168.1.254: mapping add ok
10:14:20.978 I [upnp:491] 192.168.1.254: Port 11443 mapped OK
10:14:21.145 I [user_cache:138] UserCache::initiateGetUsers() will query for 1 users
10:14:21.146 I [gui-model:2549] Login Code: 0
Gdk-CRITICAL **: IA__gdk_window_set_back_pixmap: assertion `GDK_IS_WINDOW (window)' failed
Gdk-CRITICAL **: IA__gdk_window_get_origin: assertion `GDK_IS_WINDOW (window)' failed
GLib-GObject-WARNING **: instance with invalid (NULL) class pointer
GLib-GObject-CRITICAL **: g_signal_handlers_destroy: assertion `G_TYPE_CHECK_INSTANCE (instance)' failed
Segmentation fault (core dumped)

And in dmesg I see:

[ 5176.100835] spotify[15304] general protection ip:7fc496dffee5 sp:7fff5a003650 error:0 in libglib-2.0.so.0.3120.0[7fc496dd3000+f2000]

I don't know if this info is useful, if something more specific is more useful I am happy to reproduce this bug.

James (jamesasgrim) wrote :

francisdb - I can confirm that after installing the .deb from that link and removing ~/.cache/spotify, this has fixed the crashing and everything so far seems to be working reliably!.

Antec (info-janmob) wrote :

To install the latest .deb files which can be downloaded by "Francis De Brabandere" link tips and then delete ~ /.cache / spotify only helps first start just after the deletion of spotify cache. But if you always pick off Spotify cache when you start spotify, I get no more crasher with unity-panel-service. It looks like the problem really be that flash is installed in the system. Flash crashes Spotify and Spotify crashes unity-panel-service.

Antec (info-janmob) wrote :

After the latest updates of 12:04 so works Spotify again. But if you had this problem before, you must first delete Spotify cache
path: ~/.cache/Spotify
Removing entire catalog Spotify

James (jamesasgrim) wrote :

I no longer have crashes from Spotify. If no-one else is, perhaps this can be assumed to be fixed by the Spotify Linux team?

Antec (info-janmob) wrote :

This bug is really about unity-panel-service and not Spotify even if the bug affected both flash and Spotify. Spotify has never been wrong in regarding this error but the error is what I understand, been entirely on Ubuntu, so there must be someone from the Ubuntu development team that put the bug as fixed if everything seems ok for others too..

Launchpad Janitor (janitor) wrote :

[Expired for unity because there has been no activity for 60 days.]

Changed in unity:
status: Incomplete → Expired
Launchpad Janitor (janitor) wrote :

[Expired for unity (Ubuntu) because there has been no activity for 60 days.]

Changed in unity (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.