compiz crashed with SIGSEGV in get_current_slide() from unity::BGHash::OnSlideshowTransition()

Bug #889625 reported by Anand Kumria on 2011-11-12
76
This bug affects 8 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
Critical
Marco Trevisan (Treviño)
unity (Ubuntu)
Critical
Unassigned

Bug Description

Had just compiz settings manager, and a crash dialog appeared.

ProblemType: Crash
DistroRelease: Ubuntu 11.10
Package: unity 4.24.0-0ubuntu2b1
ProcVersionSignature: Ubuntu 3.0.0-13.22-generic 3.0.6
Uname: Linux 3.0.0-13-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 1.23-0ubuntu4
Architecture: amd64
Date: Sat Nov 12 21:29:55 2011
ExecutablePath: /usr/bin/compiz
InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release amd64 (20100429)
ProcCmdline: compiz
ProcEnviron:
 LANGUAGE=en_AU:en
 PATH=(custom, user)
 LANG=en_AU.UTF-8
 LC_MESSAGES=en_AU.UTF-8
 SHELL=/bin/zsh
SegvAnalysis:
 Segfault happened at: 0x7f7bbe94452c <get_current_slide+12>: movsd 0x10(%rdi),%xmm0
 PC (0x7f7bbe94452c) ok
 source "0x10(%rdi)" (0x6060606075757585) not located in a known VMA region (needed readable region)!
 destination "%xmm0" ok
SegvReason: reading unknown VMA
Signal: 11
SourcePackage: unity
StacktraceTop:
 get_current_slide () from /usr/lib/libunity-misc.so.4
 unity::BGHash::OnSlideshowTransition(unity::BGHash*) () from /usr/lib/compiz/libunityshell.so
 ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
 g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
 ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
Title: compiz crashed with SIGSEGV in get_current_slide()
UpgradeStatus: Upgraded to oneiric on 2011-11-12 (0 days ago)
UserGroups: adm admin cdrom dialout libvirtd lpadmin plugdev sambashare
XsessionErrors:
 (software-center:4178): Gtk-WARNING **: Unknown property: GtkGrid.n-rows
 (software-center:4178): Gtk-WARNING **: Unknown property: GtkGrid.n-columns
 (software-center:4178): Gtk-WARNING **: Unknown property: GtkGrid.n-rows
 (software-center:4178): Gtk-WARNING **: Unknown property: GtkGrid.n-columns

Related branches

Anand Kumria (wildfire) wrote :

StacktraceTop:
 get_current_slide (show=0x6060606075757575, alpha=0x7fff1438a170) at gnome-bg-slideshow.c:66
 unity::BGHash::OnSlideshowTransition (self=0xddb0f0) at /build/buildd/unity-4.24.0/plugins/unityshell/src/BGHash.cpp:249
 g_timeout_dispatch (source=<optimized out>, callback=<optimized out>, user_data=<optimized out>) at /build/buildd/glib2.0-2.30.0/./glib/gmain.c:3907
 g_main_dispatch (context=0x8d0a60) at /build/buildd/glib2.0-2.30.0/./glib/gmain.c:2441
 g_main_context_dispatch (context=0x8d0a60) at /build/buildd/glib2.0-2.30.0/./glib/gmain.c:3011

Changed in unity (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
visibility: private → public
Didier Roche (didrocks) on 2011-11-22
Changed in unity (Ubuntu):
importance: Medium → Critical
Changed in unity:
importance: Undecided → High
status: New → Confirmed
Changed in unity (Ubuntu):
status: New → Confirmed
summary: - compiz crashed with SIGSEGV in get_current_slide()
+ compiz crashed with SIGSEGV in get_current_slide() from
+ unity::BGHash::OnSlideshowTransition()
tags: added: precise
Omer Akram (om26er) on 2012-07-09
Changed in unity:
importance: High → Critical
Omer Akram (om26er) wrote :

andyrock says this bug is fixed with Trevino's BGHash refactor work. He is now working on a fix for the stable series.

Changed in unity:
status: Confirmed → Fix Committed
milestone: none → 6.0
Changed in unity (Ubuntu):
status: Confirmed → Fix Committed
Changed in unity (Ubuntu Precise):
status: New → Confirmed
Andrea Azzarone (azzar1) on 2012-07-09
Changed in unity:
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
Omer Akram (om26er) on 2012-07-09
no longer affects: unity/5.0
Andrea Azzarone (azzar1) on 2012-07-09
Changed in unity (Ubuntu Precise):
assignee: nobody → Andrea Azzarone (andyrock)
Omer Akram (om26er) wrote :

ok, that can't be SRUed :/

no longer affects: unity (Ubuntu Precise)

I think this doesn't even affect Precise... There's no mentioned function in unity-5.0 code.

Didier Roche (didrocks) on 2012-07-10
Changed in unity:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (5.8 KiB)

This bug was fixed in the package unity - 6.0.0-0ubuntu1

---------------
unity (6.0.0-0ubuntu1) quantal-proposed; urgency=low

  [ Didier Roche ]
  * debian/rules, debian/control, debian/unity-autopilot.install:
    - install new unity-autopilot package, containing autopilot bindings and
      test for Unity
    - add some python build-dep for executing setup.py
    - use dh_python2 and add some python:Depends dep for automatic python
      version detection
  * debian/control:
    - remove gnome-desktop dependency: not needed upstream anymore
    - unity Breaks older lenses due to path change
    - remove libgdu in build-dep
  * debian/libunity-core-6.0-5.install, debian/libunity-core-6.0-dev.install,
    debian/control:
    - version bump in libunity-core, change soname

  [ Matthieu Baerts (matttbe) ]
  * Update apport hook for python3 ; thanks to Edward Donovan (LP: #1013171)

  [ Łukasz 'sil2100' Zemczak ]
  * New upstream release.
    - compiz crashed with SIGSEGV in get_current_slide() from
      unity::BGHash::OnSlideshowTransition() (LP: #889625)
    - Unity is visible on top of fullscreen apps (LP: #734908)
    - App icon on the Unity Launcher lost track of running instance
      (LP: #772063)
    - unity crashed with NameError in reset_unity_compiz_profile(): global
      name 'GError' is not defined (LP: #778470)
    - compiz crashed with SIGSEGV in CompWindow::id() from getPaintMask()
      [compizminimizedwindowhandler.h] from unity::UnityWindow::glPaint()
      (LP: #851982)
    - HUD - Formatting of text in the auto-complete is wrong (LP: #939436)
    - [regression] Launcher is silent to screen reader users (LP: #949448)
    - still some accent issues with unity/nux (LP: #950740)
    - [regression] [precise] 3D apps run much slower under Unity (LP: #987304)
    - No launcher icon or Alt+Tab entry for Gimp windows (LP: #995916)
    - Locked smuxi launcher icon does not indicate smuxi running status
      (LP: #999820)
    - When number of workspaces is set to 1, the Spread no longer works
      (LP: #996604)
    - Much slower OpenGL frame rates with unityshell loaded, than plain compiz
      (LP: #988079)
    - Port to libudisks2 (LP: #1012000)
    - Desktop, Launcher and menu bar still visible when screen locked
      (LP: #886605)
    - Searching in the HUD freezes unity (LP: #1016239)
    - Dragged icons rendered under dash (LP: #1021541)
    - Regression in Launcher keyboard navigation (with Alt+F1) (LP: #1021549)
    - Unity dash is is much slower/laggy after revision 2469. (LP: #1021665)
    - Dash and Launcher - As soon as a user starts dragging a file from the
      Dash, there is a 'flicker' before the Launcher icons that are valid drop
      receptacles re-saturate (LP: #863230)
    - Dash - when a file is dragged from the Dash (Dash home, file lens, or
      music lens) and dropped on a Launcher icon, the Dash should
      automatically close (LP: #865168)
    - Refreshing active blur makes the dash painfully slow (LP: #874230)
    - Open dash, press Alt+f1 - dash remains open (LP: #919209)
    - application reopens itself when last instance is closed from
      windows/application switcher (LP: #926406)
    - HUD D...

Read more...

Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers