Gradual degradation in desktop performance.

Bug #888039 reported by jhfhlkjlj on 2011-11-09
334
This bug affects 95 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
Critical
Jason Smith
unity (Ubuntu)
Critical
Ron Karoles
Oneiric
High
Daniel van Vugt

Bug Description

SRU test case:

1. start Ubuntu and use it for a few hours
2. After the constant usage of a few hours there general performance degrade noted
3. now install NUX from oneiric-proposed
4. The situation is much imporved

=====Original Report====
edit - This bug has been scoped down to a particular std:vector<int> growing out of control inside of nux. Any report about degrading performance not related to this should be filed as new bugs. :) Thanks guys.

Over the span of 1-3 days I see my desktop consistently become more sluggish. The functions most affected are window movement, file icon movement, and sometimes window resizing. Other animations (such as minimizing fades, switching desktops, expo mode) are not affected when this degradation occurs. They remain smooth; however, I have let the problem go on as long as to find out that eventually all desktop animations/effects will degrade, it just takes a lot lot longer. I find that my actual 3D gaming goes unaffected (though I have no data to back that up, perhaps it does).

I have recorded the output of 'ps auxw' and have slowly watched the VSZ and RSS memory columns creep upwards. A fresh compiz session will see 675164 and 169860, respectively. After a day or two it will result in as high as 878552 and 255664. I have attached a log output from an hourly cron job (though I had suspended for a few days because of travel).

After the degradation has occurred compiz will consistently use higher CPU. Dragging a terminal window while watching top: before: ~10%, after: ~30 percent.

This has been an issue since 11.04 for me on both my Intel i915 and Nvidia (proprietary) machines (had an 8600 GT and upgraded to 560 GTX, both having the same issue). However, the nvidia machine is where it really hurts, _always_ happening within a day or two, while the i915 machine is pretty reliable overall with certain instances of degradation (used to be affected just as badly in 11.04).

I will attach two videos demonstrating behavior before and after.
---
ApportVersion: 1.23-0ubuntu4
Architecture: amd64
CheckboxSubmission: 33c9cec13de798ee31ce4ea2f2cbd4df
CheckboxSystem: 4ed15c40009aa6f7770f606350a390a2
CompizPlugins: [core,detection,composite,opengl,decor,regex,winrules,compiztoolbox,animation,grid,vpswitch,snap,place,gnomecompat,resize,move,mousepoll,imgpng,workarounds,session,expo,wall,fade,scale,unityshell]
DistroCodename: oneiric
DistroRelease: Ubuntu 11.10
DistroVariant: ubuntu
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release amd64 (20101007)
NonfreeKernelModules: nvidia
Package: compiz 1:0.9.6+bzr20110929-0ubuntu5vv1
PackageArchitecture: all
ProcVersionSignature: Ubuntu 3.0.0-12.20-generic 3.0.4
Tags: oneiric running-unity oneiric running-unity ubuntu
Uname: Linux 3.0.0-12-generic x86_64
UnreportableReason: This is not a genuine Ubuntu package
UpgradeStatus: Upgraded to oneiric on 2011-10-13 (26 days ago)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Related branches

tags: added: apport-collected oneiric running-unity ubuntu
description: updated

apport information

apport information

apport information

I will swap out this video for another one as this isn't great quality nor demonstrates the entire impact of the bug, only showing the window dragging. I'm on a fresh session right now, however, so I need to wait a day... :)

Some things I have tried that have made no difference:

I have installed Daniel van Vugt's PPA and tried his compiz build.
I have reset all Compiz settings to factory.
I have disabled the 'Bailer' plugin
I have disabled Auto refresh rate detection and put mine in manually.
I have disabled dynamictwinview from my xorg.conf.
I have enabled "Force sync between X and GLX" in CCSM's 'workarounds' plugin
I have enabled "Force Full Screen Redraws" in CCSM's 'workarounds' plugin.

description: updated
description: updated
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in compiz (Ubuntu):
status: New → Confirmed
Rocko (rockorequin) wrote :

I see this bug on both an intel system and an nvidia system as well. The benchmark that shows the degradation is glxspheres, available in the virtualgl package (which is installable via apt-get if you do sudo apt-add-repository ppa:mj-casalogic/ironhide). glxspheres drops from around 60 fps to as low as 25 fps when the degradation is apparent.

I notice the opposite in RAM usage, however - compiz typically is using less RAM when I see the degradation. And it often comes on quite quickly. It might be related to having a few windows open (I typically run Netbeans, VirtualBox, Firefox, Thunderbird) or it might be related to using a lot of RAM. Sometimes the degradation persists across multiple reboots (and for multiple users), but when this happens there is never any degradation using metacity or mutter.

I've documented a lot of what I've tried at bug #861061 and how the problem sometimes randomly resolves itself.

Very odd that it resolves itself for you. It gets consistently worse and worse for me.

Rocko (rockorequin) wrote :

When I say it resolves itself, it never does so spontaneously. It sometimes resolves after a complete PC reboot, and once or twice when I tried unity --reset and unity crashed spectacularly.

Also if I disable the unity plugin, it resolves itself immediately, so like Daniel suspects in bug #861061 it may well be that unity is at fault rather than compiz.

can the unity plugin be disabled without a restart to compiz itself? If so, then I will make sure to try that out when it flares up again.

Rocko (rockorequin) wrote :

I'm pretty sure you can just disable it by unticking it in ccsm, but I'm not sure if that unloads it immediately. I was 'lucky' enough to have unity completely crash on me a few times without crashing compiz, and on at least one occasion it disabled itself completely from ccsm so logging in gave me just a desktop with the gnome-terminal that I always run (for emergencies like that if nothing else).

Rocko (rockorequin) wrote :

OK, I just experienced the slowdown and tried the following:

1. Test glxspheres: ~30-40 fps

2. Open ccsm and disable the unity plugin. I think that restarts compiz but it restarts without unity (all the other windows are still there).

3. Test glxspheres: ~60 fps

4. From ccsm, re-enable the unity plugin. Again, compiz seems to restart and this time unity is back.

5. Test glxspheres: ~30-40 fps.

Daniel van Vugt (vanvugt) wrote :

There is a chance the degradation in some cases is caused by the composite rendering timer drifting out of sync with your monitor. And it does, I know that for certain. When this happens, tearing becomes more visible and the frame rate can go down to half of what it should be.

*If* that is the issue for you then this fix is likely to solve it:
https://code.launchpad.net/~vanvugt/compiz-core/fix-880707/+merge/81737

The fix will be available for testing in a PPA after it's been approved by more reviewers... It will be worth trying at least.

Rocko (rockorequin) wrote :

Thanks for the update. I'm more than happy to try it, anything to improve the unity experience! Right now glxspheres is running at 33 fps, whereas an hour ago it could manage 56fps - and I haven't done anything in the meantime other than eat dinner! Let me know when the PPA is available.

isn't the glxspheres problem covered by bug 861061? It seems like we're starting to have separate issues, Rocko.

How embarrassing. I forgot to remove the audio from my "after" video.

I've updated it.... Can't make another one yet as it's not bad enough to warrant a video at the moment.

Rocko (rockorequin) wrote :

I do see the same issue as you when performance drops - windows move 'jerkily', by not moving with the mouse and then suddenly jumping a large number of pixels all at once. The worst I have seen it get is that the mouse will move and the window not at all until a second after the mouse stops moving.

I use glxspheres because it provides numbers to describe the drop in performance. Typically glxspheres has much lower fps at the same time as the desktop becomes sluggish so I assume they are related.

I originally opened bug #861061 when the drop in performance had apparently become permanent, ie persisting across reboots. At some point it automagically resolved itself but has returned a number of times since. I suspect they may be the same bug but Daniel says is experiencing a permanent drop in performance and wants to use 861061 to track this permanent drop in performance.

I don't know if this is helpful but if I move windows around in expo mode it's very butter smooth again.

description: updated
Lorenzo Villani (lvillani) wrote :

I confirm that I can see this bug also when using Catalyst (fglrx) drivers (both the version available in Oneiric and later versions avaiable from AMD's website).

In my case the issue is exacerbated by the number of active X clients. Closing some windows slightly improves the situation. However, I noticed this behavior in addition to performance degradation over time.

Daniel van Vugt (vanvugt) wrote :

People using Catalyst fglrx drivers should make sure they have the fix for bug 763005 installed first. Because bug 763005 is more severe and will prevent you from being able to tell which bugs if any still remain.

Daniel van Vugt (vanvugt) wrote :

Testing a new NVIDIA card with the NVIDIA driver 280, I think I can reproduce this bug now. It starts off smooth but if I drag windows around for a little while, it becomes jerky. The jerkiness often doesn't go away, but sometimes does if I leave everything idle for a while. Even with the workaround for bug 763005 applied the jerkiness stays.

Now for the good news:
This bug appears to be fixed when I install my compiz fix for bug 880707. Awesome :)

The bad news:
The fix for bug 880707 is undergoing a minor redesign by the compiz team so I can't make it public until that's done.

Daniel van Vugt (vanvugt) wrote :

In the previous comment, "bug 763005" should read "bug 92599".

Changed in compiz:
assignee: nobody → Daniel van Vugt (vanvugt)
status: New → In Progress
Changed in compiz (Ubuntu):
assignee: nobody → Daniel van Vugt (vanvugt)
status: Confirmed → In Progress
peter huwe (pjhuwe) wrote :

I've been struggling with what seems to be the same bug.

Summary: When I log in, compiz and all my programs run ridiculously fast. Over the course of the next 30 hours (give or take), it gradually become sluggish and jerky. If I log out and log back in again, then it goes back to being fast.

Details: It's a nice, new, sexy computer. i7-2600K Sandy Bridges processors, 16GB RAM, SSD, GeForce GTX 570, current NVIDIA driver, dual screens with twinview, running Ubuntu 11.10 with Unity.

When I log in, everything runs really, really fast with beautiful graphics. Gradually, things slow down (after maybe 6 hours). Programs which rely on OpenGL and normally use ~15%CPU will start using 100%CPU. Temp never exceeds 52 degrees F though, and RAM usage is low. Video memory usage stays low. No swap usage at all. My window switching becomes very choppy. To fix everything, all I have to do is log out and log back in. But 7 or 8 hours later, the same issues pop up. Reverting to Natty doesn't help at all.

I first noticed this problem while using the graphics intensive program, VMD. But the problem is definitely not limited to that program. I even experience choppy window switching when I have no programs open. I've tried a billion things, but nothing has remedied the problem yet.

Daniel van Vugt (vanvugt) wrote :

Hmm, perhaps the problem I reproduced was not this bug. Everyone else seems to say it takes hours or days. But I was able to get some degradation using the nvidia-driver in under a minute (!). When the proposed fix is available for testing we will of course know for certain if it's a different issue.

Florin Coras (fcoras) wrote :

Well, at least we're two. I can reproduce this bug on my laptop with an Nvidia NVS 140M shortly after a restart. For me, the sluggishness/jerkiness never goes away. This might have to do with my card being a bit outdated.

Same holds for bugs 861061 and 880707. So, I'm really looking forward to a compiz (and unity) fix Christmas present.

Daniel, thanks for writing and pushing for the fix!

Matt Pharoah (mr-exuberant) wrote :

I also am getting this bug after "minutes".

The thing is, it's not actually time. Here is the behaviour I am getting:

When attempting to move a window (ANY window, not just one with transparency) in GNOME Classic using Compiz, the very first time you click the window and drag it around it works fine. After that, any other time you click the window and drag it around, it won't update its position AT ALL unless you keep your cursor in the same position for about 1/4 of a second, at which point it will update.

I tried toggling the lazy option in Compiz's move plugin, but it had no effect.

Then I tried the half-fix posted here by Daniel, and it worked perfectly (though obviously repainting the entire screen on an update is not desirable!) I'm back to using Compiz again. I'll probably just make a shell script wrapper for my games that temporarily switches to Metacity until the program terminates.

Achim (ach1m) wrote :

Exüberance, I think you have this bug → https://bugs.launchpad.net/ubuntu/+source/compiz/+bug/874514

Matt Pharoah (mr-exuberant) wrote :

Perhaps I do, because this fix suddenly stopped working and I have no idea why.

Rocko (rockorequin) wrote :

@Exüberance: the redirect option might help for windowed games. You have to install compiz-plugins-extra and then you have 'Extra WM Actions', which allows you to assign a key combination to toggle redirect for a particular window. It works even when compiz is struggling to move windows around.

Daniel van Vugt (vanvugt) wrote :

Game performance under Unity is probably better covered in bug 861061.

Daniel van Vugt (vanvugt) wrote :

Experimental fixes for this and related performance bugs are now available
for testing in ppa:vanvugt/compiz and ppa:vanvugt/unity. For the best
results I recommend trying both together. But testing them individually is
useful too.

IMPORTANT NOTES:

  * The fixes in ppa:vanvugt/compiz REQUIRE that "Sync To VBlank" is ENABLED
    in CompizConfig Settings Manager (OpenGL section).
    This is the default setting when Ubuntu 11.10 is installed.

  * When using ppa:vanvugt/compiz you should DISABLE the workaround
    "Force full screen redraws (buffer swap) on repaint" in
    CompizConfig Settings Manager (Workarounds section).
    This is the default setting when Ubuntu 11.10 is installed.

  * I don't claim to have fixed all tearing. I only claim that the amount of
    tearing in oneiric with the fix is no longer worse than in natty.

  * nouveau: If you are using the "nouveau" driver for NVIDIA chips you will
    need to enable sync-to-vblank support in the driver options because
    nouveau has it disabled by default. You can do this by editing
    /etc/X11/xorg.conf and adding:
       Section "Device"
           Identifier "My Graphics"
           Option "GLXVBlank" "on"
       EndSection
    Then log out and in again for it to take effect.

  * fglrx (Catalyst): The fglrx driver also disables sync-to-vBlank support
    by default. To fix this:
      1. Open Catalyst Control Center.
      2. Go to 3D > More Settings.
      3. Set "Wait for vertical refresh" to
         "On, unless application specifies".

  * Please don't try using the Benchmark plugin in compiz-plugins-extra
    because it is broken and misleading (bug 898548).

Please leave feedback in the relevant bug reports.

- Daniel

---

ppa:vanvugt/compiz | https://launchpad.net/~vanvugt/+archive/compiz
compiz (1:0.9.6+bzr20110929-0ubuntu6vv2) oneiric

  * Added proposed fix for inaccurate frame timing causing tearing and
    stuttering.
    (LP: #880707) (LP: #888039) (LP: #92599) (LP: #798868) (LP: #876575)

ppa:vanvugt/unity | https://launchpad.net/~vanvugt/+archive/unity
unity (4.24.0-0ubuntu2b1vv4) oneiric; urgency=low

  * Fix major performance regressions due to unnecessary UnityFBO binding
    (LP: #861061) (LP: #880707)
    UnityFBO was being bound even when not required. This caused major lag in
    glPaintOutput, which slowed down all rendering. This was seen in reduced
    framerates in apps (LP: #861061) and significantly worse screen tearing
    with Unity 4.x compared to 3.x (LP: #880707).

Rocko (rockorequin) wrote :

With unity+compiz from the PPA on sandy bridge graphics, I have so far encountered one instance of degradation (but it's nowhere near as bad as before).

The degradation is that I see some tearing when moving a window around (which no longer happens immediately after login) and occasionally the window 'freezes' for a second before jumping over to where the mouse now is.

glxspheres is doing something similar: it reported 59, 59, 42, 59, 59, 42, 59, 59, 42,... ie every few seconds it was stuttering and losing framerate, then recovering.

A minute later I still see the tearing but glxspheres seems to have totally recovered. The 'freeze' when moving a window around is also much improved.

Daniel van Vugt (vanvugt) wrote :

I think the "freeze" issue is probably more accurately described by a different bug. I've seen several people make reference to such long pauses in other bugs but don't know if anyone has given it a unique bug ID yet.

Rocko (rockorequin) wrote :

OK, perhaps it is another bug. Anyway, after a suspend/resume I'm now seeing the 'jumpy' or 'jerky' animation when moving windows just like before, including where the window stops moving completely (freezes) until you stop moving the mouse, even if it's 10 seconds later. To get the window moving animation to work, you have to move the mouse really slowly. glxspheres is still at 59fps, though.

Daniel van Vugt (vanvugt) wrote :

Please log a bug for the "freeze" problem if you can't find an existing one. And subscribe me too.

I think we have to be careful to treat it as a different issue to stuttering, which so far I have classified as 20-30 FPS. If you're waiting a couple of seconds (i.e. 0-1 FPS) then the root cause of that problem is going to be something different.

Daniel van Vugt (vanvugt) wrote :

Come to think of it, a frame rate of 0-2 FPS might be fixed by this:
https://code.launchpad.net/~vanvugt/compiz-core/fix-priority/+merge/81952

But I'm not game to add it to the PPA unless I can reproduce the bug. And with my current code I can't reproduce or test the bug the fix was designed to address :P

Daniel van Vugt (vanvugt) wrote :

I take that back. I've queued up the timer priority fix in my PPA since it's already been accepted for upstream compiz. Could take hours to be built and published though...

compiz (1:0.9.6+bzr20110929-0ubuntu6vv4) oneiric; urgency=low

  * Fix timer scheduling priority. It was set too high, which starved compiz'
    own event loop of X and GLX events. This caused all sorts of tearing,
    stuttering and hang-related bugs.

 -- Daniel van Vugt <email address hidden> Mon, 05 Dec 2011 15:34:10 +0800

compiz (1:0.9.6+bzr20110929-0ubuntu6vv3) oneiric; urgency=low

  * Improved the frame timing fix (previous commit) to also avoid excessive
    lag when doing fullscreen repaints. This means you can once again use the
    compiz workaround "Force full screen redraws (buffer swap) on repaint" if
    you want.

 -- Daniel van Vugt <email address hidden> Mon, 05 Dec 2011 14:41:03 +0800

peter huwe (pjhuwe) wrote :

Daniel, you are a wizard. It's been two days since I installed your PPA, and I haven't had any degradation problems since. Fingers crossed that I didn't just jinx it. Thanks for all your work!

Changed in compiz:
assignee: Daniel van Vugt (vanvugt) → nobody
status: In Progress → Confirmed
Changed in compiz (Ubuntu):
assignee: Daniel van Vugt (vanvugt) → nobody
status: In Progress → Confirmed
affects: compiz (Ubuntu) → unity (Ubuntu)
affects: compiz → unity
Jason Smith (jassmith) on 2012-01-30
Changed in unity:
status: Confirmed → Fix Committed
importance: Undecided → Critical
assignee: nobody → Jason Smith (jassmith)
milestone: none → 5.2.0
Jason Smith (jassmith) on 2012-01-30
Changed in unity (Ubuntu):
status: Confirmed → Fix Committed
importance: Undecided → Critical
assignee: nobody → Jason Smith (jassmith)
Jason Smith (jassmith) on 2012-01-30
description: updated
71 comments hidden view all 151 comments
Michael Knap (michael-knap) wrote :

I will be testing Daniel's ppa over the next few days. I will report back here on the tests. Also, I will read the HowToTriage, and see what I can do with those bugs.

Michael Knap (michael-knap) wrote :

I've installed your packages Daniel, and I'm getting some other instability. compiz or unity restarts or compiz/unity dies without a restart. I haven't done any debugging yet on these issues, but I will continue to look into it.

What is the correct course of action here ?

Jason Smith (jassmith) wrote :

its unlikely any instability is being introduced by this bug. Follow normal bug reporting procedure.

Awesome job on this guys!!! I've been waiting to see the resolution of this bug! Michael, great work on finding the increasing CPU usage over time! not sure if anyone would have caught that! Awesome job and great initiative!

Michael Knap (michael-knap) wrote :

Just a quick report: Jason's fix and Daniel's packages appear to be working wonderfully ! Over the past 24 hours, compiz cpu usage has not climbed and remains steady <=4% on both of the machines I work on which exhibited this problem.

Thank You.

Didier Roche (didrocks) on 2012-02-03
Changed in unity:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (5.4 KiB)

This bug was fixed in the package unity - 5.2.0-0ubuntu1

---------------
unity (5.2.0-0ubuntu1) precise; urgency=low

  * New upstream release.
    - Unity needs a way to switch (tab) between windows on current workspace
      (LP: #863399)
    - compiz crashed with SIGSEGV in BamfLauncherIcon::NameForWindow()
      (LP: #865840)
    - Gradual degradation in desktop performance. (LP: #888039)
    - compiz (unity) crashes with SIGSEGV when a window is minimized.
      (LP: #918329)
    - FavoriteStore external change support (LP: #681503)
    - Launcher - Make Launcher left of screen reveal more responsive and less
      prone to false positives (LP: #765819)
    - Window auto-maximise functionality should be disabled on monitors with a
      resolution above 1024 x 600 (LP: #797808)
    - Dash: very high latency responding to input (LP: #828582)
    - Dash - Behaviour of the 'All' button in the Dash filters broken in
      several ways (LP: #841864)
    - alt-tab - The app title in the top left of the top bar should change as
      the alt-tab focus changes (LP: #855516)
    - Keyboard shortcut - Add keyboard shortcut hint overlay that is displayed
      when a user presses and holds the Super key (LP: #855532)
    - Unity crashes when started in an environment without utouch support
      (LP: #860707)
    - Dash - Remove Dash Home shortcut icons (LP: #885738)
    - Dash - Most Frequently Used apps change to Recently Used, without
      Launcher favorites (LP: #893214)
    - Should have a launcher on every monitor (LP: #915944)
    - Launcher autohide behaviour on multi-monitor (LP: #915946)
    - the unity wrapper should kill compiz before restarting it (LP: #919132)
    - Launcher - Implement workspace/launcher cross interactions (LP: #690143)
    - Application icons should only display windows from the current workspace
      in the window spread (LP: #689733)
    - Notification area ("system tray") missing when using dual monitors of
      different sizes, with their bottoms aligned (LP: #778256)
    - Clicking Nautilus launcher icon fails to open a Nautilus file explorer
      window when copying a file and all other Nautilus windows are closed /
      bamf should skip the taskbar (LP: #784804)
    - Dash - the search box is not aligned correctly relative to the Launcher
      BFB button (LP: #838904)
    - Dash - A expand/collapse arrow is missing from all the filter category
      headers (LP: #841870)
    - Dash - the filter buttons should not have a mouse over state
      (LP: #838901)
    - Dash - the "Filter results" text is the wrong size, wrong font weight,
      and aligned incorrectly in both the vertical and horizontal axis
      (LP: #863240)
    - Add SUPER+TAB switching mode that enables the user to switch
      applications via the Launcher (LP: #891620)
    - Software Centre - automatically add app icon to launcher (LP: #761851)
    - Compiz add transparency to titlebar along with the panel (LP: #912682)
    - The search box is too opaque and dark (LP: #913717)
    - Dash - Make statefulness of Dash Home and Dash Lenses consistent
      (LP: #914759)
    - Unity 5.0: "All" button for filters render as "..." (LP: #91...

Read more...

Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
Daniel van Vugt (vanvugt) wrote :

I'm guessing by the silence that the fix seems to be working for everyone?...

I'm thinking so!

<3 you guys.

Rocko (rockorequin) wrote :

I also think it is working great! (I'm using libnux 1.16.0-0ubuntu1.1vv1 and unity 4.28.0-0ubuntu2vv2 which look like the latest versions from ppa:vanvugt/unity.)

Joar Jegleim (joar-jegleim) wrote :

I'm still having some issues, I had some performance drop (as in very lag'y desktop) on thursday or friday before the weekend, and I'm seeing some symptoms again now.

I'm thinking I may have an other bug if no one else see any regression after last update .

I'm having trouble reporting in detail since my work days are pretty hectic, and when I hit performance problems I seldom have time to look into it 'cause I'm in the middle of something and just have to reboot and pick up where I left .
I'm working mainly through terminals, I've got 6 virtual desktops, 1 with chromium and firefox, 1 with thunderbird and the rest is filled with terminator + I got xchat, spotify and a terminator on my second monitor 'always on visible workspace' .

Ben Gamari (bgamari) wrote :

Joar,

Yes, you are likely seeing another bug. If you are still having problems the best way to proceed will be to open a new bug and attach a perf profile as was done to pinpoint this one.

AndreK (andre-k) wrote :

"dpkg -s unity" returns :
....
version: 4.28.0-0ubuntu2
...

Does this mean I did not get the update yet ? 5.2.0 seems so far away ?

Daniel van Vugt (vanvugt) wrote :

AndreK, you appear to not have the fix installed. You need to be using ppa:vanvugt/unity to get the fix for oneiric;
https://launchpad.net/~vanvugt/+archive/unity

AndreK (andre-k) wrote :

I suspected that - when does "fix released" actually mean it's an actual update in the standard repository ? when is it expected to be there. ?

Daniel van Vugt (vanvugt) wrote :

The fix is in Unity 5.2.0 as per comment #117, so it will be in 12.04 when that gets Unity 5.2. A fix has not been proposed for 11.10 yet. I said I would do so when the fix in my PPA has been sufficiently tested. Although, please don't shoot the messenger... I'm just doing this because I care.

I agree that Ubuntu's handling of Fix Released is very confusing in the least. You have no idea if Fix Released means the fix is available in an actual GA release, or is only queued up to go into the next alpha release, or if it will _ever_ be available in an update for an existing release. This problem is discussed in bug 163694, bug 827912, bug 151925, and probably many others too.

Lem (lem-jjr) wrote :

I'm not sure exactly where I should report it, but Daniel with the latest version of compiz/unity in your PPA on Ubuntu 11.10, I can run OilRush fullscreen at virtually the same speed as a non-composited desktop, provided I use Unredirect Fullscreen Windows (enabled via ccsm). The composited desktop is fast and responsive too.

Well done to you and others who have fixed this up. Will these performance settings be the default for 12.04? The last few Ubuntu releases have needed tweaking to get decent performance out of the box :( It's harder now that CCSM is outdated and can break the compiz configuration.

(my config: Phenom II X4 955, GTX560Ti 1Gb, 1920x1200, nvidia binary driver, Ubuntu 11.10 AMD64)

Daniel van Vugt (vanvugt) wrote :

Yes, I do believe all the performance-related fixes in my PPAs will be in Ubuntu 12.04.

Jason Smith (jassmith) wrote :

I am confirming that all the perf fixes will be in 12.04. probably some extra ones too. I am tired of hearing about slow perf and finally have some free cycles to do something about it. Mmmm yes optimization goodness here I come.

Daniel van Vugt (vanvugt) wrote :

Jason, I don't suppose you could improve the fix for this bug to use std::set instead of std::vector? Or even remove the code completely in Nux 2.0 as you mentioned in the MP? :)

Omer Akram (om26er) on 2012-02-08
Changed in unity (Ubuntu Oneiric):
importance: Undecided → High
status: New → Confirmed
Omer Akram (om26er) on 2012-02-08
Changed in unity (Ubuntu Oneiric):
status: Confirmed → Triaged
Omer Akram (om26er) on 2012-02-09
description: updated
Daniel van Vugt (vanvugt) wrote :

Merged into lp:nux/1.0 at revision 499

Changed in unity (Ubuntu Oneiric):
status: Triaged → Fix Committed
assignee: nobody → Daniel van Vugt (vanvugt)
Sebastien Bacher (seb128) wrote :

Uploaded: https://launchpad.net/ubuntu/oneiric/+queue?queue_state=1&queue_text=nux

Subscribed ubuntu-sru as well, somebody from that team will review and approve the upload next and update the bug asking for testing when that happens (probably next week though since it's friday)

Hello Chauncellor, or anyone else affected,

Accepted nux into oneiric-proposed. The package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed
Magnetizer (magnetizer) wrote :

Hi everybody,

Daniel, I have your used your unity PPA for some time now (+/- 2 weeks).

My first impression was that it solved the problem, but after some hours the bug just returned.

Window movement gets very slow after using unity for some time (some hours max). When it occurs I can see all windows stopping to refresh until I stop moving the window. This is most visible if I play a video in one window and try to move this window (or any other window) at the same time.

The moment I stop moving the window the video refreshes and plays again and the window moves to the new position. During all the time, the sound of the video continues normally.

If I use the 2D version of unity or XFCE, LXDE everything works normal. It also "works" if I move the window very slowly. I can see some refreshes while moving the window but the video stutters.

There are a lot of bugs out there reporting "bad performance" of unity in Ubuntu 11.10, so it is difficult to decide which is the right bug report.

Right now, I do not know which possible solution to try next. From what I saw this far this bug report matched my problem the most but unfortunately it did not solve the problem.

Does anyone have suggestions for the next step?

Thanks!

Jason Smith (jassmith) wrote :

There is an unrelated bug dealing with an improper freeing in unity that resulted in memory corruption. This memory corruption results in behavior similar to what you described. A fully up to date unity without PPA's will resolve the issue.

Magnetizer (magnetizer) wrote :

Thanks Jason, I will try updating unity to the newest version available without the PPA from Daniel.

Do you happen to know the ID of the bug you are describing?

Maciej Dragan (maciej-dragan) wrote :

Hi, I'm using Daniel's PPA for few days now and my Unity became usable again but I'm experiencing the same problem as Andre. I can't find any updates for both unity and nux in oneiric-proposed. Was it released, or the fix is only for 12.04?

dpkg -s nux-tools
... 1.16.0-0ubuntu1.1+fixlp892443-ppa1~oneiric1 ...
dpkg -s unity
... 4.28.0-0ubuntu2 ...

Magnetizer (magnetizer) wrote :

Hi Jason & Maciej,

I purged Daniel's PPA and tried ppa:unity-team/staging in order to apt-get update && apt-get-upgrade to the latest unity version. Strange enough it did not update my unity version which is still 4.28.0.

What did I do wrong?

I also tried the alpha 2 of Ubuntu 12.04 for some time. It uses unity 5.4.0 and it seems that it is much snappier than my current desktop.

Any ideas?

Omer Akram (om26er) wrote :

staging ppa is for precise only.

Magnetizer (magnetizer) wrote :

Omer, thanks.

Are you sure of explanation?

I followed

http://www.omgubuntu.co.uk/2012/01/how-to-install-unity-5-0-in-ubuntu-11-10/

where it says to install ppa:unity-team/staging

But indeed, it did not work... ;-)

What are my alternatives? Do I need to compile unity 5.4 myself or do you happen to know a .deb file out there?

Omer Akram (om26er) wrote :

Andre, you can't compile 5.4 simply as that would need quite a few other things like compiz, nux libunity and prolly a few others as well. You could try Precise Pangolin Beta-2 set to release thursday, 1st of March.

Magnetizer (magnetizer) wrote :

Omer, thanks, I get it.

I read about it and did not found a solution. I tried the Alpha2 of Precise Pangolin which is indeed a lot snappier.

I will try the Beta-2 next week. If it is stable enough I will run it. Otherwise I'll just wait for the final release. In fact, unity 4 in Ubuntu 11.10 is workable, but just not very snappy after some time. I still have XFCE and LXDE as alternatives..;-)

Thanks for the explanation.

Changed in unity (Ubuntu Oneiric):
status: Fix Committed → Fix Released
Daniel van Vugt (vanvugt) wrote :

nux (1.16.0-0ubuntu1.2) oneiric-proposed; urgency=low

  * NuxGraphics/RunTimeStats.cpp:
    - Gradual degradation in desktop performance. (LP: #888039)
 -- Omer Akram <email address hidden> Thu, 09 Feb 2012 20:56:12 +0500

Daniel van Vugt (vanvugt) wrote :

And FYI, the fix for this appears in precise in nux version 2.2.0-0ubuntu1. Though it wasn't mentioned in the changelog...

nux (2.2.0-0ubuntu1) precise; urgency=low

  * New upstream release.
    - Dash - Behaviour of the 'All' button in the Dash filters broken in
      several ways (LP: #841864)
    - Launcher, Spread - Clicking on a Launcher app icon a second time to
      close a spread is broken (LP: #893670)
    - launcher not hiding in one design-specified case (LP: #919162)
    - compiz crashed with SIGSEGV in
      nux::GridHLayout::KeyNavIterationRowOrder() (LP: #916088)
  * Cherry-pick an additional fix for boot time

 -- Didier Roche <email address hidden> Fri, 03 Feb 2012 11:35:48 +0100

Saúl Romero (spacetree) wrote :

I'm experiencing the same problem in Precise, with a Dell XPS 15.

In my case, degradation is noticeable from the moment I open an application. Also, I noticed today (as im writing this) that the performance goes smoother witouth t he power connected to the laptop, working on battery power. My guess is that the problem is in the interaciton Nvidia-Unity.

Any insights?

Saul, You should look around for a bug report regarding your issue. If you cannot find one then please open a new bug report by running 'ubuntu-bug compiz'.

This report has been resolved so it's not much use.

Brian Murray (brian-murray) wrote :

The verification of the fix for this bug in oneiric-proposed never occurred so I am setting the task back to Fix Committed. It'd be great if somebody could test the package from -proposed so we can release the fix.

Changed in unity (Ubuntu Oneiric):
status: Fix Released → Fix Committed
Pushkin (kovshovik-alexandr) wrote :

It looks like this problem is finally resolved and released in Ubuntu Quantal: http://www.ubuntuupdates.org/bugs?package_name=libnux-3.0-0

This Bug is a very entertaining read: thank you Chauncellor for detailed problem description.

Thank you, Daniel van Vugt, for keeping cool at all times.

The fix for this bug has been awaiting testing feedback in the -proposed repository for oneiric for more than 90 days. Please test this fix and update the bug appropriately with the results. In the event that the fix for this bug is still not verified 15 days from now, the package will be removed from the -proposed repository.

tags: added: removal-candidate
Rocko (rockorequin) wrote :

I'm not using Oneiric any more, but Quantal is perfoming well for me (apart from unity-compiz hanging and needing restarting sometimes, but I suspect that's an intel driver issue). Has Quantal got the same fix as Oneiric? The only times I've noticed performance degradation in Quantal is after an intel driver crash.

Brian Murray (brian-murray) wrote :

The version of nux in oneiric-proposed has been removed as this bug report was not verified in a timely fashion.

Changed in unity (Ubuntu Oneiric):
status: Fix Committed → Triaged
tags: removed: verification-needed
tags: removed: removal-candidate
Adolfo Jayme (fitojb) on 2013-05-18
Changed in unity (Ubuntu Oneiric):
status: Triaged → Won't Fix
Ron Karoles (rkaroles) on 2015-06-10
Changed in unity (Ubuntu):
assignee: Jason Smith (jassmith) → Ron Karoles (rkaroles)
Displaying first 40 and last 40 comments. View all 151 comments or add a comment.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers