compiz crashed with SIGSEGV in nux::Property<nux::color::Color>::operator=() from unity::switcher::SwitcherController::OnBackgroundUpdate()

Bug #887465 reported by GaaL on 2011-11-08
28
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
High
Daniel van Vugt
4.0
Fix Released
Undecided
Daniel van Vugt
unity (Ubuntu)
High
Daniel van Vugt
Oneiric
Undecided
Unassigned

Bug Description

SRU TEST CASE

1. Install unity from oneiric-proposed
2. test it does not crash

=====Original report=====
Crash occured when changing options via "CompizConfig" but don't know which one.

ProblemType: Crash
DistroRelease: Ubuntu 11.10
Package: unity 4.24.0-0ubuntu2b1
Uname: Linux 3.0.3-030003-generic x86_64
ApportVersion: 1.23-0ubuntu4
Architecture: amd64
Date: Mon Nov 7 16:04:41 2011
EcryptfsInUse: Yes
ExecutablePath: /usr/bin/compiz
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release amd64 (20101007)
ProcCmdline: compiz
ProcCwd: /home/melankh
ProcEnviron:
 LANGUAGE=fr:en
 PATH=(custom, no user)
 LANG=fr_FR.UTF-8
 LC_MESSAGES=fr_FR.UTF-8
 SHELL=/bin/bash
SegvAnalysis:
 Segfault happened at: 0x7f52e5952c3d <_ZN3nux8PropertyINS_5color5ColorEEaSERKS2_+45>: mov 0x8(%rdi),%rax
 PC (0x7f52e5952c3d) ok
 source "0x8(%rdi)" (0x00000059) not located in a known VMA region (needed readable region)!
 destination "%rax" ok
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: unity
StacktraceTop:
 nux::Property<nux::color::Color>::operator=(nux::color::Color const&) () from /usr/lib/compiz/libunityshell.so
 unity::switcher::SwitcherController::OnBackgroundUpdate(_GVariant*, unity::switcher::SwitcherController*) () from /usr/lib/compiz/libunityshell.so
 ?? () from /usr/lib/compiz/libunityshell.so
 g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
 ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
Title: compiz crashed with SIGSEGV in nux::Property<nux::color::Color>::operator=()
UpgradeStatus: Upgraded to oneiric on 2011-10-13 (25 days ago)
UserGroups: adm admin audio cdrom dialout dip fax floppy fuse libvirtd lpadmin netdev plugdev sambashare tape vboxusers video
XsessionErrors:
 (nautilus:2764): Gtk-CRITICAL **: gtk_action_set_visible: assertion `GTK_IS_ACTION (action)' failed
 (nautilus:2764): Gtk-CRITICAL **: gtk_action_set_visible: assertion `GTK_IS_ACTION (action)' failed

Related branches

GaaL (gaal33) wrote :

StacktraceTop:
 empty (this=<optimized out>) at /usr/include/sigc++-2.0/sigc++/functors/slot_base.h:273
 operator() (_A_a2=..., _A_a1=..., this=0x3b1a908) at /usr/include/sigc++-2.0/sigc++/functors/slot.h:592
 Set (value=..., this=0x3b1a8e0) at /usr/include/Nux-1.0/NuxCore/Property-inl.h:105
 nux::Property<nux::color::Color>::operator= (this=<optimized out>, value=<optimized out>) at /usr/include/Nux-1.0/NuxCore/Property-inl.h:75
 unity::switcher::SwitcherController::OnBackgroundUpdate (data=<optimized out>, self=0x1c27b30) at /build/buildd/unity-4.24.0/plugins/unityshell/src/SwitcherController.cpp:66

Changed in unity (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
GaaL (gaal33) on 2011-11-08
visibility: private → public
Didier Roche (didrocks) on 2011-11-22
Changed in unity (Ubuntu):
importance: Medium → Critical

Okay, so this crash occurred when you changed options in CCSM. What happened after that? Did you get to a successful Unity session after a reboot?

If yes, then it *may* be normal, not a bug. If no, then its purely a bug.

Changed in unity:
status: New → Incomplete
Changed in unity (Ubuntu):
status: New → Incomplete
Changed in unity:
importance: Undecided → High
Daniel van Vugt (vanvugt) wrote :

Confirmed. valgrind says:

==22465== Process terminating with default action of signal 11 (SIGSEGV)
==22465== Access not within mapped region at address 0x78
==22465== at 0x18C9D17D: nux::Property<nux::color::Color>::operator=(nux::color::Color const&) (slot_base.h:273)
==22465== by 0x18C9C4D2: unity::switcher::SwitcherController::OnBackgroundUpdate(_GVariant*, unity::switcher::SwitcherController*) (SwitcherController.cpp:66)
==22465== by 0x18D3FD48: ubus_server_pump_message_queue(_UBusServer*) (ubus-server.cpp:284)
==22465== by 0x66A6A5C: g_main_context_dispatch (in /lib/x86_64-linux-gnu/libglib-2.0.so.0.3000.0)
==22465== by 0x66A7257: ??? (in /lib/x86_64-linux-gnu/libglib-2.0.so.0.3000.0)
==22465== by 0x66A7791: g_main_loop_run (in /lib/x86_64-linux-gnu/libglib-2.0.so.0.3000.0)
==22465== by 0x42E855: CompScreen::eventLoop() (in /usr/bin/compiz)
==22465== by 0x422219: main (in /usr/bin/compiz)

Changed in unity:
status: Incomplete → Confirmed
Changed in unity (Ubuntu):
status: Incomplete → Confirmed
Changed in unity:
assignee: nobody → Daniel van Vugt (vanvugt)
Changed in unity (Ubuntu):
assignee: nobody → Daniel van Vugt (vanvugt)
Changed in unity:
status: Confirmed → In Progress
Changed in unity (Ubuntu):
status: Confirmed → In Progress
summary: - compiz crashed with SIGSEGV
+ compiz crashed with SIGSEGV in
+ nux::Property<nux::color::Color>::operator=() from
+ unity::switcher::SwitcherController::OnBackgroundUpdate()
Daniel van Vugt (vanvugt) wrote :

regression-release, because the offending code is new in oneiric and the use-case definitely worked in natty.

tags: added: regression-release
Changed in unity:
status: In Progress → Fix Committed
Changed in unity (Ubuntu):
status: In Progress → Fix Committed
Omer Akram (om26er) on 2011-12-08
Changed in unity (Ubuntu):
importance: Critical → High
Omer Akram (om26er) on 2011-12-08
Changed in unity:
milestone: none → 5.0.0
Omer Akram (om26er) on 2012-01-05
description: updated
Didier Roche (didrocks) on 2012-01-12
Changed in unity:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (6.0 KiB)

This bug was fixed in the package unity - 5.0.0-0ubuntu1

---------------
unity (5.0.0-0ubuntu1) precise; urgency=low

  [ Didier Roche ]
  * New upstream release.
    - compiz crashed with SIGSEGV in __dynamic_cast() (LP: #853038)
    - unity-panel-service crashed with SIGSEGV in panel_service_show_entry()
      (LP: #861144)
    - unity-panel-service crashed with SIGSEGV in
      panel_indicator_entry_accessible_get_n_children() (LP: #869816)
    - Launcher - Launcher icon for Dash does not highlight when the Alt+F1 key
      shortcut is pressed (LP: #849561)
    - compiz crashed with SIGSEGV in unity::PanelTray::FilterTrayCallback()
      (LP: #868868)
    - [regression] Compiz: Visible tearing is worse in 11.10 than 11.04, even
      when "Sync To VBlank" is enabled, but only when Unity is active.
      (LP: #880707)
    - [regression] All apps have a lower frame rate under Unity. (LP: #861061)
    - compiz crashed with SIGSEGV in
      nux::Property<nux::color::Color>::operator=() from
      unity::switcher::SwitcherController::OnBackgroundUpdate() (LP: #887465)
    - DashSearchBarSpinner.cpp:56: Conditional jump or move depends on
      uninitialised value(s) (LP: #901610)
    - quicklist shows in incorrect position when launched from workspace
      switcher (LP: #914251)
    - Build "show me the desktop" mini-app that adds a show desktop button to
      Launcher (LP: #681348)
    - Select quicklist items with just one right click (LP: #688830)
    - cannot change volume by scrolling on the icon when the SoundMenu is
      opened (LP: #722082)
    - [a11y] Unity launcher buttons are not Actionable (LP: #772573)
    - Ubuntu Start launcher item doesn't start dash with keyboard navigation
      (LP: #825037)
    - multimonitor , window management - Multi-Monitor Maximized Difficulty
      (LP: #843958)
    - [regression] Drag and drop inside dash is very slow with Active Blur
      activated (LP: #851172)
    - Activating an alt-tab icon that holds initially unminimized windows
      should unminimize all windows (LP: #854595)
    - Dash - The Dash category headers are positioned incorrectly
      (LP: #839467)
    - Missing global menu with a semi-maximized window dragged to the right.
      (LP: #861279)
    - Launcher - Dragging and dropping a running application in to the Trash
      should quit the application and (if the app is pinned to the Launcher)
      un-pin the application from the Launcher (LP: #870143)
    - top bar, integrated menu - when a application is first launched, the
      integrated menu should be displayed for 2 seconds before fading out of
      view (LP: #874254)
    - Window control buttons are not shown when an indicator is opened and the
      pointer is over the top-left corner (LP: #890970)
    - Quicklist item using some special chars doesn't show at all
      (LP: #899677)
    - PanelView.cpp:370: Conditional jump or move depends on uninitialised
      value(s) (LP: #901602)
    - unityshell.cpp:1982,1984: Conditional jump or move depends on
      uninitialised value(s) (LP: #901603)
    - Dash Search spinner sometimes doesn't spin at all (LP: #903090)
    - Point of tooltip is misaligned to focused ap...

Read more...

Changed in unity (Ubuntu):
status: Fix Committed → Fix Released

Hello GaaL, or anyone else affected,

Accepted unity into oneiric-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in unity (Ubuntu Oneiric):
status: New → Fix Committed
tags: added: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 4.28.0-0ubuntu2

---------------
unity (4.28.0-0ubuntu2) oneiric-proposed; urgency=low

  * Cherry-pick some additional fixes:
    - fix a regression where transparency is setup on the panel (LP: #830949)
    - the wrong commit causing a crash was revert. Revert the revert and
      revert the right guilty commit.

unity (4.28.0-0ubuntu1) oneiric-proposed; urgency=low

  * New upstream release.
    - don't segfault in geis_configuration_get_value() (lp: #850623)
    - get focus on dash by pressing the super key first time after login
      (lp: #860805)
    - clicking on panel when dash is open no longer causes maximized window
      to raise (lp: #873100)
    - window management, alt-tab - After using 'show desktop' to minimise all
      windows, opening any new window also incorrectly restores all
      the minimised windows (lp: #871801)
    - compiz crashed with SIGSEGV in
      unity::switcher::SwitcherModel::DetailSelectionWindow() (lp: #834630)
    - compiz crashed with SIGSEGV in g_strcmp0() (lp: #832151)
    - compiz crashed with SIGSEGV in nux::BaseWindow::GetInputWindowId()
      (when onboard is used) (lp: #865890)
    - fix multi-monitor crashers (lp: #838128, #864037, #864784, #868120)
    - Fix SIGSEGV after SwitcherController desctruction (lp: #887465)
    - Fix for "right-clicking launcher when choosing a workspace causes
      quicklists to freeze" (lp: #791810)
  * debian/patches/add_postrelease_buildfix.patch:
    - add post-release fix to build in a clean env
  * backport some additional reverts or regression fixes
 -- Didier Roche <email address hidden> Thu, 19 Jan 2012 09:54:44 +0100

Changed in unity (Ubuntu Oneiric):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers