running applications without an icon use a blank icon

Bug #886778 reported by Reece H. Dunn on 2011-11-06
26
This bug affects 5 people
Affects Status Importance Assigned to Milestone
BAMF
Medium
Brandon Schaefer
0.2
Medium
Timo Jyrinki
Unity
Fix Released
High
Brandon Schaefer
5.0
Fix Released
High
Brandon Schaefer
bamf (Ubuntu)
Undecided
Unassigned
Precise
Undecided
Timo Jyrinki
Quantal
Undecided
Unassigned
unity (Ubuntu)
Undecided
Unassigned
Precise
Undecided
Timo Jyrinki

Bug Description

[Impact]

Blank icon instead of generic icon when icon not provided by application.

[Test Case]

0. update both Unity and bamf to fixed versions (5.18.0 + 0.2.124.2)
1. install an application without an icon (e.g. Sigil);
2. run the application.
3. notice Launcher icon and task switcher icon - should not be blank

[Regression Potential]

There should be no regression potential, default icon is used only if no icon is specified. The default icon should not be used instead of real icons.

---

Starting an application that does not have an icon associated with it displays a blank icon in the launcher and the task switcher.

It should display using the standard/stock default application icon.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: unity 4.24.0-0ubuntu2b1
ProcVersionSignature: Ubuntu 3.0.0-12.20-generic 3.0.4
Uname: Linux 3.0.0-12-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 1.23-0ubuntu3
Architecture: amd64
CheckboxSubmission: 5434425585a31b50d9fa7c3153a37fe1
CheckboxSystem: b845c366ea09c60efa3a45c1b5b21525
CompizPlugins: [core,bailer,detection,composite,opengl,compiztoolbox,decor,regex,snap,move,vpswitch,grid,mousepoll,gnomecompat,animation,place,imgpng,wall,expo,resize,unitymtgrabhandles,ezoom,workarounds,session,fade,scale,unityshell]
Date: Sun Nov 6 09:53:35 2011
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Beta amd64 (20100318)
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
SourcePackage: unity
UpgradeStatus: Upgraded to oneiric on 2011-09-24 (42 days ago)

Related branches

Reece H. Dunn (msclrhd-gmail) wrote :
Bilal Shahid (s9iper1) wrote :

Thank you for taking time in filing the bug to make ubuntu better.
1).is this bug reproduceable?
2).than describe the steps to reproduce it.
also attach a screenshot of the bug.

Changed in unity (Ubuntu):
status: New → Incomplete
Reece H. Dunn (msclrhd-gmail) wrote :

Steps to reproduce:
1. install an application without an icon (e.g. Sigil);
2. press the Dash Home button on the launcher;
3. type the application name in the search bar.

NOTE: Here, dash uses the standard document icon; it should use the standard application icon [see dash.png].

4. run the application.

NOTE: Here, launcher does not use an icon; it should use the standard application icon [see launcher.png].

5. press Alt+Tab to bring up the task switcher.

NOTE: Here, the task switcher does not use an icon; it should use the standard application icon [see task-switcher.png].

Reece H. Dunn (msclrhd-gmail) wrote :
Reece H. Dunn (msclrhd-gmail) wrote :
Reece H. Dunn (msclrhd-gmail) wrote :
Reece H. Dunn (msclrhd-gmail) wrote :

This bug is 100% reproducible, and occurs with more than one application.

Bilal Shahid (s9iper1) wrote :

i have also seen this with the libre office but it was white not black.but this bug is present.

Changed in unity:
status: New → Confirmed
Changed in unity (Ubuntu):
status: Incomplete → Confirmed
Omer Akram (om26er) wrote :

thanks for your bug report. Is that still an issue in Ubuntu 12.04? Can you please test that and let us know?

Changed in unity (Ubuntu):
status: Confirmed → Incomplete
Changed in unity:
status: Confirmed → Incomplete
Daniel van Vugt (vanvugt) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. This particular bug has already been reported and is a duplicate of bug 772986, so it is being marked as such. Please look at the other bug report to see if there is any missing information that you can provide, or to see if there is a workaround for the bug. Additionally, any further discussion regarding the bug should occur in the other report. Feel free to continue to report any other bugs you may find.

This is actually a different problem then bug#772986....while it exhibits the same problem a blank icon. This one happens when the *.desktop files them selfs do not contain an icon.

Bug#772986 seems to me most likely caused by a reference counting problem.

Changed in unity:
status: Incomplete → Confirmed
Changed in unity (Ubuntu):
status: Incomplete → Confirmed
Changed in unity:
assignee: nobody → Brandon Schaefer (brandontschaefer)
Tim Penhey (thumper) on 2012-07-12
Changed in unity:
importance: Undecided → High
status: Confirmed → In Progress
milestone: none → 6.2
Changed in unity (Ubuntu):
status: Confirmed → In Progress
Changed in unity:
status: In Progress → Fix Committed
Changed in unity (Ubuntu):
status: In Progress → Fix Committed
Changed in bamf:
status: New → Fix Committed
assignee: nobody → Brandon Schaefer (brandontschaefer)
importance: Undecided → Medium
Didier Roche (didrocks) on 2012-08-10
Changed in bamf:
status: Fix Committed → Fix Released
Changed in unity:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package bamf - 0.2.122-0ubuntu1

---------------
bamf (0.2.122-0ubuntu1) quantal-proposed; urgency=low

  * New upstream release.
    - Type mismatch in libbamf bamf_control_register_application_for_pid()
      and dbus interface (LP: #1021143)
    - running applications without an icon use a blank icon (LP: #886778)
 -- Lukasz 'sil2100' Zemczak <email address hidden> Fri, 10 Aug 2012 12:18:02 +0200

Changed in bamf (Ubuntu):
status: New → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (3.9 KiB)

This bug was fixed in the package unity - 6.2.0-0ubuntu1

---------------
unity (6.2.0-0ubuntu1) quantal-proposed; urgency=low

  [ Adam Conrad ]
  * Removed debian/patches/libgeis-rename.patch

  [ Łukasz 'sil2100' Zemczak ]
  * debian/rules:
    - added override for dh_shlibdeps to point it to the private directory of
      libunity-protocol-private.so
  * debian/unity.lintian-overrides,
    debian/libunity-core-6.0-5.lintian-overrides:
    - added override to silence the binary-or-shlib-defines-rpath error, since
      we are forced to use RPATH in our case

  [ Didier Roche ]
  * New upstream release.
    - [nvidia] compiz crashed with SIGSEGV in
      nux::GraphicsEngine::QRP_GLSL_Color() from
      nux::GraphicsEngine::QRP_Color() from nux::BasePainter::PaintBackground
      (LP: #982626)
    - Launcher - when a user starts dragging a item, any folded launcher icons
      that are valid drop receptacles should unfold. (LP: #839717)
    - running applications without an icon use a blank icon (LP: #886778)
    - compiz crashed with SIGSEGV in
      unity::ui::KeyboardUtil::GetKeycodeAboveKeySymbol() (LP: #920258)
    - still some accent issues with unity/nux (LP: #950740)
    - Launcher doesn't autoscroll when holding an icon (can't reach trash)
      (LP: #987223)
    - Purchased items are not being added to the Unity launcher (LP: #925014)
    - [GLES] framebuffer output scaled incorrect in both blur and items above
      shell with multimonitor (LP: #1016789)
    - [regression] [unity 6.0] Fullscreen windows flicker and/or never redraw
      properly if panel_opacity<1.0 or dash is opened. (LP: #1024911)
    - panel and launcher blinks when using libreoffice presenter/spreadsheet
      (LP: #1024459)
    - compiz crashed with SIGSEGV in
      unity::ui::EdgeBarrierController::Impl::OnPointerBarrierEvent()
      (LP: #1020075)
    - Update to 1.6.4 (LP: #1014850)
    - [nvidia] unity crashed in nux::GraphicsEngine::QRP_GLSL_1Tex
      (glDrawArrays) (LP: #1031554)
    - Dragging image from firefox/chrome to dock causes lagg/freeze
      (LP: #772445)
    - Launcher, Dash - Showing dash, via super key, with a quicklist shown
      doesn't work (LP: #913994)
    - REGRESSION: can't type characters with accent (dead keys) (LP: #961741)
    - Launcher wrongly shows top tooltip when peforming the accordion effect
      (LP: #980942)
    - Unity Launcher Fails To Auto-Hide When Enabled & Installing Commercial
      Software (LP: #1002440)
    - logging out/in with mounted drives causes unity launcher icons to be
      duplicated (LP: #1010714)
    - Mounted volume icons doubled up in launcher (LP: #1010858)
    - Launcher - when a user starts dragging a item, the launcher icons that
      are *not* valid drop receptacles should be tinted (LP: #1020891)
    - Alt+F4 does not close the hud when Numlock or Capslock are on.
      (LP: #1022801)
    - Unity shortcut overlay needs to include shortcut for video lens
      (LP: #937334)
    - padding between last quicklist item and bottom edge is non-deterministic
      (changes randomly) (LP: #955158)
    - give a way to remove 'Show Desktop' from the Alt-Tab items
      (LP: #1014346)
    - Multi...

Read more...

Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
Eugene Romanenko (eros2) wrote :

Same bug, reported by me - #857243

Eugene Romanenko (eros2) wrote :

Please backport into Precise...

description: updated
Changed in bamf (Ubuntu Quantal):
status: New → Fix Released
Changed in bamf (Ubuntu Precise):
status: New → In Progress
assignee: nobody → Timo Jyrinki (timo-jyrinki)
Changed in unity (Ubuntu Precise):
status: New → In Progress
assignee: nobody → Timo Jyrinki (timo-jyrinki)
Timo Jyrinki (timo-jyrinki) wrote :

Separated the Dash document icon issue into bug #1081901, leaving this bug to deal with the blank icons in launcher and task switcher.

description: updated

Hello Reece, or anyone else affected,

Accepted unity into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/unity/5.18.0-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in unity (Ubuntu Precise):
status: In Progress → Fix Committed
tags: added: verification-needed
Timo Jyrinki (timo-jyrinki) wrote :

With the combination of unity now in -proposed and the related bamf update in ppa:unity-team/sru, the issue is fixed and no blank icon is shown. Instead, a generic icon is used.

tags: added: verification-done
removed: verification-needed

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 5.18.0-0ubuntu1

---------------
unity (5.18.0-0ubuntu1) precise-proposed; urgency=low

  * New upstream release.
    - Launcher: start the drag icon request from the original mouse-down
      position. (LP: #858540)
    - Ignore transient unmmaped windows on minimize/unminimize
      (LP: #929712)
    - Fixes alt+tab losing focus when alt+tabing to quickly due to ubus
      being to slow to send a message (LP: #1035628)
    - If no icon is found then use the default one. This will cause all
      blank icons to be a '?' icon (LP: #886778)
    - Use GMountOperation in g_volume_mount. GMountOperation provides a
      mechanism for interacting with the use. (LP: #713432)
    - Do not reuse the menu entries if their order changes (LP: #1062283)
    - BamfLauncherIcon: ensure the icon and name values when the running
      state changes. This avoids to get "?" icons. (LP: #772986)
    - Use linear filtering to draw icons (when needed). (LP: #1036231)
 -- Timo Jyrinki <email address hidden> Mon, 12 Nov 2012 14:17:04 +0200

Changed in unity (Ubuntu Precise):
status: Fix Committed → Fix Released
description: updated
Changed in bamf (Ubuntu Precise):
milestone: none → ubuntu-12.04.2

Hello Reece, or anyone else affected,

Accepted bamf into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/bamf/0.2.124.2-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in bamf (Ubuntu Precise):
status: In Progress → Fix Committed
tags: removed: verification-done
tags: added: verification-needed
Timo Jyrinki (timo-jyrinki) wrote :

The -proposed version works fine now.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package bamf - 0.2.124.2-0ubuntu1

---------------
bamf (0.2.124.2-0ubuntu1) precise-proposed; urgency=low

  * New upstream release.
    - Includes all previous cherry-picks
    - Daemon, BamfApplication: Use the default icon if there is not
      one defined in the desktop file. (LP: #886778)
    - BamfMatcher: don't reopen windows when iterating on view's
      list, add tests. (LP: #1082298)
    - BamfMatcher: add support for libreoffice Base, and libreoffice
      matching tests (LP: #1063862)
 -- Timo Jyrinki <email address hidden> Wed, 28 Nov 2012 15:42:28 +0200

Changed in bamf (Ubuntu Precise):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers