unity launcher does not retain custom application when dragging

Bug #879447 reported by Thabo Ntitsane on 2011-10-21
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
Low
Unassigned
5.0
Triaged
Low
Unassigned
unity (Ubuntu)
Low
Unassigned

Bug Description

We've created a custom ~/.local/share/applications/app-lication.desktop.
(yes, the filename has a hyphen in it).

It shows in the dash, but does not get retained by the launcher when
dragging it from the dash. To retain it, one has to launch it from the dash,
then right click on it in the launcher and choose "Keep In Launcher".
This works.

The desktop file looks like this:

0 user@somalia:~$ cat .local/share/applications/su-application.desktop
#!/usr/bin/env xdg-open

[Desktop Entry]
Version=1.0
Type=Application
Terminal=false
Exec=xterm -title 'Uni Application' -bg black -fg white -fn 10x20 -g 80x25+100+100 -name QVTerm -e 'ssh -X <email address hidden>'
Name=Uni Application
Comment=University Application
Icon=gnome-terminal
0 user@somalia:~$

Robert Roth (evfool) on 2011-10-21
affects: ubuntu → unity (Ubuntu)
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity (Ubuntu):
status: New → Confirmed
Didier Roche (didrocks) on 2011-10-25
Changed in unity:
status: New → Confirmed
Sebastien Bacher (seb128) wrote :

Thank you for your bug report, I can confirm that here

Changed in unity:
importance: Undecided → Low
Changed in unity (Ubuntu):
importance: Undecided → Low
Changed in unity (Ubuntu):
status: Confirmed → Triaged
Changed in unity:
status: Confirmed → Triaged

This works for me in current unity

Changed in unity:
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers