[Thinkpad T510] Plugging in DisplayPort causes Unity to crash

Bug #876613 reported by Jeff Lane on 2011-10-17
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Unity
Fix Released
Undecided
Unassigned
unity (Ubuntu)
Medium
Unassigned
Oneiric
Medium
Unassigned

Bug Description

Filing this against xorg initially as I'm not sure if it's related to the driver or if it's a Unity bug, though I've not seen this behaviour on other systems.

Plugged an external monitor into the Thinkpad T510 (7375) using the DisplayPort port. The external monitor DID come alive and display at least the 11.10 background, but Unity crashed (panel, launcher and window-decorations all went away). I had to drop to a console and reset Unity to get all the controls back and working.

Tried this twice and same thing happened each time. Plug in DisplayPort, Unity, Window decorations, Launcher all disappear even though external monitor comes on (also with no panel). unity --reset at console after unplugging external monitor to fix.

I'm also attaching a short video showing this as it occurs.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: xorg 1:7.6+7ubuntu7
ProcVersionSignature: Ubuntu 3.0.0-12.20-generic 3.0.4
Uname: Linux 3.0.0-12-generic i686
.tmp.unity.support.test.0:

ApportVersion: 1.23-0ubuntu3
Architecture: i386
CompizPlugins: [core,bailer,detection,composite,opengl,decor,mousepoll,vpswitch,regex,animation,snap,expo,move,compiztoolbox,place,grid,imgpng,gnomecompat,wall,ezoom,workarounds,resize,fade,unitymtgrabhandles,scale,session,unityshell]
CompositorRunning: compiz
Date: Mon Oct 17 11:26:10 2011
DistUpgraded: Fresh install
DistroCodename: oneiric
DistroVariant: ubuntu
ExtraDebuggingInterest: Yes, whatever it takes to get this fixed in Ubuntu
GraphicsCard:
 Intel Corporation Core Processor Integrated Graphics Controller [8086:0046] (rev 02) (prog-if 00 [VGA controller])
   Subsystem: Lenovo Device [17aa:215a]
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release i386 (20111012)
Lsusb:
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
 Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
 Bus 001 Device 002: ID 8087:0020 Intel Corp. Integrated Rate Matching Hub
 Bus 002 Device 002: ID 8087:0020 Intel Corp. Integrated Rate Matching Hub
MachineType: LENOVO 43492LU
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.0.0-12-generic root=UUID=6ebbd55b-cdb1-42ff-8d08-89305e566190 ro quiet splash initcall_debug vt.handoff=7
SourcePackage: xorg
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 02/09/2011
dmi.bios.vendor: LENOVO
dmi.bios.version: 6MET82WW (1.42 )
dmi.board.name: 43492LU
dmi.board.vendor: LENOVO
dmi.board.version: Not Available
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Not Available
dmi.modalias: dmi:bvnLENOVO:bvr6MET82WW(1.42):bd02/09/2011:svnLENOVO:pn43492LU:pvrThinkPadT510:rvnLENOVO:rn43492LU:rvrNotAvailable:cvnLENOVO:ct10:cvrNotAvailable:
dmi.product.name: 43492LU
dmi.product.version: ThinkPad T510
dmi.sys.vendor: LENOVO
version.compiz: compiz 1:0.9.6+bzr20110929-0ubuntu3
version.libdrm2: libdrm2 2.4.26-1ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 7.11-0ubuntu3
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 7.11-0ubuntu3
version.xserver-xorg: xserver-xorg 1:7.6+7ubuntu7
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.6.0-1ubuntu13
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.99~git20110811.g93fc084-0ubuntu1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.15.901-1ubuntu2
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20110411+8378443-1

Jeff Lane (bladernr) wrote :
tags: added: blocks-hwcert
Jeff Lane (bladernr) wrote :

Here's the promised video showing the failure in action as I plug in the DisplayPort connector.

bugbot (bugbot) on 2011-10-18
affects: xorg (Ubuntu) → xorg-server (Ubuntu)
Anthony Wong (anthonywong) wrote :

Symptom of this bug is similar to bug 875815 (unity 2D), while this issue is on Unity 3D.

Changed in xorg-server (Ubuntu):
assignee: nobody → Ming Lei (tom-leiming)
importance: Undecided → Medium
Robert Hooker (sarvatt) on 2011-12-01
affects: xorg-server (Ubuntu) → unity (Ubuntu)
Changed in unity (Ubuntu):
assignee: Ming Lei (tom-leiming) → nobody
Omer Akram (om26er) on 2011-12-02
tags: added: multimonitor
Bryce Harrington (bryce) wrote :

Could you also include the snippet from your .xsession-errors around the time of the crash? Often this indicates an error message that can help narrow down what the problem was.

Alternately (and perhaps even better), would you mind running unity under gdb and collect a full backtrace on the crash?

description: updated
Changed in unity (Ubuntu Oneiric):
status: New → Incomplete
Bryce Harrington (bryce) wrote :

Guessing this is going to be related to bug #828623

Bryce Harrington (bryce) on 2012-02-14
Changed in unity (Ubuntu):
status: New → Incomplete
Changed in unity:
status: New → Incomplete
Jeff Lane (bladernr) wrote :

Adding Marc Legris... Marc, if you can reproduce this, can you add the xsession-errors log for Bryce?

Did a fresh install with 11.10 and plugged a monitor in using Displayport, I'm also seeing unity die and not come back.

Changed in unity:
status: Incomplete → Confirmed
Changed in unity (Ubuntu):
status: Incomplete → Confirmed
Changed in unity (Ubuntu Oneiric):
status: Incomplete → Confirmed
importance: Undecided → Medium
Omer Akram (om26er) wrote :

Is that still an issue in Precise?

Omer Akram (om26er) on 2012-07-24
Changed in unity:
status: Confirmed → Incomplete
Changed in unity (Ubuntu):
status: Confirmed → Incomplete
Changed in unity (Ubuntu Oneiric):
status: Confirmed → Incomplete
Anthony Wong (anthonywong) wrote :

This machine is now certified with 12.04, so I assume it has been fixed.

Changed in unity (Ubuntu):
status: Incomplete → Fix Released
Changed in unity:
status: Incomplete → Fix Released
Changed in unity (Ubuntu Oneiric):
status: Incomplete → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related blueprints