Unity not longer working after upgrade to ubuntu 11.10

Bug #875209 reported by Tony Dietrich on 2011-10-15
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
unity (Ubuntu)
Undecided
Unassigned

Bug Description

After upgrading to ubuntu 11.10 unity 3d is not longer working. Tryed serveral things (reinstall compinz, ccsm, re-enabling unity in ccsm,... ). It seams that unity crashes after segfault:

tony@xllap:~$ unity
unity-panel-service: Kein Prozess gefunden
Checking if settings need to be migrated ...no
Checking if internal files need to be migrated ...no
Backend : gconf
Integration : true
Profile : unity
Adding plugins
Skipping upgrade com.canonical.unity.unity.01.upgrade
Skipping upgrade com.canonical.unity.unity.02.upgrade
Initializing core options...done
Initializing bailer options...done
Initializing detection options...done
Initializing composite options...done
Initializing opengl options...done
Initializing decor options...done
Initializing mousepoll options...done
Initializing vpswitch options...done
Initializing animation options...done
Initializing snap options...done
compiz (expo) - Warn: failed to bind image to texture
Initializing expo options...done
Initializing move options...done
Initializing place options...done
Initializing grid options...done
Initializing gnomecompat options...done
Initializing wall options...done
Initializing ezoom options...done
Initializing workarounds options...done
Initializing resize options...done
Initializing fade options...done
Initializing unitymtgrabhandles options...done
Initializing scale options...done
Initializing session options...done
error in geis_init
WARN 2011-10-15 14:14:03 glib.glib-gobject <unknown>:0 invalid (NULL) pointer instance

Screen geometry changed:
   0x0x3600x1080

unity-panel-service: Kein Prozess gefunden
Segmentation fault (core dumped)
WARNING: no DISPLAY variable set, setting it to :0

================================================

tony@xllap:~$ /usr/lib/nux/unity_support_test -p
OpenGL vendor string: NVIDIA Corporation
OpenGL renderer string: Quadro NVS 140M/PCI/SSE2
OpenGL version string: 3.3.0 NVIDIA 285.05.09

Not software rendered: yes
Not blacklisted: yes
GLX fbconfig: yes
GLX texture from pixmap: yes
GL npot or rect textures: yes
GL vertex program: yes
GL fragment program: yes
GL vertex buffer object: yes
GL framebuffer object: yes
GL version is 1.4+: yes

Unity 3D supported: yes

================================================

tony@xllap:~$ lsb_release -rd
Description: Ubuntu 11.10
Release: 11.10

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: unity 4.22.0-0ubuntu3
ProcVersionSignature: Ubuntu 3.0.0-12.20-generic 3.0.4
Uname: Linux 3.0.0-12-generic x86_64
NonfreeKernelModules: nvidia
.proc.driver.nvidia.gpus.0: Error: [Errno 21] Ist ein Verzeichnis: '/proc/driver/nvidia/gpus/0'
.proc.driver.nvidia.registry: Binary: ""
.proc.driver.nvidia.version:
 NVRM version: NVIDIA UNIX x86_64 Kernel Module 285.05.09 Fri Sep 23 17:31:57 PDT 2011
 GCC version: gcc-Version 4.6.1 (Ubuntu/Linaro 4.6.1-9ubuntu3)
.tmp.unity.support.test.0:

ApportVersion: 1.23-0ubuntu3
Architecture: amd64
CheckboxSubmission: dd5a0b5e68cf7049b7173da4e9c04390
CheckboxSystem: bb422ca46d02494cdbc459927a98bc2f
CompizPlugins: [core,bailer,detection,composite,opengl,decor,mousepoll,vpswitch,regex,animation,snap,expo,move,compiztoolbox,place,grid,imgpng,gnomecompat,wall,ezoom,workarounds,resize,fade,unitymtgrabhandles,scale,session,unityshell]
CompositorRunning: None
Date: Sat Oct 15 19:27:07 2011
DistUpgraded: Log time: 2011-10-13 23:32:58.199368
DistroCodename: oneiric
DistroVariant: ubuntu
DkmsStatus:
 nvidia-current, 285.05.09, 3.0.0-12-generic, x86_64: installed
 vboxhost, 4.0.4, 2.6.38-12-generic, x86_64: installed
 vboxhost, 4.0.4, 3.0.0-12-generic, x86_64: installed
GraphicsCard:
 nVidia Corporation G84M [Quadro NVS 140M] [10de:0429] (rev a1) (prog-if 00 [VGA controller])
   Subsystem: Lenovo ThinkPad T61 [17aa:20d8]
MachineType: LENOVO 6460DAG
PccardctlIdent:
 Socket 0:
   no product info available
PccardctlStatus:
 Socket 0:
   no card
ProcEnviron:
 PATH=(custom, no user)
 LANG=de_DE.UTF-8
 SHELL=/bin/zsh
ProcKernelCmdLine: root=UUID=40120ec0-631f-49e4-8e81-b549f5eec426 ro quiet splash
SourcePackage: unity
UpgradeStatus: Upgraded to oneiric on 2011-10-14 (0 days ago)
dmi.bios.date: 05/11/2009
dmi.bios.vendor: LENOVO
dmi.bios.version: 7LETC6WW (2.26 )
dmi.board.name: 6460DAG
dmi.board.vendor: LENOVO
dmi.board.version: Not Available
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Not Available
dmi.modalias: dmi:bvnLENOVO:bvr7LETC6WW(2.26):bd05/11/2009:svnLENOVO:pn6460DAG:pvrThinkPadT61:rvnLENOVO:rn6460DAG:rvrNotAvailable:cvnLENOVO:ct10:cvrNotAvailable:
dmi.product.name: 6460DAG
dmi.product.version: ThinkPad T61
dmi.sys.vendor: LENOVO
version.compiz: compiz 1:0.9.6+bzr20110929-0ubuntu5
version.ia32-libs: ia32-libs 20090808ubuntu26
version.libdrm2: libdrm2 2.4.26+git20111003.c82ef03e-0ubuntu0sarvatt
version.libgl1-mesa-dri: libgl1-mesa-dri 7.12.0~git20111012.ae1153c4-0ubuntu0sarvatt
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 7.12.0~git20111012.ae1153c4-0ubuntu0sarvatt
version.nvidia-graphics-drivers: nvidia-graphics-drivers N/A
version.xserver-xorg: xserver-xorg 1:7.6+7ubuntu7edgers1
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.6.0+git20110912.070f30e0-0ubuntu0sarvatt
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.99+git20110922.a6b2bd2d-0ubuntu0sarvatt
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.16.0+git20111011.823a4272-0ubuntu0sarvatt
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20111011.d575a28a-0ubuntu0sarvatt

Tony Dietrich (fullpath) wrote :
Omer Akram (om26er) wrote :

thats because you are using the Xorg edgers ppa.

Changed in unity (Ubuntu):
status: New → Invalid
To post a comment you must log in.