Double-click on the dash top panel is taken effect on the window underneith

Bug #870844 reported by markba on 2011-10-08
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Unity
Fix Released
Low
Marco Trevisan (Treviño)
4.0
Fix Released
Low
Marco Trevisan (Treviño)
unity (Ubuntu)
Low
Marco Trevisan (Treviño)
Oneiric
Undecided
Unassigned

Bug Description

When dash is actived, a double click on the top panel result in the active window underneith to go from maximized into non-maximized, just as if dash was not active. This is not expected behaviour; expected would be that the window-state of dash it self is changed (toggle maximized status).

Related branches

Omer Akram (om26er) on 2011-10-10
Changed in unity:
importance: Undecided → Low
Changed in unity (Ubuntu):
importance: Undecided → Low
status: New → Confirmed
Changed in unity:
status: New → Confirmed
tags: added: bitesize
Changed in unity:
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
Changed in unity (Ubuntu):
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)

The same happens with middle-click. Fixing both in lp:~3v1n0/unity/fix-panel-dash-interactions .

Neil J. Patel (njpatel) on 2011-10-11
Changed in unity:
milestone: none → 4.24.0
status: Confirmed → Fix Committed
Changed in unity (Ubuntu):
status: Confirmed → Fix Committed
Omer Akram (om26er) on 2011-10-16
Changed in unity:
status: Fix Committed → Fix Released

Hello markba, or anyone else affected,

Accepted unity into oneiric-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in unity (Ubuntu Oneiric):
status: New → Fix Committed
tags: added: verification-needed
Omer Akram (om26er) wrote :

I can confirm this to be fixed in the proposed version of Unity.

tags: added: verification-done
removed: verification-needed
markba (mark-baaijens) wrote :

Tested and it works as expected now.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 4.24.0-0ubuntu2

---------------
unity (4.24.0-0ubuntu2) oneiric-proposed; urgency=low

  * Cherry-pick upstream:
    - SRU0-Regression: scrollbar displacement caused dash rows to show less
      icons (LP: #875023)
    - Really reverts the UI change that was still uploaded even if we had
      reverted it…

unity (4.24.0-0ubuntu1) oneiric-proposed; urgency=low

  * New upstream release and some cherry-pick:
    - compiz crashed with SIGSEGV in PluginClassHandler<UnityWindow,
      CompWindow, 0>::get() (LP: #864758)
    - unity panel menus don't stay open when clicked on second monitor
      (LP: #869196)
    - (oneiric) menu bar in wrong place and invisible (LP: #845856)
    - Lens range widgets do not function correctly (LP: #862996)
    - Cannot raise window from panel after minimize (LP: #863114)
    - unity-panel-service crashed with SIGSEGV in g_closure_invoke()
      (LP: #843280)
    - Windows get corrupted sometimes when semi-maximizing them. (LP: #865177)
    - Automaximization happens on unminimize (LP: #868930)
    - compiz crashed with SIGSEGV in nux::ROProperty<std::string>::operator
      std::string() (LP: #869109)
    - Dash - horizental divider line in between categories incorrectly drawn
      (LP: #841750)
    - F10 opens a random menu item when it should open the first one
      [regression] (LP: #862849)
    - Switching desktops after using showdesktop can cause hidden windows to
      become "active" (LP: #864503)
    - Clicking blank space on top panel doesn't raise maximized window to
      front (LP: #864708)
    - unity launcher loses track of deja-dup windows (LP: #865051)
    - Dash - App Lens 'Rating' filter behaves incorrectly (LP: #865482)
    - Launcher does not show on "Show desktop" (LP: #867959)
    - ibus character selection window not drawn (LP: #867885)
    - the dash's entry get wrongly colored on left or right key use
      (LP: #868434)
    - [ibus] Pressing down when ibus is active moves focus (LP: #872730)
    - Double-click on the dash top panel is taken effect on the window
      underneith (LP: #870844)
 -- Didier Roche <email address hidden> Tue, 18 Oct 2011 12:47:54 +0200

Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 4.24.0-0ubuntu2b1

---------------
unity (4.24.0-0ubuntu2b1) oneiric-proposed; urgency=low

  * No-change reupload because of broken powerpc build.

unity (4.24.0-0ubuntu2) oneiric-proposed; urgency=low

  * Cherry-pick upstream:
    - SRU0-Regression: scrollbar displacement caused dash rows to show less
      icons (LP: #875023)
    - Really reverts the UI change that was still uploaded even if we had
      reverted it…

unity (4.24.0-0ubuntu1) oneiric-proposed; urgency=low

  * New upstream release and some cherry-pick:
    - compiz crashed with SIGSEGV in PluginClassHandler<UnityWindow,
      CompWindow, 0>::get() (LP: #864758)
    - unity panel menus don't stay open when clicked on second monitor
      (LP: #869196)
    - (oneiric) menu bar in wrong place and invisible (LP: #845856)
    - Lens range widgets do not function correctly (LP: #862996)
    - Cannot raise window from panel after minimize (LP: #863114)
    - unity-panel-service crashed with SIGSEGV in g_closure_invoke()
      (LP: #843280)
    - Windows get corrupted sometimes when semi-maximizing them. (LP: #865177)
    - Automaximization happens on unminimize (LP: #868930)
    - compiz crashed with SIGSEGV in nux::ROProperty<std::string>::operator
      std::string() (LP: #869109)
    - Dash - horizental divider line in between categories incorrectly drawn
      (LP: #841750)
    - F10 opens a random menu item when it should open the first one
      [regression] (LP: #862849)
    - Switching desktops after using showdesktop can cause hidden windows to
      become "active" (LP: #864503)
    - Clicking blank space on top panel doesn't raise maximized window to
      front (LP: #864708)
    - unity launcher loses track of deja-dup windows (LP: #865051)
    - Dash - App Lens 'Rating' filter behaves incorrectly (LP: #865482)
    - Launcher does not show on "Show desktop" (LP: #867959)
    - ibus character selection window not drawn (LP: #867885)
    - the dash's entry get wrongly colored on left or right key use
      (LP: #868434)
    - [ibus] Pressing down when ibus is active moves focus (LP: #872730)
    - Double-click on the dash top panel is taken effect on the window
      underneith (LP: #870844)
 -- Martin Pitt <email address hidden> Tue, 25 Oct 2011 07:01:51 +0200

Changed in unity (Ubuntu Oneiric):
status: Fix Committed → Fix Released
Omer Akram (om26er) on 2011-12-18
no longer affects: unity/5.0
Changed in unity:
milestone: 4.24.0 → 5.0.0
status: Fix Released → Fix Committed
Didier Roche (didrocks) on 2012-01-12
Changed in unity:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers