Window Management - Unmaximizing a window doesn't return to the initial size/position.

Bug #869907 reported by John Lea on 2011-10-07
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ayatana Design
Medium
John Lea
Unity
Fix Released
Medium
Sam Spilsbury
unity (Ubuntu)
Undecided
Sam Spilsbury

Bug Description

Unmaximizing a window doesn't return to the initial size/position. They keep moving to the right and get a bit smaller, e.g a remote desktop window (Remmina) that fitted exactly before maximize will now extend into the other monitor and have scrollbars.

--------------------------------

Desired Solution:

- When a maximised window is restored either by using the 'restore' window decoration button, or double clicking on empty space in the Top Bar, the window should be restored to exactly the same position it was last in. Currently there is a bug that causes the window to jump slightly to the right each time the window is restored.

John Lea (johnlea) on 2011-10-07
Changed in ayatana-design:
assignee: nobody → John Lea (johnlea)
importance: Undecided → Medium
tags: added: onew udo
Changed in ayatana-design:
status: New → Fix Committed
Changed in unity:
assignee: nobody → Sam Spilsbury (smspillaz)
Changed in unity (Ubuntu):
assignee: nobody → Sam Spilsbury (smspillaz)
John Lea (johnlea) on 2011-10-18
Changed in unity:
milestone: none → backlog
tags: added: udp
Changed in ayatana-design:
status: Fix Committed → Triaged
Sam Spilsbury (smspillaz) wrote :

Assigning me, but I'm pretty sure I fixed this a week ago.

Tim Penhey (thumper) on 2011-11-25
Changed in ayatana-design:
status: Triaged → Fix Committed
Changed in unity:
status: New → In Progress
importance: Undecided → Medium
Changed in unity (Ubuntu):
status: New → In Progress
Bryce Harrington (bryce) wrote :

Yep, I remember seeing this effect myself in oneiric, but I am not able to reproduce it now. Running wmctrl -lG in one window while maximizing/unmaximizing another window on the other screen seems to work fine. I also tested with a second window and various positions of the sample windows, and unmaximizing always restored to the previous location.

So given sam's comment I think this can be marked fixed. If someone still sees the original behavior please provide a more detailed test case of how to reproduce it.

Changed in unity (Ubuntu):
status: In Progress → Fix Released
Bryce Harrington (bryce) on 2011-12-16
Changed in unity:
status: In Progress → Fix Released
Nick Tait (jnick-tait) on 2012-04-26
Changed in ayatana-design:
status: Fix Committed → Fix Released
tags: added: reviewedbydesignp
removed: udo udp
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related blueprints