unity-panel-service crashed with SIGSEGV in panel_indicator_entry_accessible_get_n_children()

Bug #869816 reported by Stefan Pasat on 2011-10-07
146
This bug affects 19 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
Critical
Michal Hruby
unity (Ubuntu)
Critical
Michal Hruby

Bug Description

dunno much

As per duplicate: For me, this happened running "GNOME classic (no effects)". I think the crash was in response to a mouse click on the top panel somewhere.

ProblemType: Crash
DistroRelease: Ubuntu 11.10
Package: unity-services 4.22.0-0ubuntu2
ProcVersionSignature: Ubuntu 3.0.0-12.19-generic 3.0.4
Uname: Linux 3.0.0-12-generic x86_64
NonfreeKernelModules: fglrx
.tmp.unity.support.test.0:

ApportVersion: 1.23-0ubuntu2
Architecture: amd64
CompizPlugins: [core,bailer,detection,composite,opengl,compiztoolbox,decor,gnomecompat,shift,workarounds,scale,place,move,resize,imgpng,vpswitch,regex,grid,annotate,mousepoll,unitymtgrabhandles,session,expo,wall,ezoom,staticswitcher,ring,unityshell]
CompositorRunning: compiz
Date: Fri Oct 7 10:48:29 2011
DistUpgraded: Log time: 2011-10-01 16:09:20.580709
DistroCodename: oneiric
DistroVariant: ubuntu
ExecutablePath: /usr/lib/unity/unity-panel-service
GraphicsCard:
 ATI Technologies Inc Manhattan [Mobility Radeon HD 5400 Series] [1002:68e0] (prog-if 00 [VGA controller])
   Subsystem: Dell Device [1028:0455]
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Beta amd64 (20110330)
JockeyStatus:
 xorg:fglrx_updates - ATI/AMD proprietary FGLRX graphics driver (post-release updates) (Proprietary, Disabled, Not in use)
 kmod:wl - Broadcom STA wireless driver (Proprietary, Disabled, Not in use) [auto-install]
 xorg:fglrx - ATI/AMD proprietary FGLRX graphics driver (Proprietary, Enabled, In use)
MachineType: Dell Inc. Inspiron N3010
ProcCmdline: /usr/lib/unity/unity-panel-service
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, user)
 LANGUAGE=en_US:en
 LANG=en_US.UTF-8
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.0.0-12-generic root=UUID=109d94c1-5e86-469f-9f86-39c842585818 ro quiet splash vt.handoff=7
SegvAnalysis:
 Segfault happened at: 0x405782: cmp %rsi,(%rdx)
 PC (0x00405782) ok
 source "%rsi" ok
 destination "(%rdx)" (0x00007262) not located in a known VMA region (needed writable region)!
SegvReason: writing NULL VMA
Signal: 11
SourcePackage: unity
StacktraceTop:
 ?? ()
 ?? () from /usr/lib/gtk-3.0/modules/libatk-bridge.so
 g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
 ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
 g_main_loop_run () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
Title: unity-panel-service crashed with SIGSEGV in g_main_context_dispatch()
UdevDb: Error: [Errno 2] No such file or directory
UpgradeStatus: Upgraded to oneiric on 2011-10-01 (5 days ago)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
XsessionErrors:
 (gnome-settings-daemon:1977): GLib-CRITICAL **: g_variant_new_string: assertion `string != NULL' failed
 (nautilus:2028): Gtk-CRITICAL **: gtk_action_set_visible: assertion `GTK_IS_ACTION (action)' failed
 (nautilus:2028): Gtk-CRITICAL **: gtk_action_set_visible: assertion `GTK_IS_ACTION (action)' failed
 (thunderbird-bin:2031): libebook-WARNING **: e_book_client_new: Cannot get book from factory: Invalid source
dmi.bios.date: 10/18/2010
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A09
dmi.board.name: 08FJWT
dmi.board.vendor: Dell Inc.
dmi.board.version: A09
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Inc.
dmi.chassis.version: A09
dmi.modalias: dmi:bvnDellInc.:bvrA09:bd10/18/2010:svnDellInc.:pnInspironN3010:pvrA09:rvnDellInc.:rn08FJWT:rvrA09:cvnDellInc.:ct8:cvrA09:
dmi.product.name: Inspiron N3010
dmi.product.version: A09
dmi.sys.vendor: Dell Inc.
version.compiz: compiz 1:0.9.6+bzr20110929-0ubuntu3
version.fglrx-installer: fglrx-installer N/A
version.ia32-libs: ia32-libs 20090808ubuntu25
version.libdrm2: libdrm2 2.4.26-1ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 7.11-0ubuntu3
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 7.11-0ubuntu3
version.xserver-xorg: xserver-xorg 1:7.6+7ubuntu7
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.6.0-1ubuntu13
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.99~git20110811.g93fc084-0ubuntu1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.15.901-1ubuntu2
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20110411+8378443-1

Related branches

Stefan Pasat (stefan-pasat) wrote :

StacktraceTop:
 panel_indicator_entry_accessible_get_n_children (accessible=<optimized out>) at /build/buildd/unity-4.22.0/services/panel-indicator-entry-accessible.c:256
 append_children (traversal=0xc98340, accessible=0x11d7eb0) at ../../atk-adaptor/accessible-cache.c:233
 add_pending_items (data=<optimized out>) at ../../atk-adaptor/accessible-cache.c:289
 g_main_dispatch (context=0xb93e10) at /build/buildd/glib2.0-2.30.0/./glib/gmain.c:2441
 g_main_context_dispatch (context=0xb93e10) at /build/buildd/glib2.0-2.30.0/./glib/gmain.c:3011

Changed in unity (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
visibility: private → public
summary: - unity-panel-service crashed with SIGSEGV in g_main_context_dispatch()
+ unity-panel-service crashed with SIGSEGV in
+ panel_indicator_entry_accessible_get_n_children()
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity (Ubuntu):
status: New → Confirmed
Alan Jenkins (aj504) on 2011-10-14
description: updated
Didier Roche (didrocks) on 2011-10-25
Changed in unity:
status: New → Confirmed
Didier Roche (didrocks) on 2011-10-25
Changed in unity (Ubuntu):
importance: Medium → Critical
Michal Hruby (mhr3) on 2011-11-09
tags: added: a11y
Tim Penhey (thumper) on 2011-11-28
Changed in unity:
importance: Undecided → Critical
assignee: nobody → Michal Hruby (mhr3)
milestone: none → 5.0.0
Changed in unity:
status: Confirmed → Fix Committed
Omer Akram (om26er) on 2011-12-08
Changed in unity (Ubuntu):
status: Confirmed → Fix Committed
assignee: nobody → Michal Hruby (mhr3)
Didier Roche (didrocks) on 2012-01-12
Changed in unity:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (6.0 KiB)

This bug was fixed in the package unity - 5.0.0-0ubuntu1

---------------
unity (5.0.0-0ubuntu1) precise; urgency=low

  [ Didier Roche ]
  * New upstream release.
    - compiz crashed with SIGSEGV in __dynamic_cast() (LP: #853038)
    - unity-panel-service crashed with SIGSEGV in panel_service_show_entry()
      (LP: #861144)
    - unity-panel-service crashed with SIGSEGV in
      panel_indicator_entry_accessible_get_n_children() (LP: #869816)
    - Launcher - Launcher icon for Dash does not highlight when the Alt+F1 key
      shortcut is pressed (LP: #849561)
    - compiz crashed with SIGSEGV in unity::PanelTray::FilterTrayCallback()
      (LP: #868868)
    - [regression] Compiz: Visible tearing is worse in 11.10 than 11.04, even
      when "Sync To VBlank" is enabled, but only when Unity is active.
      (LP: #880707)
    - [regression] All apps have a lower frame rate under Unity. (LP: #861061)
    - compiz crashed with SIGSEGV in
      nux::Property<nux::color::Color>::operator=() from
      unity::switcher::SwitcherController::OnBackgroundUpdate() (LP: #887465)
    - DashSearchBarSpinner.cpp:56: Conditional jump or move depends on
      uninitialised value(s) (LP: #901610)
    - quicklist shows in incorrect position when launched from workspace
      switcher (LP: #914251)
    - Build "show me the desktop" mini-app that adds a show desktop button to
      Launcher (LP: #681348)
    - Select quicklist items with just one right click (LP: #688830)
    - cannot change volume by scrolling on the icon when the SoundMenu is
      opened (LP: #722082)
    - [a11y] Unity launcher buttons are not Actionable (LP: #772573)
    - Ubuntu Start launcher item doesn't start dash with keyboard navigation
      (LP: #825037)
    - multimonitor , window management - Multi-Monitor Maximized Difficulty
      (LP: #843958)
    - [regression] Drag and drop inside dash is very slow with Active Blur
      activated (LP: #851172)
    - Activating an alt-tab icon that holds initially unminimized windows
      should unminimize all windows (LP: #854595)
    - Dash - The Dash category headers are positioned incorrectly
      (LP: #839467)
    - Missing global menu with a semi-maximized window dragged to the right.
      (LP: #861279)
    - Launcher - Dragging and dropping a running application in to the Trash
      should quit the application and (if the app is pinned to the Launcher)
      un-pin the application from the Launcher (LP: #870143)
    - top bar, integrated menu - when a application is first launched, the
      integrated menu should be displayed for 2 seconds before fading out of
      view (LP: #874254)
    - Window control buttons are not shown when an indicator is opened and the
      pointer is over the top-left corner (LP: #890970)
    - Quicklist item using some special chars doesn't show at all
      (LP: #899677)
    - PanelView.cpp:370: Conditional jump or move depends on uninitialised
      value(s) (LP: #901602)
    - unityshell.cpp:1982,1984: Conditional jump or move depends on
      uninitialised value(s) (LP: #901603)
    - Dash Search spinner sometimes doesn't spin at all (LP: #903090)
    - Point of tooltip is misaligned to focused ap...

Read more...

Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
tags: added: precise
To post a comment you must log in.