compiz crashed with SIGSEGV in unity::PanelTray::FilterTrayCallback()

Bug #868868 reported by jason on 2011-10-06
62
This bug affects 14 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
High
Mirco Müller
unity (Ubuntu)
High
Mirco Müller

Bug Description

it crashed after opeing compiz unity panel

ProblemType: Crash
DistroRelease: Ubuntu 11.10
Package: unity 4.22.0-0ubuntu2
ProcVersionSignature: Ubuntu 3.0.0-12.19-generic 3.0.4
Uname: Linux 3.0.0-12-generic i686
NonfreeKernelModules: wl
ApportVersion: 1.23-0ubuntu2
Architecture: i386
CrashCounter: 1
Date: Wed Oct 5 23:37:14 2011
ExecutablePath: /usr/bin/compiz
InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release i386 (20100429)
ProcCmdline: compiz
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SegvAnalysis:
 Segfault happened at: 0x1692afe <_ZN5unity9PanelTray18FilterTrayCallbackEP7_NaTrayP12_NaTrayChildPS0_+110>: mov (%eax),%edi
 PC (0x01692afe) ok
 source "(%eax)" (0x00000000) not located in a known VMA region (needed readable region)!
 destination "%edi" ok
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: unity
StacktraceTop:
 unity::PanelTray::FilterTrayCallback(_NaTray*, _NaTrayChild*, unity::PanelTray*) () from /usr/lib/compiz/libunityshell.so
 ?? () from /usr/lib/libunity-misc.so.4
 g_cclosure_marshal_VOID__OBJECT () from /usr/lib/i386-linux-gnu/libgobject-2.0.so.0
 g_closure_invoke () from /usr/lib/i386-linux-gnu/libgobject-2.0.so.0
 ?? () from /usr/lib/i386-linux-gnu/libgobject-2.0.so.0
Title: compiz crashed with SIGSEGV in unity::PanelTray::FilterTrayCallback()
UpgradeStatus: Upgraded to oneiric on 2011-09-30 (5 days ago)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
XsessionErrors:
 (nautilus:1650): Gtk-CRITICAL **: gtk_action_set_visible: assertion `GTK_IS_ACTION (action)' failed
 (nautilus:1650): Gtk-CRITICAL **: gtk_action_set_visible: assertion `GTK_IS_ACTION (action)' failed

Related branches

jason (jasonrisenburg) wrote :

StacktraceTop:
 unity::PanelTray::FilterTrayCallback (tray=0x8ece848, icon=0x8e63320, self=0x8ec80b0) at /build/buildd/unity-4.22.0/plugins/unityshell/src/PanelTray.cpp:160
 tray_added (manager=0x87598f8, icon=0x8e63320, trays_screen=0x8ece6b0) at na-tray.c:216
 g_cclosure_marshal_VOID__OBJECT (closure=0x81e71e8, return_value=0x0, n_param_values=2, param_values=0x87652a0, invocation_hint=0xbfe3b0f0, marshal_data=0x0) at /build/buildd/glib2.0-2.30.0/./gobject/gmarshal.c:644
 g_closure_invoke (closure=0x81e71e8, return_value=0x0, n_param_values=2, param_values=0x87652a0, invocation_hint=0xbfe3b0f0) at /build/buildd/glib2.0-2.30.0/./gobject/gclosure.c:774
 signal_emit_unlocked_R (node=0x8ecf6f0, detail=0, instance=0x87598f8, emission_return=0x0, instance_and_params=0x87652a0) at /build/buildd/glib2.0-2.30.0/./gobject/gsignal.c:3272

Changed in unity (Ubuntu):
importance: Undecided → Medium
tags: removed: need-i386-retrace
visibility: private → public
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity (Ubuntu):
status: New → Confirmed
gackthugo (gackthugo) wrote :

In my case app ccsm crashed when enable/disable wobbly windows. In one situation it even auto"ended session" my ubuntu session. In ubuntu 11.10 i686.

Manu Muller (manu) wrote :

seem to be the same bug, but append at the activation of compiz window decorator
(the command of this option is 'gtk-window-decorator --replace' witch is the last functional config but no the default config))

Didier Roche (didrocks) on 2011-10-25
Changed in unity:
status: New → Confirmed
Didier Roche (didrocks) on 2011-10-25
Changed in unity (Ubuntu):
importance: Medium → Critical
Daniel van Vugt (vanvugt) wrote :

And the same stack from valgrind:

==10980== Process terminating with default action of signal 11 (SIGSEGV)
==10980== General Protection Fault
==10980== at 0x18CC0A3D: unity::PanelTray::FilterTrayCallback(_NaTray*, _NaTrayChild*, unity::PanelTray*) (PanelTray.cpp:160)
==10980== by 0x1A5BD061: ??? (in /usr/lib/libunity-misc.so.4.1.0)
==10980== by 0x9A810A3: g_closure_invoke (in /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0.3000.0)
==10980== by 0x9A93029: ??? (in /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0.3000.0)
==10980== by 0x9A9C6B0: g_signal_emit_valist (in /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0.3000.0)
==10980== by 0x9A9C851: g_signal_emit (in /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0.3000.0)
==10980== by 0x1A5BBCCE: ??? (in /usr/lib/libunity-misc.so.4.1.0)
==10980== by 0x8135250: ??? (in /usr/lib/libgdk-3.so.0.200.0)
==10980== by 0x81353CE: ??? (in /usr/lib/libgdk-3.so.0.200.0)
==10980== by 0x810D720: gdk_display_get_event (in /usr/lib/libgdk-3.so.0.200.0)
==10980== by 0x81350F1: ??? (in /usr/lib/libgdk-3.so.0.200.0)
==10980== by 0x66A6A5C: g_main_context_dispatch (in /lib/x86_64-linux-gnu/libglib-2.0.so.0.3000.0)
==10980==

Changed in unity:
assignee: nobody → Daniel van Vugt (vanvugt)
Changed in unity (Ubuntu):
assignee: nobody → Daniel van Vugt (vanvugt)
Daniel van Vugt (vanvugt) wrote :

Confirmed the fix for bug 832151 solves this one too. They have the same root cause.

Changed in unity:
status: Confirmed → Fix Committed
Changed in unity (Ubuntu):
status: Confirmed → Fix Committed
Changed in unity:
assignee: Daniel van Vugt (vanvugt) → nobody
Changed in unity (Ubuntu):
assignee: Daniel van Vugt (vanvugt) → nobody
Omer Akram (om26er) on 2011-12-08
Changed in unity:
milestone: none → 5.0.0
assignee: nobody → Mirco Müller (macslow)
Changed in unity (Ubuntu):
assignee: nobody → Mirco Müller (macslow)
Changed in unity:
importance: Undecided → High
Changed in unity (Ubuntu):
importance: Critical → High
Didier Roche (didrocks) on 2012-01-12
Changed in unity:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (6.0 KiB)

This bug was fixed in the package unity - 5.0.0-0ubuntu1

---------------
unity (5.0.0-0ubuntu1) precise; urgency=low

  [ Didier Roche ]
  * New upstream release.
    - compiz crashed with SIGSEGV in __dynamic_cast() (LP: #853038)
    - unity-panel-service crashed with SIGSEGV in panel_service_show_entry()
      (LP: #861144)
    - unity-panel-service crashed with SIGSEGV in
      panel_indicator_entry_accessible_get_n_children() (LP: #869816)
    - Launcher - Launcher icon for Dash does not highlight when the Alt+F1 key
      shortcut is pressed (LP: #849561)
    - compiz crashed with SIGSEGV in unity::PanelTray::FilterTrayCallback()
      (LP: #868868)
    - [regression] Compiz: Visible tearing is worse in 11.10 than 11.04, even
      when "Sync To VBlank" is enabled, but only when Unity is active.
      (LP: #880707)
    - [regression] All apps have a lower frame rate under Unity. (LP: #861061)
    - compiz crashed with SIGSEGV in
      nux::Property<nux::color::Color>::operator=() from
      unity::switcher::SwitcherController::OnBackgroundUpdate() (LP: #887465)
    - DashSearchBarSpinner.cpp:56: Conditional jump or move depends on
      uninitialised value(s) (LP: #901610)
    - quicklist shows in incorrect position when launched from workspace
      switcher (LP: #914251)
    - Build "show me the desktop" mini-app that adds a show desktop button to
      Launcher (LP: #681348)
    - Select quicklist items with just one right click (LP: #688830)
    - cannot change volume by scrolling on the icon when the SoundMenu is
      opened (LP: #722082)
    - [a11y] Unity launcher buttons are not Actionable (LP: #772573)
    - Ubuntu Start launcher item doesn't start dash with keyboard navigation
      (LP: #825037)
    - multimonitor , window management - Multi-Monitor Maximized Difficulty
      (LP: #843958)
    - [regression] Drag and drop inside dash is very slow with Active Blur
      activated (LP: #851172)
    - Activating an alt-tab icon that holds initially unminimized windows
      should unminimize all windows (LP: #854595)
    - Dash - The Dash category headers are positioned incorrectly
      (LP: #839467)
    - Missing global menu with a semi-maximized window dragged to the right.
      (LP: #861279)
    - Launcher - Dragging and dropping a running application in to the Trash
      should quit the application and (if the app is pinned to the Launcher)
      un-pin the application from the Launcher (LP: #870143)
    - top bar, integrated menu - when a application is first launched, the
      integrated menu should be displayed for 2 seconds before fading out of
      view (LP: #874254)
    - Window control buttons are not shown when an indicator is opened and the
      pointer is over the top-left corner (LP: #890970)
    - Quicklist item using some special chars doesn't show at all
      (LP: #899677)
    - PanelView.cpp:370: Conditional jump or move depends on uninitialised
      value(s) (LP: #901602)
    - unityshell.cpp:1982,1984: Conditional jump or move depends on
      uninitialised value(s) (LP: #901603)
    - Dash Search spinner sometimes doesn't spin at all (LP: #903090)
    - Point of tooltip is misaligned to focused ap...

Read more...

Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers