compiz assert failure: *** glibc detected *** compiz: free(): corrupted unsorted chunks: 0xa05166e0 *** (drm_intel_gem_bo_unreference)

Bug #868293 reported by Johan Smits on 2011-10-05
232
This bug affects 30 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
High
Unassigned
libdrm (Ubuntu)
Undecided
Unassigned
unity (Ubuntu)
High
Unassigned

Bug Description

Was working in a gnome-terminal and compiz crached (display dreeze). All windows came back and system is working normal again.

ProblemType: Crash
DistroRelease: Ubuntu 11.10
Package: libnux-1.0-0 1.14.0-0ubuntu1
ProcVersionSignature: Ubuntu 3.0.0-12.19-generic-pae 3.0.4
Uname: Linux 3.0.0-12-generic-pae i686
ApportVersion: 1.23-0ubuntu2
Architecture: i386
AssertionMessage: *** glibc detected *** compiz: free(): corrupted unsorted chunks: 0xa05166e0 ***
CrashCounter: 1
Date: Wed Oct 5 13:53:06 2011
ExecutablePath: /usr/bin/compiz
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Alpha i386 (20110705.1)
ProcCmdline: compiz
ProcEnviron:
 LANG=nl_NL.UTF-8
 SHELL=/bin/bash
Signal: 6
SourcePackage: nux
StacktraceTop:
 __kernel_vsyscall ()
 raise () from /lib/i386-linux-gnu/libc.so.6
 abort () from /lib/i386-linux-gnu/libc.so.6
 ?? () from /lib/i386-linux-gnu/libc.so.6
 ?? () from /lib/i386-linux-gnu/libc.so.6
Title: compiz assert failure: *** glibc detected *** compiz: free(): corrupted unsorted chunks: 0xa05166e0 ***
UpgradeStatus: Upgraded to oneiric on 2011-09-23 (12 days ago)
UserGroups: adm admin cdrom dialout libvirtd lpadmin plugdev sambashare

Johan Smits (johan-smits) wrote :

StacktraceTop:
 __libc_message (do_abort=2, fmt=0xb6ef7080 "*** glibc detected *** %s: %s: 0x%s ***\n") at ../sysdeps/unix/sysv/linux/libc_fatal.c:189
 malloc_printerr (action=<optimized out>, str=<optimized out>, ptr=0xa05166e0) at malloc.c:6283
 _int_free (av=0xb1600010, p=0xa05166d8) at malloc.c:4795
 __GI___libc_free (mem=0xa05166e0) at malloc.c:3738
 drm_intel_gem_bo_unreference_final (bo=0xa971e40, time=17621) at ../../intel/intel_bufmgr_gem.c:946

Changed in nux (Ubuntu):
importance: Undecided → Medium
tags: removed: need-i386-retrace

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in nux (Ubuntu):
status: New → Confirmed
Didier Roche (didrocks) on 2011-10-06
visibility: private → public
Changed in unity:
milestone: none → 4.24.0
importance: Undecided → High
status: New → Triaged
Changed in nux (Ubuntu):
status: Confirmed → Triaged
importance: Medium → High
summary: compiz assert failure: *** glibc detected *** compiz: free(): corrupted
- unsorted chunks: 0xa05166e0 ***
+ unsorted chunks: 0xa05166e0 *** (drm_intel_gem_bo_unreference)
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in libdrm (Ubuntu):
status: New → Confirmed
Hans gogia (hansg01) wrote :

was on normal multitasking and suddenly display freeze and everything stopped

tags: added: bugpattern-needed
Didier Roche (didrocks) on 2011-10-07
Changed in libdrm (Ubuntu):
status: Confirmed → Invalid
Changed in unity:
status: Triaged → Fix Committed
affects: nux (Ubuntu) → unity (Ubuntu)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 4.22.0-0ubuntu3

---------------
unity (4.22.0-0ubuntu3) oneiric; urgency=low

  * Cherry-pick upstream:
    - Resize the _gradient_texture (in PanelMenuView::Draw) if needed
      (LP: #863068, #868293, #869028)
 -- Didier Roche <email address hidden> Fri, 07 Oct 2011 09:03:50 +0200

Changed in unity (Ubuntu):
status: Triaged → Fix Released
Didier Roche (didrocks) on 2011-10-14
Changed in unity:
status: Fix Committed → Fix Released
To post a comment you must log in.