Maximized windows can be accidentally closed from wrong monitor.

Bug #865701 reported by Alistair Buxton on 2011-10-03
82
This bug affects 13 people
Affects Status Importance Assigned to Milestone
Release Notes for Ubuntu
Undecided
Unassigned
Unity
Fix Released
High
Marco Trevisan (Treviño)
unity (Ubuntu)
High
Marco Trevisan (Treviño)
Precise
High
Marco Trevisan (Treviño)

Bug Description

To reproduce:

1. Have two monitors
2. Maximize a window on one monitor.
3. While the window is activated, click in the top left corner of the other monitor.

This sends a close event to the active window, on the other monitor. The close controls are not shown, so it is possible to do this by accident. For example, if out of habit you click where the BFB used to be in natty, you can close the window on monitor two by accident.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: unity 4.20.0-0ubuntu2
ProcVersionSignature: Ubuntu 3.0.0-12.19-generic 3.0.4
Uname: Linux 3.0.0-12-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 1.23-0ubuntu2
Architecture: amd64
CompizPlugins: [core,bailer,detection,composite,opengl,compiztoolbox,decor,resize,snap,place,mousepoll,move,gnomecompat,grid,vpswitch,imgpng,wall,session,unitymtgrabhandles,regex,animation,expo,workarounds,fade,ezoom,scale,unityshell]
Date: Mon Oct 3 21:38:03 2011
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Beta amd64 (20110921.2)
ProcEnviron:
 LANGUAGE=en_GB:en
 PATH=(custom, user)
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
SourcePackage: unity
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Alistair Buxton (a-j-buxton) wrote :
Alistair Buxton (a-j-buxton) wrote :

Here is a screenshot explaining the problem, hope fully it is easier to understand.

BTW, it works both ways. Clicking in the top left corner of any monitor closes the active window regardless of which monitor it is on.

Arthur Peters (amp) wrote :

This even works if there is no maximized window on the other monitor. So the panel-looking-thing that is not a gnome-panel (and I sometimes wish it was) is at fault. No other window needs to be involved on the monitor where the click is done.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity (Ubuntu):
status: New → Confirmed
Alistair Buxton (a-j-buxton) wrote :

Ah yes, you don't need a maximized window on both monitors. That was just a coincidence.

Steve Langasek (vorlon) on 2011-10-08
Changed in unity (Ubuntu Oneiric):
importance: Undecided → High
status: Confirmed → Triaged
milestone: none → oneiric-updates
Changed in ubuntu-release-notes:
status: New → Fix Committed
Changed in ubuntu-release-notes:
status: Fix Committed → Fix Released
Changed in unity (Ubuntu Precise):
milestone: oneiric-updates → none
Didier Roche (didrocks) on 2011-10-25
Changed in unity:
status: New → Triaged
Changed in unity:
importance: Undecided → High
tags: added: multimonitor
tags: added: rls-mgr-p-tracking
David Barth (dbarth) on 2012-02-10
Changed in unity:
milestone: none → 5.6.0
assignee: nobody → Jason Smith (jassmith)
David Barth (dbarth) wrote :

@jassmith: feel free to reassign to someone else in dx; but please report on that rls-team priority bug. thanks

Changed in unity (Ubuntu Precise):
milestone: none → ubuntu-12.04-beta-1
assignee: nobody → Jason Smith (jassmith)
Martin Pitt (pitti) on 2012-03-02
Changed in unity (Ubuntu):
milestone: ubuntu-12.04-beta-1 → ubuntu-12.04-beta-2
Changed in unity:
assignee: Jason Smith (jassmith) → Marco Trevisan (Treviño) (3v1n0)
Changed in unity (Ubuntu Precise):
assignee: Jason Smith (jassmith) → Marco Trevisan (Treviño) (3v1n0)
Didier Roche (didrocks) on 2012-03-12
Changed in unity:
milestone: 5.6.0 → 5.8.0
tags: added: rls-p-tracking
Didier Roche (didrocks) on 2012-03-23
Changed in unity:
milestone: 5.8.0 → 5.10.0
Martin Pitt (pitti) on 2012-03-26
Changed in unity (Ubuntu Precise):
milestone: ubuntu-12.04-beta-2 → ubuntu-12.04
Changed in unity:
status: Triaged → In Progress
Changed in unity (Ubuntu Precise):
status: Triaged → In Progress
Changed in unity:
status: In Progress → Fix Committed
Changed in unity (Ubuntu Precise):
status: In Progress → Fix Committed
Didier Roche (didrocks) on 2012-04-12
Changed in unity:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (9.2 KiB)

This bug was fixed in the package unity - 5.10.0-0ubuntu3

---------------
unity (5.10.0-0ubuntu3) precise-proposed; urgency=low

  [ Oliver Grawert ]
  * Enable subarch specific quilt support
  * add linaros disable_standalone-clients.patch to make unity build with GLES

  [ Didier Roche ]
  * remove a symlink and replace with a real file for
    debian/patches/series.<arch> as not supported in non v3 (and we don't
    want v3 format with full source upstream derived branch)

unity (5.10.0-0ubuntu2) precise-proposed; urgency=low

  [ Ricardo Salveti de Araujo ]
  * Enabling build with OpenGL ES2.0 support for ARM and disable maintainer
     mode on that arch to avoid -Werror failure (LP: #980544)

unity (5.10.0-0ubuntu1) precise-proposed; urgency=low

  * New upstream release:
    - bamfdaemon crashed with SIGABRT in g_assertion_message() (LP: #926208)
    - We are using 1 bad hack for compiz hanging on startup (LP: #963264)
    - GConf backend steals glib events from compiz (LP: #965220)
    - when I closed QupZill brawser it crashed and then and then I sow
      worrning that compiz crashed but fire fox and chrome is estle working.
      gtk-window-decorator crashed with SIGSEGV in max_window_name_width()
      (LP: #948580)
    - compiz crashed with SIGSEGV in std::basic_string<...>::basic_string()
      from unity::launcher::HudLauncherIcon::HudLauncherIcon()::{lambda} from
      unity::UBusManager::OnCallback (LP: #964897)
    - unity-panel-service crashed due to heap corruption in g_free() from
      service_proxy_name_changed() [libindicator/indicator-service-
      manager.c:574] (LP: #969360)
    - Opening dash while an application is maximized makes unity completely
      useless, have to relogin (LP: #975103)
    - unity crash on alt-tab (LP: #975168)
    - Top bar - Menus should be condensed to fit panel/overlay of appmenu
      (LP: #655184)
    - Topbar - window controls for maximised windows in the top bar should
      conform to Fitts's law (LP: #839690)
    - [FFe, UIFe] Dash - When the Dash is open and there is a maximised app in
      the background, the top bar background should not disappear
      (LP: #839480)
    - Dash - The inner bottom left, bottom right and top right corners of the
      desktop dash border are rendered incorrectly (LP: #839476)
    - Showdesktoped window contents invisible in window spread (LP: #877778)
    - Maximized windows can be accidentally closed from wrong monitor.
      (LP: #865701)
    - Unity launcher on-screen corruption on resume from suspend with nVidia
      proprietary driver (LP: #915265)
    - Launcher - Inserting items into launcher makes unnecessary animations on
      other monitors (LP: #925021)
    - Far left character in panel (and launcher popups) distorted
      (LP: #927441)
    - Jenkins build failure: SetAcceptKeyNavFocusOnMouseEnter not declared
      (LP: #938037)
    - super+<unbound key> and sometimes super+<number> keys now cause launch
      to wedge with the key hints shown and retains focus instead of selecting
      the requested window (LP: #934084)
    - three-finger move does not move (Precise) (LP: #940612)
    - compiz crashed with SIGSEGV in std::__de...

Read more...

Changed in unity (Ubuntu Precise):
status: Fix Committed → Fix Released
Adolfo Jayme (fitojb) on 2013-02-26
no longer affects: unity (Ubuntu Oneiric)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers