unity-panel-service crashed with SIGSEGV in g_type_check_instance()

Bug #865122 reported by Jean-Baptiste Lallement on 2011-10-03
922
This bug affects 157 people
Affects Status Importance Assigned to Milestone
Indicator Display Objects
Fix Released
Undecided
Michal Hruby
Unity
Fix Released
Undecided
Michal Hruby
ido (Ubuntu)
High
Unassigned
Oneiric
High
Unassigned
unity (Ubuntu)
Undecided
Unassigned
Oneiric
Undecided
Unassigned

Bug Description

TEST CASE:
1. Open the sound menu
2. Press the mouse button on the volume slider and hold it down to initiate a drag
3. Move the mouse pointer over another indicator (e.g Calendar)

Result:
This crash.

ProblemType: Crash
DistroRelease: Ubuntu 11.10
Package: unity-services 4.20.0-0ubuntu2
ProcVersionSignature: Ubuntu 3.0.0-12.19-generic 3.0.4
Uname: Linux 3.0.0-12-generic i686
ApportVersion: 1.23-0ubuntu2
Architecture: i386
CompizPlugins: [core,bailer,detection,composite,opengl,decor,mousepoll,vpswitch,regex,animation,snap,expo,move,compiztoolbox,place,grid,imgpng,gnomecompat,wall,ezoom,workarounds,resize,fade,unitymtgrabhandles,scale,session,unityshell]
CrashCounter: 1
Date: Mon Oct 3 09:41:12 2011
ExecutablePath: /usr/lib/unity/unity-panel-service
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha i386 (20110209)
ProcCmdline: /usr/lib/unity/unity-panel-service
SegvAnalysis:
 Segfault happened at: 0x1fb588 <g_type_check_instance+8>: call 0x1d0df7 <__i686.get_pc_thunk.bx>
 PC (0x001fb588) ok
 source "0x1d0df7" (0x001d0df7) ok
 destination "(%esp)" (0xbf684000) not located in a known VMA region (needed writable region)!
 Stack memory exhausted (SP below stack segment)
SegvReason: writing unknown VMA
Signal: 11
SourcePackage: unity
StacktraceTop:
 g_type_check_instance (type_instance=0x98df010) at /build/buildd/glib2.0-2.30.0/./gobject/gtype.c:4051
 g_signal_emit_valist (instance=0x98df010, signal_id=18, detail=0, var_args=0xbf68417c "") at /build/buildd/glib2.0-2.30.0/./gobject/gsignal.c:2936
 g_signal_emit (instance=0x98df010, signal_id=18, detail=0) at /build/buildd/glib2.0-2.30.0/./gobject/gsignal.c:3060
 ?? () from /usr/lib/libgtk-3.so.0
 ?? () from /usr/lib/libgtk-3.so.0
Title: unity-panel-service crashed with SIGSEGV in g_type_check_instance()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
XsessionErrors:
 (nautilus:1600): Gtk-CRITICAL **: gtk_action_set_visible: assertion `GTK_IS_ACTION (action)' failed
 (nautilus:1600): Gtk-CRITICAL **: gtk_action_set_visible: assertion `GTK_IS_ACTION (action)' failed
 (indicator-weather:1603): libappindicator-WARNING **: Unable to connect to the Notification Watcher: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name :1.75 was not provided by any .service files

Related branches

lp:~mhr3/ido/bug-865122
Sebastien Bacher: Approve on 2011-10-03
Robert Carr (community): Approve on 2011-10-03
Jean-Baptiste Lallement (jibel) wrote :
visibility: private → public
description: updated
tags: added: testcase
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in indicator-sound (Ubuntu):
status: New → Confirmed
Changed in unity (Ubuntu):
status: New → Confirmed
affects: indicator-sound (Ubuntu) → ido (Ubuntu)
Changed in ido (Ubuntu Oneiric):
importance: Undecided → High

Thank you for taking the time to report this crash and helping to make Ubuntu better. This particular crash has already been reported and is a duplicate of bug #847495, so is being marked as such. Please look at the other bug report to see if there is any missing information that you can provide, or to see if there is a workaround for the bug. Additionally, any further discussion regarding the bug should occur in the other report. Please continue to report any other bugs you may find.

tags: removed: need-i386-retrace
Michal Hruby (mhr3) on 2011-10-03
Changed in ido:
status: New → In Progress
assignee: nobody → Michal Hruby (mhr3)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ido - 0.3.0-0ubuntu2

---------------
ido (0.3.0-0ubuntu2) oneiric; urgency=low

  * src/idorange.c
    - cherry picked fix from Michal Hruby for a crasher in
      IdoRange (LP: #865122)
 -- Ken VanDine <email address hidden> Mon, 03 Oct 2011 11:08:59 -0400

Changed in ido (Ubuntu Oneiric):
status: Confirmed → Fix Released
Michal Hruby (mhr3) on 2011-10-03
Changed in ido:
status: In Progress → Fix Committed
Michal Hruby (mhr3) on 2011-10-04
Changed in unity (Ubuntu Oneiric):
status: Confirmed → Fix Released
Michal Hruby (mhr3) on 2011-10-06
Changed in unity:
milestone: none → 4.24.0
status: New → Fix Released
assignee: nobody → Michal Hruby (mhr3)
Ted Gould (ted) on 2011-10-12
Changed in ido:
milestone: none → 0.3.1
Ted Gould (ted) on 2011-10-13
Changed in ido:
status: Fix Committed → Fix Released
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu laptop testing tracker.

A list of all reports related to this bug can be found here:
http://laptop.qa.ubuntu.com/qatracker/reports/bugs/865122

tags: added: laptop-testing
To post a comment you must log in.