unity launcher loses track of deja-dup windows

Bug #865051 reported by Rocko on 2011-10-03
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
Medium
Sam Spilsbury
unity (Ubuntu)
Undecided
Sam Spilsbury
Oneiric
Undecided
Unassigned

Bug Description

To reproduce:

1. Run deja-dup (search for backup in the dash since the dash doesn't find deja-dup).

2. Set a backup running (preferably one that will last a long time) so that there is a window called "Back Up" (the "Backing Up..." window) and the main deja-dup window.

3. Minimize one of the windows.

4. Click on the backup icon in the unity launcher and click again to make the window chooser appear.

Normally both windows should appear in the window chooser, but only the one currently visible appears.

If you minimize this window, clicking on the backup icon twice will show the window chooser but this time only the other window will appear.

The unity launcher does know there are two windows open for the application, because it has two white arrows next to it. But it can only restore one of them at a time.

TESTCASE

1. xterm &
2. xterm -iconic &
3. Clicking on the launcher icon should restore the initially minimized one

1. xterm -iconic &
2. Selecting in alt-tab or clicking on the launcher icon should restore the initially minimized window

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: unity 4.20.0-0ubuntu2
Uname: Linux 3.1.0-rc8-git-20111002.1538 x86_64
ApportVersion: 1.23-0ubuntu2
Architecture: amd64
CompizPlugins: [core,bailer,detection,composite,opengl,decor,text,mousepoll,gnomecompat,imgpng,snap,grid,wall,imgjpeg,move,place,vpswitch,session,compiztoolbox,resize,regex,animation,workarounds,unitymtgrabhandles,expo,fade,scale,ezoom,scaleaddon,unityshell]
Date: Mon Oct 3 13:22:27 2011
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Beta amd64 (20110330)
SourcePackage: unity
UpgradeStatus: Upgraded to oneiric on 2011-09-29 (3 days ago)

Rocko (rockorequin) wrote :
Rocko (rockorequin) wrote :

And the same thing happens with update-manager if you manage to minimize the main window before the child window appears - at that point you cannot get the main window back.

Sam Spilsbury (smspillaz) wrote :

Right, so we need to force unminimize initially minimized windows when activating the launcher icon

Changed in unity:
status: New → Confirmed
Changed in unity (Ubuntu):
status: New → Confirmed
Changed in unity:
importance: Undecided → Medium
assignee: nobody → Sam Spilsbury (smspillaz)
Changed in unity (Ubuntu):
assignee: nobody → Sam Spilsbury (smspillaz)
Changed in unity:
milestone: none → 4.24.0
Changed in unity:
status: Confirmed → In Progress
Changed in unity (Ubuntu):
status: Confirmed → In Progress
Rocko (rockorequin) wrote :

If it helps, an easy way to reproduce this is to run gedit, minimize the window, and then run sudo gedit.

Changed in unity:
status: In Progress → Fix Committed
Changed in unity (Ubuntu):
status: In Progress → Fix Released
description: updated
Didier Roche (didrocks) on 2011-10-14
Changed in unity:
status: Fix Committed → Fix Released
status: Fix Released → Fix Committed
Didier Roche (didrocks) on 2011-10-14
Changed in unity (Ubuntu):
status: Fix Released → Fix Committed
Changed in unity:
status: Fix Committed → Fix Released
status: Fix Released → Triaged
status: Triaged → Fix Committed
Omer Akram (om26er) on 2011-10-16
Changed in unity:
status: Fix Committed → Fix Released

Hello Rocko, or anyone else affected,

Accepted unity into oneiric-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in unity (Ubuntu Oneiric):
status: New → Fix Committed
tags: added: verification-needed
Rocko (rockorequin) wrote :

Great, it is almost fixed now. It works great with update-manager and two gedit windows being open.

With deja-dup, however, if for example if I do this:

* Start a backup
* When the dialog asks for a passphrase, minimize the deja-dup window
* Click on the launcher icon

then what happens is I see the passphrase window on one side of the screen, and an invisible window on the other. (It is visible while it zooms out of the launher, and then it becomes invisible.) I can click on the invisible window and the main deja-dup window appears. So the only problem is that it is invisible, really.

Rocko (rockorequin) wrote :

I just tried this on an older system (ie with the previous version of unity on it), and I was able to get the main update-manager window showing there when it was minimized and the update dialog was showing. It was invisible in the chooser, though - I had to guess where it was and click on it.

Martin Pitt (pitti) wrote :

So it seems it's getting better, but not perfect yet. So this doesn't block the SRU.

Daniel Hahler (blueyed) wrote :

Just for info: bug 842566 appears to have similar symptoms (for libreoffice).

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 4.24.0-0ubuntu2

---------------
unity (4.24.0-0ubuntu2) oneiric-proposed; urgency=low

  * Cherry-pick upstream:
    - SRU0-Regression: scrollbar displacement caused dash rows to show less
      icons (LP: #875023)
    - Really reverts the UI change that was still uploaded even if we had
      reverted it…

unity (4.24.0-0ubuntu1) oneiric-proposed; urgency=low

  * New upstream release and some cherry-pick:
    - compiz crashed with SIGSEGV in PluginClassHandler<UnityWindow,
      CompWindow, 0>::get() (LP: #864758)
    - unity panel menus don't stay open when clicked on second monitor
      (LP: #869196)
    - (oneiric) menu bar in wrong place and invisible (LP: #845856)
    - Lens range widgets do not function correctly (LP: #862996)
    - Cannot raise window from panel after minimize (LP: #863114)
    - unity-panel-service crashed with SIGSEGV in g_closure_invoke()
      (LP: #843280)
    - Windows get corrupted sometimes when semi-maximizing them. (LP: #865177)
    - Automaximization happens on unminimize (LP: #868930)
    - compiz crashed with SIGSEGV in nux::ROProperty<std::string>::operator
      std::string() (LP: #869109)
    - Dash - horizental divider line in between categories incorrectly drawn
      (LP: #841750)
    - F10 opens a random menu item when it should open the first one
      [regression] (LP: #862849)
    - Switching desktops after using showdesktop can cause hidden windows to
      become "active" (LP: #864503)
    - Clicking blank space on top panel doesn't raise maximized window to
      front (LP: #864708)
    - unity launcher loses track of deja-dup windows (LP: #865051)
    - Dash - App Lens 'Rating' filter behaves incorrectly (LP: #865482)
    - Launcher does not show on "Show desktop" (LP: #867959)
    - ibus character selection window not drawn (LP: #867885)
    - the dash's entry get wrongly colored on left or right key use
      (LP: #868434)
    - [ibus] Pressing down when ibus is active moves focus (LP: #872730)
    - Double-click on the dash top panel is taken effect on the window
      underneith (LP: #870844)
 -- Didier Roche <email address hidden> Tue, 18 Oct 2011 12:47:54 +0200

Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 4.24.0-0ubuntu2b1

---------------
unity (4.24.0-0ubuntu2b1) oneiric-proposed; urgency=low

  * No-change reupload because of broken powerpc build.

unity (4.24.0-0ubuntu2) oneiric-proposed; urgency=low

  * Cherry-pick upstream:
    - SRU0-Regression: scrollbar displacement caused dash rows to show less
      icons (LP: #875023)
    - Really reverts the UI change that was still uploaded even if we had
      reverted it…

unity (4.24.0-0ubuntu1) oneiric-proposed; urgency=low

  * New upstream release and some cherry-pick:
    - compiz crashed with SIGSEGV in PluginClassHandler<UnityWindow,
      CompWindow, 0>::get() (LP: #864758)
    - unity panel menus don't stay open when clicked on second monitor
      (LP: #869196)
    - (oneiric) menu bar in wrong place and invisible (LP: #845856)
    - Lens range widgets do not function correctly (LP: #862996)
    - Cannot raise window from panel after minimize (LP: #863114)
    - unity-panel-service crashed with SIGSEGV in g_closure_invoke()
      (LP: #843280)
    - Windows get corrupted sometimes when semi-maximizing them. (LP: #865177)
    - Automaximization happens on unminimize (LP: #868930)
    - compiz crashed with SIGSEGV in nux::ROProperty<std::string>::operator
      std::string() (LP: #869109)
    - Dash - horizental divider line in between categories incorrectly drawn
      (LP: #841750)
    - F10 opens a random menu item when it should open the first one
      [regression] (LP: #862849)
    - Switching desktops after using showdesktop can cause hidden windows to
      become "active" (LP: #864503)
    - Clicking blank space on top panel doesn't raise maximized window to
      front (LP: #864708)
    - unity launcher loses track of deja-dup windows (LP: #865051)
    - Dash - App Lens 'Rating' filter behaves incorrectly (LP: #865482)
    - Launcher does not show on "Show desktop" (LP: #867959)
    - ibus character selection window not drawn (LP: #867885)
    - the dash's entry get wrongly colored on left or right key use
      (LP: #868434)
    - [ibus] Pressing down when ibus is active moves focus (LP: #872730)
    - Double-click on the dash top panel is taken effect on the window
      underneith (LP: #870844)
 -- Martin Pitt <email address hidden> Tue, 25 Oct 2011 07:01:51 +0200

Changed in unity (Ubuntu Oneiric):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers