Ubuntu

Enabling second monitor causes crash.

Reported by Dereck Wonnacott on 2011-10-02
126
This bug affects 25 people
Affects Status Importance Assigned to Milestone
Unity
High
Sam Spilsbury
unity (Ubuntu)
High
Sam Spilsbury
Oneiric
Undecided
Unassigned

Bug Description

SRU TEST CASE:
1. start nvidia-settings
2. turn on secondary monitor with twin view
3. the screen comes up scrambled or unity crashes
4. now install Unity from oneiric-proposed
5. see there are not artifacts on the screen.

=====Original Report=====

I upgraded to 11.10 and am no longer able to use my external monitor with my laptop while using Unity. It was fine with 11.04.

I have the latest NVIDIA driver installed via jockey.
I tried both drivers listed, both act the same.

Repo:
I use the Nvidia-Settings manager tool to turn on my secondary monitor with twinview. (As usual)
The screens come up but the graphics are scrambled up. If i'm lucky Unity will crash and I'll be left with a blank screen with just my wallpaper left.

Unity 2d works as expected.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: unity 4.20.0-0ubuntu2
ProcVersionSignature: Ubuntu 3.0.0-12.19-generic 3.0.4
Uname: Linux 3.0.0-12-generic x86_64
NonfreeKernelModules: nvidia
.proc.driver.nvidia.gpus.0: Error: [Errno 21] Is a directory: '/proc/driver/nvidia/gpus/0'
.proc.driver.nvidia.registry: Binary: ""
.proc.driver.nvidia.version:
 NVRM version: NVIDIA UNIX x86_64 Kernel Module 280.13 Wed Jul 27 16:53:56 PDT 2011
 GCC version: gcc version 4.6.1 (Ubuntu/Linaro 4.6.1-9ubuntu3)
.tmp.unity.support.test.0:

ApportVersion: 1.23-0ubuntu2
Architecture: amd64
CompizPlugins: [core,bailer,detection,composite,opengl,compiztoolbox,decor,mousepoll,gnomecompat,place,imgpng,resize,unitymtgrabhandles,wall,move,grid,snap,regex,vpswitch,session,animation,fade,expo,workarounds,scale,ezoom,unityshell]
CompositorRunning: None
Date: Sat Oct 1 13:29:25 2011
DistUpgraded: Log time: 2011-09-30 12:31:36.704031
DistroCodename: oneiric
DistroVariant: ubuntu
DkmsStatus: nvidia-current-updates, 280.13, 3.0.0-12-generic, x86_64: installed
EcryptfsInUse: Yes
GdmLog1: X: /tmp/.X11-unix has suspicious mode (not 1777) or is not a directory, aborting.
GraphicsCard:
 nVidia Corporation GT218 [NVS 2100M] [10de:0a6a] (rev a2) (prog-if 00 [VGA controller])
   Subsystem: Toshiba America Info Systems Device [1179:0001]
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release amd64 (20101007)
JockeyStatus:
 xorg:nvidia_current - NVIDIA accelerated graphics driver (Proprietary, Disabled, Not in use)
 xorg:nvidia_current_updates - NVIDIA accelerated graphics driver (post-release updates) (Proprietary, Enabled, In use)
MachineType: TOSHIBA TECRA A11
ProcEnviron:
 PATH=(custom, user)
 LANG=en_US.utf8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.0.0-12-generic root=UUID=c9cb3867-8b9d-4110-ac8c-ec11f8014e88 ro quiet splash nomodeset video=uvesafb:mode_option=1600x900-24,mtrr=3,scroll=ywrap vt.handoff=7
SourcePackage: unity
UpgradeStatus: Upgraded to oneiric on 2011-09-30 (0 days ago)
dmi.bios.date: 12/03/2010
dmi.bios.vendor: TOSHIBA
dmi.bios.version: Version 2.90
dmi.board.asset.tag: 0000000000
dmi.board.name: Portable PC
dmi.board.vendor: TOSHIBA
dmi.board.version: Version A0
dmi.chassis.asset.tag: 0000000000
dmi.chassis.type: 10
dmi.chassis.vendor: TOSHIBA
dmi.chassis.version: Version 1.0
dmi.modalias: dmi:bvnTOSHIBA:bvrVersion2.90:bd12/03/2010:svnTOSHIBA:pnTECRAA11:pvrPTSE3U-0N806X:rvnTOSHIBA:rnPortablePC:rvrVersionA0:cvnTOSHIBA:ct10:cvrVersion1.0:
dmi.product.name: TECRA A11
dmi.product.version: PTSE3U-0N806X
dmi.sys.vendor: TOSHIBA
version.compiz: compiz 1:0.9.6+bzr20110929-0ubuntu1
version.ia32-libs: ia32-libs 20090808ubuntu25
version.libdrm2: libdrm2 2.4.26-1ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 7.11-0ubuntu3
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 7.11-0ubuntu3
version.nvidia-graphics-drivers: nvidia-graphics-drivers N/A
version.xserver-xorg: xserver-xorg 1:7.6+7ubuntu7
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.6.0-1ubuntu13
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.99~git20110811.g93fc084-0ubuntu1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.15.901-1ubuntu2
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20110411+8378443-1

Related branches

lp:~smspillaz/unity/unity.fix_864784_868120_872625v2
Merged into lp:unity at revision 1816
Jason Smith (community): Approve on 2012-01-05
Mirco Müller: Pending requested 2011-12-16
Neil J. Patel: Pending requested 2011-12-16
lp:~smspillaz/unity/unity.oem-fixes
Merged into lp:unity/4.0 at revision 1726
Jason Smith (community): Approve on 2012-01-05
Robert Carr: Approve on 2012-01-04
Dereck Wonnacott (dereck) wrote :
Changed in unity (Ubuntu):
status: New → In Progress
assignee: nobody → Sam Spilsbury (smspillaz)
Changed in unity:
status: New → In Progress
assignee: nobody → Sam Spilsbury (smspillaz)
milestone: none → 4.24.0
David Barth (dbarth) on 2011-10-10
Changed in unity:
milestone: 4.24.0 → 4.26.0
Gorka Navarrete (emrys) wrote :

There is any way to help test/troubleshoot this? Any idea about when the solution will land?

I've found that you can solve the problems caused by activating a second monitor by opening a virtual terminal CONTROL+ALT+F2, doing a $unity --replace and coming back to CONTROL+ALT+F7. This should give you a workable system.

Gorka Navarrete (emrys) wrote :

There is a working solution to this in the forums: http://ubuntuforums.org/showpost.php?p=11363278&postcount=21

description: updated
Jorge Gustavo (jgr) wrote :

I can have both monitors working, but only after 2 or 3 attempts. My first 10-15 minutes of each lesson is to configure Ubuntu for dual monitors. Urh!

It freezes after changing nvidia configuration. But after some attempts, it finally applies the configuration. It takes some minutes between attempts.

If the configuration is always the same, there is no problem. But since I have to connect to a lot of different projectors, it is really annoying.

Ubuntu 11.10 (did not happen in previous version, maybe since 2006). It happens both with Unity and Gnome 3.

I find that saving my settings to Xorg.conf with the second monitor enabled
and rebooting tends to work every time. But you have to have the external
monitor/projector plugged in at boot to have it work. Perhaps if you can
get a projector working, then 'save to xorg.conf' you will be able to plug
in the projector and then boot your laptop and be able to save some
time.... Less than idea but perhaps better luck to you.

I find that Unity crashes much less frequently now when enabling my
external monitor, but it's always a scary operation, I've become accustom
to closing all of my applications before trying just in case, which is
quite annoying.... I for one can't wait for 12.04.... I don't want to go
back to 10.10 but it's looking better and better every day.

~Dereck

“The greater danger for most of us lies not in setting our aim too high and
falling short; but in setting our aim too low, and achieving our mark.” -
Michelangelo

On Tue, Nov 8, 2011 at 8:30 PM, Jorge Gustavo <email address hidden> wrote:

> I can have both monitors working, but only after 2 or 3 attempts. My
> first 10-15 minutes of each lesson is to configure Ubuntu for dual
> monitors. Urh!
>
> It freezes after changing nvidia configuration. But after some attempts,
> it finally applies the configuration. It takes some minutes between
> attempts.
>
> If the configuration is always the same, there is no problem. But since
> I have to connect to a lot of different projectors, it is really
> annoying.
>
> Ubuntu 11.10 (did not happen in previous version, maybe since 2006). It
> happens both with Unity and Gnome 3.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/864784
>
> Title:
> Enableing second monitor causes crash.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/unity/+bug/864784/+subscriptions
>

I can confirm this.

02:00.0 VGA compatible controller: nVidia Corporation GT216 [GeForce GT 330M] (rev a2)

I noticed that, after applying the additional Monitor, the confirm dialog appearn on the second screen, but this screen mitght take longer than 15 seconds to warm up. Mostly i see this dialog at 1s. Hard to click "yes". but normaly this window has focus, so you can use the <leftarrow-key> to select yes, and if you see your screen seems to work you can press <enter>.

Often, when i miss that, i have to restart the displaymanager, because the mainscreen lasts black, or i can see my windows but miss windowmanger and unitybars.

-Sobo.

Thomas Telleis (sobolog) wrote :

this appears in syslog, don't know what this means, but doesn't sounds normal?!

Dec 2 15:31:18 slappy gnome-session[8937]: WARNING: Application 'compiz.desktop' killed by signal
Dec 2 15:31:18 slappy gnome-session[8937]: WARNING: App 'compiz.desktop' respawning too quickly
Dec 2 15:31:18 slappy gnome-session[8937]: CRITICAL: We failed, but the fail whale is dead. Sorry....
Dec 2 15:31:49 slappy kernel: [ 8237.444091] compiz[10054]: segfault at 58 ip 00007f8a4c9c76d1 sp 00007fff33bf36e8 error 4 in libnvidia-glcore.so.280.13[7f8a4b919000+15f4000]
Dec 2 15:31:49 slappy gnome-session[8937]: WARNING: App 'compiz.desktop' respawning too quickly
Dec 2 15:31:49 slappy gnome-session[8937]: WARNING: Application 'compiz.desktop' killed by signal
Dec 2 15:31:49 slappy gnome-session[8937]: WARNING: App 'compiz.desktop' respawning too quickly

Omer Akram (om26er) on 2011-12-02
Changed in unity:
importance: Undecided → High
Changed in unity (Ubuntu):
importance: Undecided → High
David Barth (dbarth) on 2011-12-16
Changed in unity:
milestone: 4.26.0 → 4.28.0
Shanekpiper (shanekpiper) wrote :

I have an Nvida 9600 GT with dual monitor setup. I have found that if I $ sudo nvidia-settings after 2 or 3 attempts it does what I am asking but I get the following errors in terminal:
shane@Aspire-8930:~$ sudo nvidia-settings
[sudo] password for shane:

WARNING: Unable to find CorePointer in X configuration; attempting to add new CorePointer section.
WARNING: The CorePointer device was not specified explicitly in the layout; using the first mouse device.
WARNING: Unable to find CoreKeyboard in X configuration; attempting to add new CoreKeyboard section.
WARNING: The CoreKeyboard device was not specified explicitly in the layout; using the first keyboard device.
WARNING: Unable to find CorePointer in X configuration; attempting to add new CorePointer section.
WARNING: The CorePointer device was not specified explicitly in the layout; using the first mouse device.
WARNING: Unable to find CoreKeyboard in X configuration; attempting to add new CoreKeyboard section.
WARNING: The CoreKeyboard device was not specified explicitly in the layout; using the first keyboard device.
python: can't open file '/usr/share/screen-resolution-extra/nvidia-polkit.py': [Errno 2] No such file or directory
ERROR: Unable to open X config file '/etc/X11/xorg.conf' for writing.

Why is this not working, It would be nice to just plug in a monitor/projector auto detect and apply settings without having to do this everytime.

PS running Ubuntu 12.04 Alpha release 1

Omer Akram (om26er) on 2012-01-05
Changed in unity:
status: In Progress → Fix Released
Omer Akram (om26er) on 2012-01-05
description: updated
Changed in unity:
status: Fix Released → Fix Committed
Omer Akram (om26er) on 2012-01-11
Changed in unity:
status: Fix Committed → Fix Released
Ed Guenter (edgue) wrote :

Question:

Not sure if I am "affected" by this bug ... I am using a Lenovo W510 with nvidia graphics.
After upgrading to 11.10 I figured at some point, that I cant undock my laptop any more.
Earlier on, the laptop would simply switch to the internal display - but with unity/11.10 ...
the xserver (nvida driver) is crashing.

I followed the advice of a coworker - when running unity2D the problem isnt there;
I can (un)dock without any xserver crashes.

I found this bug entry here; saw it says "fixed"; so I added the ubuntu-desktop ppa
and upgraded to unity 4.28 - rebooted; but unfortunately xserver is still crashing upon undock.

Hello Dereck, or anyone else affected,

Accepted unity into oneiric-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in unity (Ubuntu Oneiric):
status: New → Fix Committed
tags: added: verification-needed

I tried unity-4.28 from oneiric-proposed on Dell Latitude with nvidia driver 280.13

Before update I was able to crash unity (not all the times, but easily)
I tried to crash unity 6 times after update but was not able to. I have seen a brief display distortion after first switch and then system recovered. The rest of the switches were without distortion.

Omer Akram (om26er) on 2012-01-18
tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 4.28.0-0ubuntu2

---------------
unity (4.28.0-0ubuntu2) oneiric-proposed; urgency=low

  * Cherry-pick some additional fixes:
    - fix a regression where transparency is setup on the panel (LP: #830949)
    - the wrong commit causing a crash was revert. Revert the revert and
      revert the right guilty commit.

unity (4.28.0-0ubuntu1) oneiric-proposed; urgency=low

  * New upstream release.
    - don't segfault in geis_configuration_get_value() (lp: #850623)
    - get focus on dash by pressing the super key first time after login
      (lp: #860805)
    - clicking on panel when dash is open no longer causes maximized window
      to raise (lp: #873100)
    - window management, alt-tab - After using 'show desktop' to minimise all
      windows, opening any new window also incorrectly restores all
      the minimised windows (lp: #871801)
    - compiz crashed with SIGSEGV in
      unity::switcher::SwitcherModel::DetailSelectionWindow() (lp: #834630)
    - compiz crashed with SIGSEGV in g_strcmp0() (lp: #832151)
    - compiz crashed with SIGSEGV in nux::BaseWindow::GetInputWindowId()
      (when onboard is used) (lp: #865890)
    - fix multi-monitor crashers (lp: #838128, #864037, #864784, #868120)
    - Fix SIGSEGV after SwitcherController desctruction (lp: #887465)
    - Fix for "right-clicking launcher when choosing a workspace causes
      quicklists to freeze" (lp: #791810)
  * debian/patches/add_postrelease_buildfix.patch:
    - add post-release fix to build in a clean env
  * backport some additional reverts or regression fixes
 -- Didier Roche <email address hidden> Thu, 19 Jan 2012 09:54:44 +0100

Changed in unity (Ubuntu Oneiric):
status: Fix Committed → Fix Released
Matt Fischer (mfisch) on 2012-11-07
summary: - Enableing second monitor causes crash.
+ Enabling second monitor causes crash.
Changed in unity (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.