Dash - After scrolling to the bottom of the Dash using the cursor keys, navigating back upwards is broken

Bug #863405 reported by John Lea
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Ayatana Design
Fix Released
Medium
John Lea
Nux
Fix Released
Medium
Jay Taoko
Unity
Fix Released
Medium
Jay Taoko
nux (Ubuntu)
Fix Released
Medium
Unassigned
unity (Ubuntu)
Fix Released
Medium
Unassigned

Bug Description

After scrolling to the bottom of the Dash using the cursor keys, navigating back upwards using the cursor keys is broken.

To Reproduce:
1. Open the Dash and go to the App lens
2. Expand the "Installed" category header
3. using the 'down arrow' cursor key, scroll to the bottom of the results
4. when at the bottom of the results, press the 'up arrow' cursor key a few times

What currently incorrectly happens:
- after pressing up a couple of time, the focus magically jumps back to the top of the dash

Desired correct behaviour:
- pressing the 'up arrow' cursor key should be the exact opposite of pressing the 'down arrow' cursor key. The focus should move one step at a time and should not magically jump.

John Lea (johnlea)
tags: added: onew udo
Changed in ayatana-design:
assignee: nobody → John Lea (johnlea)
importance: Undecided → Medium
status: New → Fix Committed
David Barth (dbarth)
Changed in unity:
milestone: none → 4.24.0
status: New → Triaged
Changed in unity (Ubuntu):
status: New → Triaged
milestone: none → later
Revision history for this message
Gord Allott (gordallott) wrote :

Assigned nux + jay because it seems like fixing this is not possible with the current focus API we have in nux, when the focus is changed we have no idea which direction we were focused from, so we can't make sure that the correct item is focused if you navigate up say from one result view to a result view above it

Changed in unity:
assignee: nobody → Gord Allott (gordallott)
Changed in nux:
assignee: nobody → Jay Taoko (jaytaoko)
Changed in unity:
milestone: 4.24.0 → 4.26.0
John Lea (johnlea)
tags: added: udp
Changed in ayatana-design:
status: Fix Committed → Triaged
Jay Taoko (jaytaoko)
Changed in nux:
status: New → Confirmed
Changed in nux (Ubuntu):
status: New → Confirmed
John Lea (johnlea)
Changed in ayatana-design:
status: Triaged → Fix Committed
Mirco Müller (macslow)
Changed in nux:
importance: Undecided → Low
Changed in unity:
importance: Undecided → Low
David Barth (dbarth)
Changed in unity:
milestone: 4.26.0 → 4.28.0
Omer Akram (om26er)
Changed in unity:
milestone: 4.28.0 → 4.30.0
Omer Akram (om26er)
Changed in nux:
importance: Low → Medium
Changed in unity (Ubuntu):
milestone: later → oneiric-updates
Changed in nux (Ubuntu):
importance: Undecided → Medium
Changed in unity (Ubuntu):
importance: Undecided → Medium
Changed in unity:
importance: Low → Medium
Changed in unity:
milestone: 4.30.0 → 5.4.0
Andrea Azzarone (azzar1)
Changed in nux:
status: Confirmed → Fix Committed
Changed in unity:
status: Triaged → Fix Committed
Changed in nux (Ubuntu):
status: Confirmed → Fix Committed
Changed in unity (Ubuntu):
status: Triaged → Fix Committed
Changed in unity:
assignee: Gord Allott (gordallott) → Jay Taoko (jaytaoko)
Changed in nux:
milestone: none → 2.4
Changed in nux:
status: Fix Committed → Fix Released
Changed in unity:
status: Fix Committed → Fix Released
Changed in nux (Ubuntu):
status: Fix Committed → Fix Released
Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
Nick Tait (jnick-tait)
tags: added: reviewedbydesignp
Changed in ayatana-design:
status: Fix Committed → Fix Released
Nick Tait (jnick-tait)
tags: removed: udo udp
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Related blueprints