Lens range widgets do not function correctly

Bug #862996 reported by Jono Bacon on 2011-09-30
26
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
High
Zaid Yeganeh
unity (Ubuntu)
High
Unassigned
Oneiric
Undecided
Unassigned

Bug Description

I have noticed some problems with the range widgets present in the dash lens filters. The most notable examples here are the Size filter in the FIles and the Decade filter in the Music Lens.

I expect the functionality to work that I click on a one of the blocks (E.g. in the Decade filter I click on 80s) and it will only select that block. I then expect if I click the 70s block now both 70s and 80s would be selected. I then expect that if I click 70s again it would disappear leaving 80s still selected. I expect if I now click 60s it will select 60s and 80s (which was already selected) and also include 70s as it is covering the range.

Unfortunately, this behaviour does not happen. I have found that random blocks would be selected and unselected and I could not find a good way of reproducing this.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: unity 4.20.0-0ubuntu1
ProcVersionSignature: Ubuntu 3.0.0-12.19-generic 3.0.4
Uname: Linux 3.0.0-12-generic i686
.tmp.unity.support.test.0:

ApportVersion: 1.23-0ubuntu2
Architecture: i386
CompizPlugins: [core,bailer,detection,composite,opengl,decor,regex,resize,animation,gnomecompat,move,imgpng,grid,mousepoll,wall,compiztoolbox,fade,unitymtgrabhandles,snap,expo,place,scale,vpswitch,workarounds,ezoom,session,unityshell]
CompositorRunning: compiz
Date: Thu Sep 29 22:11:01 2011
DistUpgraded: Log time: 2011-07-13 12:27:27.246539
DistroCodename: oneiric
DistroVariant: ubuntu
DkmsStatus:
 virtualbox, 4.1.2, 3.0.0-10-generic, i686: installed
 virtualbox, 4.1.2, 3.0.0-11-generic, i686: installed
 virtualbox, 4.1.2, 3.0.0-12-generic, i686: installed
 virtualbox, 4.1.2, 3.0.0-9-generic, i686: installed
GraphicsCard:
 Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller [8086:2a42] (rev 07) (prog-if 00 [VGA controller])
   Subsystem: Lenovo Device [17aa:20e4]
   Subsystem: Lenovo Device [17aa:20e4]
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha i386 (20110202)
MachineType: LENOVO 7417CTO
PccardctlIdent:
 Socket 0:
   no product info available
PccardctlStatus:
 Socket 0:
   no card
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.0.0-12-generic root=UUID=70dfeb40-de6f-4ce0-9058-9ba257c3facd ro quiet splash drm.debug=0xe drm.debug=0xe vt.handoff=7
SourcePackage: unity
UpgradeStatus: Upgraded to oneiric on 2011-07-13 (78 days ago)
dmi.bios.date: 11/26/2009
dmi.bios.vendor: LENOVO
dmi.bios.version: 7UET81WW (3.11 )
dmi.board.name: 7417CTO
dmi.board.vendor: LENOVO
dmi.board.version: Not Available
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Not Available
dmi.modalias: dmi:bvnLENOVO:bvr7UET81WW(3.11):bd11/26/2009:svnLENOVO:pn7417CTO:pvrThinkPadT400:rvnLENOVO:rn7417CTO:rvrNotAvailable:cvnLENOVO:ct10:cvrNotAvailable:
dmi.product.name: 7417CTO
dmi.product.version: ThinkPad T400
dmi.sys.vendor: LENOVO
version.compiz: compiz 1:0.9.6+bzr20110929-0ubuntu1
version.libdrm2: libdrm2 2.4.26-1ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 7.11-0ubuntu3
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 7.11-0ubuntu3
version.xserver-xorg: xserver-xorg 1:7.6+7ubuntu7
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.6.0-1ubuntu13
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.99~git20110811.g93fc084-0ubuntu1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.15.901-1ubuntu2
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20110411+8378443-1

Related branches

Jono Bacon (jonobacon) wrote :
Didier Roche (didrocks) on 2011-09-30
Changed in unity:
milestone: none → 4.22.0
status: New → Triaged
Changed in unity (Ubuntu):
status: New → Triaged
Changed in unity:
importance: Undecided → Medium
Changed in unity (Ubuntu):
importance: Undecided → Medium
Changed in unity:
importance: Medium → High
Changed in unity (Ubuntu):
importance: Medium → High
tags: added: rls-mgr-o-tracking
Didier Roche (didrocks) on 2011-10-04
Changed in unity:
milestone: 4.22.0 → 4.24.0
Zaid Yeganeh (yeganeh) on 2011-10-07
Changed in unity:
assignee: nobody → Zaid Yeganeh (yeganeh)
Zaid Yeganeh (yeganeh) on 2011-10-07
Changed in unity:
status: Triaged → In Progress
Changed in unity (Ubuntu):
status: Triaged → In Progress
Neil J. Patel (njpatel) on 2011-10-12
Changed in unity (Ubuntu):
status: In Progress → Fix Committed
Changed in unity:
status: In Progress → Fix Committed
Omer Akram (om26er) on 2011-10-16
Changed in unity:
status: Fix Committed → Fix Released

Hello Jono, or anyone else affected,

Accepted unity into oneiric-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in unity (Ubuntu Oneiric):
status: New → Fix Committed
tags: added: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 4.24.0-0ubuntu2

---------------
unity (4.24.0-0ubuntu2) oneiric-proposed; urgency=low

  * Cherry-pick upstream:
    - SRU0-Regression: scrollbar displacement caused dash rows to show less
      icons (LP: #875023)
    - Really reverts the UI change that was still uploaded even if we had
      reverted it…

unity (4.24.0-0ubuntu1) oneiric-proposed; urgency=low

  * New upstream release and some cherry-pick:
    - compiz crashed with SIGSEGV in PluginClassHandler<UnityWindow,
      CompWindow, 0>::get() (LP: #864758)
    - unity panel menus don't stay open when clicked on second monitor
      (LP: #869196)
    - (oneiric) menu bar in wrong place and invisible (LP: #845856)
    - Lens range widgets do not function correctly (LP: #862996)
    - Cannot raise window from panel after minimize (LP: #863114)
    - unity-panel-service crashed with SIGSEGV in g_closure_invoke()
      (LP: #843280)
    - Windows get corrupted sometimes when semi-maximizing them. (LP: #865177)
    - Automaximization happens on unminimize (LP: #868930)
    - compiz crashed with SIGSEGV in nux::ROProperty<std::string>::operator
      std::string() (LP: #869109)
    - Dash - horizental divider line in between categories incorrectly drawn
      (LP: #841750)
    - F10 opens a random menu item when it should open the first one
      [regression] (LP: #862849)
    - Switching desktops after using showdesktop can cause hidden windows to
      become "active" (LP: #864503)
    - Clicking blank space on top panel doesn't raise maximized window to
      front (LP: #864708)
    - unity launcher loses track of deja-dup windows (LP: #865051)
    - Dash - App Lens 'Rating' filter behaves incorrectly (LP: #865482)
    - Launcher does not show on "Show desktop" (LP: #867959)
    - ibus character selection window not drawn (LP: #867885)
    - the dash's entry get wrongly colored on left or right key use
      (LP: #868434)
    - [ibus] Pressing down when ibus is active moves focus (LP: #872730)
    - Double-click on the dash top panel is taken effect on the window
      underneith (LP: #870844)
 -- Didier Roche <email address hidden> Tue, 18 Oct 2011 12:47:54 +0200

Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 4.24.0-0ubuntu2b1

---------------
unity (4.24.0-0ubuntu2b1) oneiric-proposed; urgency=low

  * No-change reupload because of broken powerpc build.

unity (4.24.0-0ubuntu2) oneiric-proposed; urgency=low

  * Cherry-pick upstream:
    - SRU0-Regression: scrollbar displacement caused dash rows to show less
      icons (LP: #875023)
    - Really reverts the UI change that was still uploaded even if we had
      reverted it…

unity (4.24.0-0ubuntu1) oneiric-proposed; urgency=low

  * New upstream release and some cherry-pick:
    - compiz crashed with SIGSEGV in PluginClassHandler<UnityWindow,
      CompWindow, 0>::get() (LP: #864758)
    - unity panel menus don't stay open when clicked on second monitor
      (LP: #869196)
    - (oneiric) menu bar in wrong place and invisible (LP: #845856)
    - Lens range widgets do not function correctly (LP: #862996)
    - Cannot raise window from panel after minimize (LP: #863114)
    - unity-panel-service crashed with SIGSEGV in g_closure_invoke()
      (LP: #843280)
    - Windows get corrupted sometimes when semi-maximizing them. (LP: #865177)
    - Automaximization happens on unminimize (LP: #868930)
    - compiz crashed with SIGSEGV in nux::ROProperty<std::string>::operator
      std::string() (LP: #869109)
    - Dash - horizental divider line in between categories incorrectly drawn
      (LP: #841750)
    - F10 opens a random menu item when it should open the first one
      [regression] (LP: #862849)
    - Switching desktops after using showdesktop can cause hidden windows to
      become "active" (LP: #864503)
    - Clicking blank space on top panel doesn't raise maximized window to
      front (LP: #864708)
    - unity launcher loses track of deja-dup windows (LP: #865051)
    - Dash - App Lens 'Rating' filter behaves incorrectly (LP: #865482)
    - Launcher does not show on "Show desktop" (LP: #867959)
    - ibus character selection window not drawn (LP: #867885)
    - the dash's entry get wrongly colored on left or right key use
      (LP: #868434)
    - [ibus] Pressing down when ibus is active moves focus (LP: #872730)
    - Double-click on the dash top panel is taken effect on the window
      underneith (LP: #870844)
 -- Martin Pitt <email address hidden> Tue, 25 Oct 2011 07:01:51 +0200

Changed in unity (Ubuntu Oneiric):
status: Fix Committed → Fix Released
To post a comment you must log in.